Avatars Not Showing up in 3.2.4

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
miltonsj
Registered User
Posts: 6
Joined: Tue Dec 04, 2018 4:27 am

Avatars Not Showing up in 3.2.4

Post by miltonsj » Tue Dec 04, 2018 4:38 am

Hello. My avatars do not show up when I upload them in phpBB. All that shows is a blank square with a blue question mark inside. I have changed the permissions on the images/avatars/upload folder to 777. The avatars worked in 3.2.3. I am not sure what has changed since then to cause them not to work. :?

Thanks in advance for your help.
"It feels better to love than hate."
--Stevie Wonder

User avatar
Lumpy Burgertushie
Registered User
Posts: 65328
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Avatars Not Showing up in 3.2.4

Post by Lumpy Burgertushie » Tue Dec 04, 2018 6:08 am

right click where one of the avatars that is not showing up should be. choose view image. see where it is looking for the image and it should tell you why it is not showing up.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
david63
Jr. Extension Validator
Posts: 15070
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Avatars Not Showing up in 3.2.4

Post by david63 » Tue Dec 04, 2018 6:33 am

Could it be a style related issue? Do you use the default prosilver style? If not then switch to prosilver and see if the problem persists.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

miltonsj
Registered User
Posts: 6
Joined: Tue Dec 04, 2018 4:27 am

Re: Avatars Not Showing up in 3.2.4

Post by miltonsj » Tue Dec 04, 2018 7:00 am

@robert
The location it is looking for the image is mydomain.com/board/download/file.php?avatar=2_1543895308.jpg
Shouldn't it be in the images/avatars/upload directory? I don't know how to change it to look in the proper directory.

@david63
I am using the default prosilver style. Thanks
"It feels better to love than hate."
--Stevie Wonder

User avatar
david63
Jr. Extension Validator
Posts: 15070
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Avatars Not Showing up in 3.2.4

Post by david63 » Tue Dec 04, 2018 7:09 am

Check your path settings in ACP > General > Avatar settings
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

miltonsj
Registered User
Posts: 6
Joined: Tue Dec 04, 2018 4:27 am

Re: Avatars Not Showing up in 3.2.4

Post by miltonsj » Tue Dec 04, 2018 7:37 am

All my path settings seem to be correct. Avatar storage path is images/avatars/upload.
My gallery path is images/avatars/gallery.

Thanks
"It feels better to love than hate."
--Stevie Wonder

User avatar
canonknipser
Registered User
Posts: 1713
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Avatars Not Showing up in 3.2.4

Post by canonknipser » Tue Dec 04, 2018 9:38 am

miltonsj wrote:
Tue Dec 04, 2018 7:00 am

The location it is looking for the image is mydomain.com/board/download/file.php?avatar=2_1543895308.jpg
Shouldn't it be in the images/avatars/upload directory?
That is the correct path - uploaded files (Attachments, avatars, ...) are handled by a special file wrapper which is download/file.php. The file wrapper has in your case a parameter for avatar handling and the file name of the avatar. The file wrapper then does lookup for the correct file in the expected folder . So, I would recommend to check
  1. is the file 2_1543895308.jpg present in the images/avatars/upload?
  2. can you open the file images/avatars/upload/2_1543895308.jpg with a image viewer (maybe the file is corrupted)?
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

miltonsj
Registered User
Posts: 6
Joined: Tue Dec 04, 2018 4:27 am

Re: Avatars Not Showing up in 3.2.4

Post by miltonsj » Wed Dec 05, 2018 4:24 am

Frank, the image is present in the uploads folder. I cannot open it with the image viewer because it just gives me a blank image.

I have tried other images, and they all do the same thing. What could be wrong here? :?

Thanks
"It feels better to love than hate."
--Stevie Wonder

User avatar
Lumpy Burgertushie
Registered User
Posts: 65328
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Avatars Not Showing up in 3.2.4

Post by Lumpy Burgertushie » Wed Dec 05, 2018 4:29 am

how about a link to a post that is affected please.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
canonknipser
Registered User
Posts: 1713
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Avatars Not Showing up in 3.2.4

Post by canonknipser » Wed Dec 05, 2018 7:03 am

miltonsj wrote:
Wed Dec 05, 2018 4:24 am
Frank, the image is present in the uploads folder. I cannot open it with the image viewer because it just gives me a blank image.
Maybe it was a misunderstanding - use your ftp access, browse the folder, download the file to your local computer (be sure to use binary mode for that) and try open it on your computer using a image viewer or image editor (like windows photo viewer, paint, photoshop, gimp, ...)


But first: did you check the folder and file permissions? Folder should be at least 755 (Write by owner, read by all other, enter folder for all), in doubt use 777 and files should be 644 or 666.
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

miltonsj
Registered User
Posts: 6
Joined: Tue Dec 04, 2018 4:27 am

Re: Avatars Not Showing up in 3.2.4

Post by miltonsj » Wed Dec 05, 2018 1:07 pm

Ok. I installed phpBB on a different web host, and my avatars are working. I don't know what was going on with the other one, but it all works now. I had checked my folder permissions and everything, but it still would not work.

Thanks to all who tried to help me out with this. I really appreciate it!
"It feels better to love than hate."
--Stevie Wonder

User avatar
Mick
Support Team Member
Support Team Member
Posts: 20375
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Avatars Not Showing up in 3.2.4

Post by Mick » Wed Dec 05, 2018 2:06 pm

Who were you hosted with and what package was it originally?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

miltonsj
Registered User
Posts: 6
Joined: Tue Dec 04, 2018 4:27 am

Re: Avatars Not Showing up in 3.2.4

Post by miltonsj » Wed Dec 05, 2018 9:06 pm

I have an unmanaged VPS with Ramnode. I have the 1024MB SKVMS package. They are a great provider, and this is the first time I have ever had a problem.
"It feels better to love than hate."
--Stevie Wonder

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: </Solidjeuh>, actane, fanmail, lopoto, panhead, Paul, Scanialady, Zanzazaar and 30 guests