Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
BigRed01
Registered User
Posts: 469
Joined: Mon Jan 24, 2005 9:26 am
Location: The upper midwest

Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by BigRed01 » Tue Dec 04, 2018 8:13 pm

What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? lsrcc.com
Who do you host your board with? hostgator
How did you install your board? download from phphbb.com
What is the most recent action performed on your board? disabling extensions
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? None that i remember
Do you have any extensions installed? no
What version of phpBB3 did you update from? phpBB 3.2.2 => 3.2.4
What extensions do you have installed?
What styles do you currently have installed? prosilver
What language(s) is your board currently using? en
Which database type/version are you using?php5.6
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? na
What password can be used to view this issue? Nona
What actions did you take (updating your board; installing a MOD, style or extension; etc.) I followed the automatic update instructions
Please describe your problem.

Trying to upgrade from 3.2.2-3.2.4 using the automatic update package. I don't think I've ever run into issues before like this and am not understanding how fix this. I've attached a screenshot

thanks
Attachments
phpbb.jpg

User avatar
warmweer
Registered User
Posts: 1473
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by warmweer » Tue Dec 04, 2018 8:53 pm

BigRed01 wrote:
Tue Dec 04, 2018 8:13 pm

What is the most recent action performed on your board? disabling extensions
...
Do you have any extensions installed? no

What actions did you take (updating your board; installing a MOD, style or extension; etc.) I followed the automatic update instructions
Please describe your problem.

Trying to upgrade from 3.2.2-3.2.4 using the automatic update package. I don't think I've ever run into issues before like this and am not understanding how fix this. I've attached a screenshot

thanks
3.2.2 >>> 3.2.4 is an update, not an upgrade.

There's conflicing information regarding extensions ? But it's good that you disabled extensions before updating!

The major error was to use the autoupdate. The autoupdate depends too much on write permissions on the host and can also suffer from timeouts.
For a simple update, the changed files package or the full package are the best ways to proceed.
The best thing to do is to use the full package. Read the instructions and follow these to the letter. In the cache directory, delete the installer and production directories, if present. In the store directory, delete io_lock.lock + any migrationsXXX files, if present.

Then go to install/app.php and use update database only.
After the succesful update, check if there are new versions for your extensions (might not be necessary)
A bug is a feature that hasn't made it to the manual (yet)

BigRed01
Registered User
Posts: 469
Joined: Mon Jan 24, 2005 9:26 am
Location: The upper midwest

Re: Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by BigRed01 » Wed Dec 05, 2018 6:20 pm

I'm not getting the update the database only option with the changed files
Last edited by BigRed01 on Wed Dec 05, 2018 6:28 pm, edited 1 time in total.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49749
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by stevemaury » Wed Dec 05, 2018 6:26 pm

Revert to your starting point using your backups and then follow this - https://www.phpbb.com/support/docs/en/3 ... ating-32x/
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
warmweer
Registered User
Posts: 1473
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by warmweer » Wed Dec 05, 2018 6:32 pm

BigRed01 wrote:
Wed Dec 05, 2018 6:20 pm
I'm not getting the update the database only with the changed files
Full package is the way to go in case of errors (you don't know what has been changed, added, removed).
Show a printscreen of what you are getting. IIRC you should be able to select update, then database only.
A bug is a feature that hasn't made it to the manual (yet)

BigRed01
Registered User
Posts: 469
Joined: Mon Jan 24, 2005 9:26 am
Location: The upper midwest

Re: Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by BigRed01 » Thu Dec 06, 2018 5:21 am

warmweer wrote:
Wed Dec 05, 2018 6:32 pm
BigRed01 wrote:
Wed Dec 05, 2018 6:20 pm
I'm not getting the update the database only with the changed files
Full package is the way to go in case of errors (you don't know what has been changed, added, removed).
Show a printscreen of what you are getting. IIRC you should be able to select update, then database only.
I'm starting over. I restored my files and database. I'll try it again and see what happens.

BigRed01
Registered User
Posts: 469
Joined: Mon Jan 24, 2005 9:26 am
Location: The upper midwest

Re: Issues Upgrading from 3.2.2-3.2.4 Using Automatic Upgrade Package

Post by BigRed01 » Sat Dec 08, 2018 12:16 pm

I ended up using the full package to make the update work. Thanks for the help!

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: </Solidjeuh>, actane, AllenGeen, EA117, fanmail, janus_zonstraal, lopoto, rudswa, Zanzazaar and 25 guests