Page 1 of 1

Error on extensions - Migrated site

Posted: Tue Dec 18, 2018 12:38 pm
by SteStory
Hi All,

Currently in the process of migrating my board over from one server to the other. I ran a fresh install on the new server, and restored the database from a backup taken from the old server.

All seems to have migrated over fine and the new board is working as normal.

However, the "extensions" tab is visible but gives an error when I try to click on it:

Code: Select all

Cannot find module ./../includes/acp/\phpbb\pages\acp\pages_module.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
I presume it's brought over info in the database restore of old extensions. I tried copying all the files over from /ext/ which then gave another longer error. I've not really any need or use for the old extensions I had on the old server anyway.

I found the "modission" file for removing old mods and permissions here: https://gist.github.com/3D-I/200b8541d5 ... 1cf0816819
and tried that, but I'm on 3.2.4 and I believe it's set to only 3.2.3, as I got the result: "phpBB version inappropriate so nothing can be deleted"

Is there a version or any way of just removing all the old extension data completely?

Regards

Re: Error on extensions - Migrated site

Posted: Tue Dec 18, 2018 12:44 pm
by david63
SteStory wrote:
Tue Dec 18, 2018 12:38 pm
any way of just removing all the old extension data completely?
Yes, disable and delete data from the ACP and then delete the files