Page 2 of 3

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 4:14 pm
by stevemaury
I assume you have updates of both files and database tucked safely away?

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 4:17 pm
by AngelM
stevemaury wrote:
Tue Jan 08, 2019 4:14 pm
I assume you have updates of both files and database tucked safely away?
I have an update prior to doing the first update from 3.2.4 to 3.2.5. I have no save an update of all the restores. :shock:

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 4:23 pm
by GanstaZ
I think there was a similar issue some time ago, but i can't find it. It was related to litespeed server, but at the same time this issue can be related to cache like was mentioned on previous page.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 4:51 pm
by AngelM
GanstaZ wrote:
Tue Jan 08, 2019 4:23 pm
I think there was a similar issue some time ago, but i can't find it. It was related to litespeed server, but at the same time this issue can be related to cache like was mentioned on previous page.
I was think that same thing. It's almost like when you come into the forum and see old cache...then you refresh you are being redirected to the new cache. I know nothing about what I am talking about...but it just makes since that it has something to do with that. But why all of a sudden did it happen is the question of the day.

Thanks for your response.

Angel

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 5:00 pm
by GanstaZ
Only one thing comes to mind, is that some settings have been changed by someone from team or host.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 5:35 pm
by warmweer
AngelM wrote:
Tue Jan 08, 2019 4:11 pm
Praying you or someone can figure this out.
It does sound like a cookie-problem (although from what I read, that seems OK).
Check the ACP and report the php-version please.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 6:08 pm
by AngelM
warmweer wrote:
Tue Jan 08, 2019 5:35 pm
AngelM wrote:
Tue Jan 08, 2019 4:11 pm
Praying you or someone can figure this out.
It does sound like a cookie-problem (although from what I read, that seems OK).
Check the ACP and report the php-version please.
PHP 5.6.39
Board Version 3.2.4

Thanks!

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 9:48 pm
by warmweer
AngelM wrote:
Tue Jan 08, 2019 4:11 pm
When LP restored back to 3.2.4 the first time the forum ran as normal... no issues.
Do you still have that exact backup, or only the backup of the second 3.2.4 restore they did?

Also (just random thoughts now) is it a possibility that your certificate was removed and not restored, is outdated, or corrupt?
I take it you have emptied the cache a couple of times already (if not, do it, either through the ACP or manually, in this last case don't delete index.htm and .htaccess )
You could also try changing the cookie_name in the config_table (and check whether cookie_secure is marked as enabled (1) in the config_table).

If you're comfortable with a personal webserver, I'ld install a copy of your board (3.2.4) on localhost, test it, update to 3.2.5, test again. If you can stay logged in on localhost, then you can exclude a problem with the database (you might have to set cookie_secure to off on localhost).

Just tested with test account again. Only the 2 board index links and your header are affected. All the other links let Joe stay logged in (visibly). I can't find any cookie set though.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Tue Jan 08, 2019 11:39 pm
by AngelM
warmweer wrote:
Tue Jan 08, 2019 9:48 pm
AngelM wrote:
Tue Jan 08, 2019 4:11 pm
When LP restored back to 3.2.4 the first time the forum ran as normal... no issues.
Do you still have that exact backup, or only the backup of the second 3.2.4 restore they did?

Also (just random thoughts now) is it a possibility that your certificate was removed and not restored, is outdated, or corrupt?
I take it you have emptied the cache a couple of times already (if not, do it, either through the ACP or manually, in this last case don't delete index.htm and .htaccess )
You could also try changing the cookie_name in the config_table (and check whether cookie_secure is marked as enabled (1) in the config_table).

If you're comfortable with a personal webserver, I'ld install a copy of your board (3.2.4) on localhost, test it, update to 3.2.5, test again. If you can stay logged in on localhost, then you can exclude a problem with the database (you might have to set cookie_secure to off on localhost).

Just tested with test account again. Only the 2 board index links and your header are affected. All the other links let Joe stay logged in (visibly). I can't find any cookie set though.
Let me see what I can do with the info you gave me. I really don't know much about doing this kind of stuff...so have to Google or work through it. I may not get back to you until tomorrow. But thank you very much for your time and checking things out.

Just a thought... I have a testboard that is doing the same thing. I wonder if you could check that out with permissions set for you to see what you need to see through ACP. It doesn't matter if that board gets crashed because there isn't much on it as I just use it for testing things.

Thanks again!

Kathy

EDIT: Forgot to say that the backup I have is after the first restore. The forum was running perfectly after then. I did a backup of the board before I did the update again. After that update the board went back to being the the OP said. I just can't figure out how to put the backup in because LP sent me an email with the name of the backup, but when I go to the control panel I don't see it there. UGH!

I don't know how to know if the certificate is corrupt etc.

I've cleared cache numerous times. I was afraid to do it through FTP because I was afraid I would delete the wrong things.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Wed Jan 09, 2019 8:10 am
by warmweer
AngelM wrote:
Tue Jan 08, 2019 11:39 pm
Just a thought... I have a testboard that is doing the same thing. I wonder if you could check that out with permissions set for you to see what you need to see through ACP. It doesn't matter if that board gets crashed because there isn't much on it as I just use it for testing things.
OK, a bit busy today but send me the info in a PM (Leaving now and will only be back this evening)
AngelM wrote:
Tue Jan 08, 2019 11:39 pm
EDIT: Forgot to say that the backup I have is after the first restore. The forum was running perfectly after then. I did a backup of the board before I did the update again. After that update the board went back to being the the OP said. I just can't figure out how to put the backup in because LP sent me an email with the name of the backup, but when I go to the control panel I don't see it there. UGH!
OK, so if that backup can be found the board can be restored to the bugfree 3.2.4.
Use FTP and look in the /store directory of your board - if you made it with the phpBB backup feature then it 's either stored there or you downloaded it.
If you have that backup (made by the board) somewhere else, you could copy the file to the /store, and use the phpBB restore feature.
AngelM wrote:
Tue Jan 08, 2019 11:39 pm
I've cleared cache numerous times. I was afraid to do it through FTP because I was afraid I would delete the wrong things.
In the /cache directory, delete everything EXCEPT for index.htm and .htaccess.
Should you delete those 2 by accident, just copy them back from another directory, no harm done.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Wed Jan 09, 2019 11:45 pm
by AngelM
warmweer wrote:
Wed Jan 09, 2019 8:10 am
AngelM wrote:
Tue Jan 08, 2019 11:39 pm
Just a thought... I have a testboard that is doing the same thing. I wonder if you could check that out with permissions set for you to see what you need to see through ACP. It doesn't matter if that board gets crashed because there isn't much on it as I just use it for testing things.
OK, a bit busy today but send me the info in a PM (Leaving now and will only be back this evening)
PM Sent

AngelM wrote:
Tue Jan 08, 2019 11:39 pm
EDIT: Forgot to say that the backup I have is after the first restore. The forum was running perfectly after then. I did a backup of the board before I did the update again. After that update the board went back to being the the OP said. I just can't figure out how to put the backup in because LP sent me an email with the name of the backup, but when I go to the control panel I don't see it there. UGH!
OK, so if that backup can be found the board can be restored to the bugfree 3.2.4.
Use FTP and look in the /store directory of your board - if you made it with the phpBB backup feature then it 's either stored there or you downloaded it.
If you have that backup (made by the board) somewhere else, you could copy the file to the /store, and use the phpBB restore feature.
Lunarpages sent me some information that I am trying to figure out. I made the backup from my cPanel at Lunarpages. I figured out how to get a zip of the backup. But they are wanting me to do a bunch of other stuff before I do anything with the backup. I will refer back here if I can't figure that part out.

AngelM wrote:
Tue Jan 08, 2019 11:39 pm
I've cleared cache numerous times. I was afraid to do it through FTP because I was afraid I would delete the wrong things.
In the /cache directory, delete everything EXCEPT for index.htm and .htaccess.
Should you delete those 2 by accident, just copy them back from another directory, no harm done.
I did this last night and it didn't change anything as far as the board problems go... or at least anything I can see. But, this same problem is on the testboard, so you should be able to see it all in action.

Sorry I am using colored text, but I thought it would be easier for you to see each part I am answering to since there are so many parts to this.

Thank you very much for your help.

Angel


Re: Need to refresh to see current posts after 3.2.5 update

Posted: Thu Jan 10, 2019 6:58 am
by david63
Is your test board on the same server as your production board? If it is and you are having the same problem on both then it could point to a server set up problem - especially with this
warmweer wrote:
Tue Jan 08, 2019 9:48 pm
I can't find any cookie set though.

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Thu Jan 10, 2019 7:33 am
by AngelM
david63 wrote:
Thu Jan 10, 2019 6:58 am
Is your test board on the same server as your production board? If it is and you are having the same problem on both then it could point to a server set up problem - especially with this
warmweer wrote:
Tue Jan 08, 2019 9:48 pm
I can't find any cookie set though.
Yes it is. I also have another forum and it's having the same issue after the update.
https://www.marvelousartworks.com/ideas ... /index.php

I just enabled a notice for cookies.

Thanks for responding.

Angel

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Thu Jan 10, 2019 7:45 am
by david63
AngelM wrote:
Thu Jan 10, 2019 7:33 am
I just enabled a notice for cookies.
Sorry but I don't understand what you mean by that

Re: Need to refresh to see current posts after 3.2.5 update

Posted: Thu Jan 10, 2019 8:16 am
by GanstaZ
To clear some thoughts, set up a fresh 3.2.5 version and test it or better setup a fresh 3.2.x that is lower than 5 and test again. It seems to be server related or there's a second layer cache.