Fatal error: Uncaught Twig_Error_Loader

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 7:57 pm

im instaling a new forum and it runs eel but sunndely i get an erro after uploading som avatars

Code: Select all

Fatal error: Uncaught Twig_Error_Loader: Unable to find template "index_body.html" (looked into: ). in /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:232 Stack trace: #0 /customers/8/1/0/aspie-forum.dk/httpd.www/phpbb/template/twig/loader.php(135): Twig_Loader_Filesystem->findTemplate('index_body.html') #1 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(150): phpbb\template\twig\loader->findTemplate('index_body.html') #2 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Environment.php(330): Twig_Loader_Filesystem->getCacheKey('index_body.html') #3 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Environment.php(424): Twig_Environment->getTemplateClass('index_body.html') #4 /customers/8/1/0/aspie-forum.dk/httpd.www/phpbb/template/twig/environment.php(277): Twig_Environment->loadTemplate('index_body.html', NULL) #5 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Environment.php(363): in /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 232
Whats wrong ??
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2364
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by kinerity » Sat Jan 26, 2019 8:19 pm

Try clearing the cache and uploading fresh copies of the vendor and phpbb folders. Also, please fill out the Support Request Template and post it back here to enable us to assist you better.
Kailey Truscott - Community Team

User avatar
lopoto
Registered User
Posts: 106
Joined: Thu Feb 12, 2015 3:13 pm

Re: Fatal error: Uncaught Twig_Error_Loader

Post by lopoto » Sat Jan 26, 2019 8:19 pm

clear cache

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:21 pm

venter ???

I have cleard cache
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2364
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by kinerity » Sat Jan 26, 2019 8:24 pm

Jesper Møller wrote:
Sat Jan 26, 2019 8:21 pm
venter ???
:oops: vendor
Kailey Truscott - Community Team

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:28 pm

Thanks .. ill try
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:29 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.5
What is your board's URL? http://Aspi-forum.dk
Who do you host your board with? one.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? Prosilver_se
What language(s) is your board currently using? Danish
Which database type/version are you using? MariaDB
What is your level of experience? New to PHP but not phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I installde PHPBB and it rund ok. (Installed in root folder)
i then uploade some avatar with FTP to the gallery
Please describe your problem. After i oploade avatars to the gallery i go to the index board and get this error the ACP runs ok

Fatal error: Uncaught Twig_Error_Loader: Unable to find template "index_body.html" (looked into: ). in /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Loader/Filesystem.php:232 Stack trace: #0 /customers/8/1/0/aspie-forum.dk/httpd.www/phpbb/template/twig/loader.php(135): Twig_Loader_Filesystem->findTemplate('index_body.html') #1 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Loader/Filesystem.php(150): phpbb\template\twig\loader->findTemplate('index_body.html') #2 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Environment.php(330): Twig_Loader_Filesystem->getCacheKey('index_body.html') #3 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Environment.php(424): Twig_Environment->getTemplateClass('index_body.html') #4 /customers/8/1/0/aspie-forum.dk/httpd.www/phpbb/template/twig/environment.php(277): Twig_Environment->loadTemplate('index_body.html', NULL) #5 /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Environment.php(363): in /customers/8/1/0/aspie-forum.dk/httpd.www/vendor/twig/twig/lib/Twig/Loader/Filesystem.php on line 232
Generated by SRT Generator
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:35 pm

reloading the vendor didn't help
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:38 pm

can it be this #0 /customers/8/1/0/aspie-forum.dk/httpd.www/phpbb/template/twig/loader.php(135)
i have installe all in the root don't see/have a phpbbFolder
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
Lumpy Burgertushie
Registered User
Posts: 66741
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Lumpy Burgertushie » Sat Jan 26, 2019 8:42 pm

if you don't have a phpbb folder inside the phpBB3 folder then that is your problem.

if your board is the root of your site then you should have a folder named phpbb in there to.

remember phpbb and phpBB are not the same thing.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:49 pm

So www.aspie-forum.dk/pbpbb/ ??

will the link www.aspie-forum.dk open that ??
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:51 pm

it workd for 30 min and works in the root on local machine

I simply oploade all files and folder to the root
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 8:53 pm

Lumpy Burgertushie wrote:
Sat Jan 26, 2019 8:42 pm
if you don't have a phpbb folder inside the phpBB3 folder then that is your problem.
robert
I don't have a php3 folder ??
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69367
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by KevC » Sat Jan 26, 2019 9:11 pm

One of the folders that is part of the phpBB3 download is called /phpbb

That needs to be in the server with the other files and folder of your installation
Attachments
Screenshot 2019-01-26 at 21.09.41.png
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Jesper Møller
Registered User
Posts: 239
Joined: Wed Jul 05, 2006 1:00 pm
Location: Copenhagen Denmark
Name: Jesper G.O. Møller
Contact:

Re: Fatal error: Uncaught Twig_Error_Loader

Post by Jesper Møller » Sat Jan 26, 2019 9:20 pm

Thanks .. ill try to start allover with a fresh download
"Education is learning what you didn't even know you didn't know!"

"True knowledge exists in knowing that you know nothing."

Post Reply

Return to “[3.2.x] Support Forum”