PHPBB and PHP versions

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
shaidyn
Registered User
Posts: 3
Joined: Sun Jun 09, 2013 9:52 pm

PHPBB and PHP versions

Post by shaidyn »

Hi there,

I'm using Yahoo Small Business, and I recently tried to upgrade my PHPBB from 3.0.x to 3.2.x. I deleted the old files and copied in the new ones. But when I went to the site, I got this message:

"You are running an unsupported PHP version. Please upgrade to PHP 5.4.0 or higher before trying to install or update to phpBB 3.2"

Which is pretty self explanatory. I then went to the yahoo small business php updater, and was told that 5.3.6 is the highest version of php I can use. So I'm now stuck with a non-operational forum.

Does anyone know what the highest version of PHPBB I'll be able to use with the version of php that's been forced upon me? Thanks.
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: PHPBB and PHP versions

Post by A_Jelly_Doughnut »

According to their knowledge base, Yahoo Small Business hosting supports PHP 7.2.6, which will work with phpBB 3.2. https://help.smallbusiness.yahoo.net/s/article/SLN20660
You just have to jump through a few hoops to get there: https://help.smallbusiness.yahoo.net/s/article/SLN20661
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
User avatar
warmweer
Jr. Extension Validator
Posts: 5355
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: PHPBB and PHP versions

Post by warmweer »

shaidyn wrote:
Fri Feb 01, 2019 3:36 am
... So I'm now stuck with a non-operational forum.

Does anyone know what the highest version of PHPBB I'll be able to use with the version of php that's been forced upon me? Thanks.
Not if you have a backup.
And I actually doubt your database was modified because the requirement check is the first thing done before any database changes are made.
If this is the case you could just put back the phpBB files (of your versions).
And since you're at 3.0.? , you should update to 3.0.14 if you haven't already.

You should also read Upgrading from 3.0 to 3.2 (where point 1, 2 and 3 could have helped in avioding your current predicament.

Also YSB writes
Yes, you can enhance your web site with a powerful, fully customizable bulletin board package. The PHP-based phpBB utility allows you to create an online community on your web site. You can easily administrate the bulletin board using phpBB's straightforward interface and useful help documentation.

For assistance and more information about phpBB, try the phpBB Community web site, which includes a link to download the latest version and installation instructions.
It's not clear to me whether this is an automatic installation with YSB supplied files or an self installation with original phpBB files which you downloaded.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68124
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: PHPBB and PHP versions

Post by Lumpy Burgertushie »

that looks like the description that the auto installer on the host uses. doesn't look like anything phpbb has ever put out for that purpose.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
Post Reply

Return to “[3.2.x] Support Forum”