Going back to 3.1.9?

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Tithenon
Registered User
Posts: 55
Joined: Mon Mar 08, 2010 3:51 pm
Name: Paul Emerson

Going back to 3.1.9?

Post by Tithenon » Fri Feb 08, 2019 5:00 pm

Hey, does anyone know if I can go back to running prosilver 3.1.9 and Latte 3.1.9 while I'm in 3.2.5? Will that cause any major problems on the forum?

These guys (phpBB and Arty) have really screwed the quoting system and the line spacing system. However, I can't go back to 3.1.10 because my players have added too many posts to the game and it would take a while for me to get back there, plus I don't know if the database is backwards compatible. 3.1.10, except for some MINOR security issues, was really the pinnacle of this software as far as I can tell, and I would like the phpBB crew to go back to 3.1.10 and start over. Just fix the security issues, don't take away the ability to quote properly, with names in the quote blocks, no matter what the style/theme version, nor screwing up line spacing. 99% of the users of phpBB use some manner of theme for their forum site; will there ever be true support for those themes?

I know you guys do this in your spare time, and I know you likely don't make a whole lot of money off of it, and if you're trying to sour the milk, so to speak, so you can STOP doing this, then that's fine... just let us know that support will be ending 100% at a particular date, to give us time to transition back or forward. I appreciate all of the work you've done, and I've used phpBB for all of my forums for the past... what... 15 years... and I would love to keep using it.

Thank you.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68868
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Going back to 3.1.9?

Post by KevC » Fri Feb 08, 2019 5:03 pm

Only if you have a database backup from before you went to 3.2.5 and then you would also lose everything posted since.

Might be easier to post in the Wanted forum for someone to add the names and spacing you want to the style you're using.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Tithenon
Registered User
Posts: 55
Joined: Mon Mar 08, 2010 3:51 pm
Name: Paul Emerson

Re: Going back to 3.1.9?

Post by Tithenon » Fri Feb 08, 2019 6:02 pm

Thanks, KevC. I have those old database backups, from the past five years, once every three months at a minimum. None of this is going to be easy, is it.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68868
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Going back to 3.1.9?

Post by KevC » Fri Feb 08, 2019 8:17 pm

It's just a case of putting your old board back up instead.

Seems a bit drastic just for the lack of a quoted author. That seems like the easier thing to fix if you can find someone to code it because they can probably just lift the right bit from prosilver.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Tithenon
Registered User
Posts: 55
Joined: Mon Mar 08, 2010 3:51 pm
Name: Paul Emerson

Re: Going back to 3.1.9?

Post by Tithenon » Sat Feb 09, 2019 4:28 am

Well, I can't afford to have anyone code it, and I don't know enough about coding it, myself. I dearly love to use Latte, but the same thing that makes me love it -the beautiful automation side- is also the thing that is part of the problem. I did not get the line break problem or the lack of quoted author problem until I upgraded to 3.2.5, while leaving Latte alone. There were no warnings, when I was upgrading, that anything would be wrong with Latte and, when I read about the changes to Latte it didn't seem like I needed to change anything. I have gone through God knows how many upgrades, since 2.0.8 I guess, maybe 6, and have NEVER had a problem with this. Latte broke only after I upgraded to phpBB 3.2.5. I have since tried to upgrade to Latte 3.2.5 because someone told me that would fix a host of problems. Not only did it NOT fix ANYTHING, it broke several other things, jumbled the posting page all over hell and gone so I have to scroll up to get to the button bar...

No, this is a phpBB 3.2.5 issue; all of them are. Of course, I can't prove it, but I didn't fix helicopters in the Army and not figure out basic troubleshooting, and my troubleshooting instinct here is that one or more new coders were added to the team and they started gutting code they THOUGHT no one ever used, but which has affected a great deal, in actuality.

As for the quoted author issue... the players of my role-playing game PbF and I have come to rely on being able to quote and answer multiple authors in a single post, and it's VERY important -to allay confusion of who's speaking in a quote- to have those names there. I cannot put an =Character Name in either the opening quote tag or in the opening ooc tag, because neither of them show up. Before I upgraded to Latte 3.2.5 I could at least see the first quoted poster's name, but now I have to put [b][i]Character's Name[/i][/b]: AFTER the opening quote tag and BEFORE the opening out-of-character (ooc) tag, if there is one. My players are in Finland, Germany, Great Britain, and on the East Coast, West Coast, and here in Texas with me, and of the seven only two have a clue what I'm talking about when I mention the words opening and closing tag. It took me a LONG time to teach, re-fresh, and re-teach those who don't understand because they're too old and/or are not coders to get them to use the OOC tags without having to worry about also putting in Character Spaces. Four of the seven are writers, but only one of those understands what white space on a paper is used for, and in our game you need white space to separate quotes, ooc posts, and lists. If I have a group of players who post, and then one comes on later to post, they SHOULD be able to quote ALL of those players posts and respond to them individually, but then another player, or one of the others comes on and reads and they can't remember who's speaking at the time because the character name does not show up in the post, anywhere, unless it's shoe-horned in between tags.

If I eliminate Latte 3.2.5 and go back to Latte 3.1.9, I can fight with the Character Spaces between one open/close tag and another, between list items, instead of the behavior that NEVER should have been changed, because it WASN'T BROKEN, where I can hit Enter twice between tag groups and get my space, and I can hit it three times to get the proper space between my bullet points in my lists. I can also see at least the first person quoted in a tag group, quote or ooc.

As I have my old databases saved up, and if there's a way for me to download the database entries only after I updated from 3.1.10, then maybe I could go back to 3.1.10, import the old database, and then import the entries since 3.1.10 was replaced. That way, I don't have a database that's expecting 3.2.5 when all I have is 3.1.10. Is there a way to do that... only grab a fragment from a particular date and re-upload everything, then import what's missing? Oops... I've also been re-writing rules, re-categorizing things to make it easier for my players to read and understand, I've started two new threads and added three new character journals, etc., etc.

What a friggin' mess.

Oh, and if I could afford to have someone re-code these things for me, what happens when the next version comes down... do I just stick with what I've got, or MUST I have that fix for the security issue called out that justified the new version?

There is no other forum software that can do what phpBB does... can I have my line spaces and quotes back, please?

User avatar
david63
Jr. Extension Validator
Posts: 15770
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Going back to 3.1.9?

Post by david63 » Sat Feb 09, 2019 8:16 am

Tithenon wrote:
Sat Feb 09, 2019 4:28 am
this is a phpBB 3.2.5 issue
I would ask the question - do things work correctly with the default prosilver style? If so then it is not a "phpBB 3.2.5 issue" but a style issue which should be addressed to the style author.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68868
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Going back to 3.1.9?

Post by KevC » Sat Feb 09, 2019 10:42 am

Tithenon wrote:
Sat Feb 09, 2019 4:28 am
Well, I can't afford to have anyone code it, and I don't know enough about coding it, myself.
Until you ask, you don't know the cost. It might be a 5 minute job (I'm not a coder either but it might be).
Tithenon wrote:
Sat Feb 09, 2019 4:28 am
There were no warnings, when I was upgrading, that anything would be wrong with Latte
That's why it's prudent to do a test before you do it for real.
Tithenon wrote:
Sat Feb 09, 2019 4:28 am
Is there a way to do that... only grab a fragment from a particular date and re-upload everything, then import what's missing
That is horrifically more complicated than fixing the style.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 3813
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Going back to 3.1.9?

Post by HiFiKabin » Sat Feb 09, 2019 11:39 am

I have just tested quoting with latte on phpBB 3.2.5 and I can not see any problem. All authors are quoted correctly.
screenshot_35.png
If you are seeing something different then I suggest that either phpBB 3.2.5 is not installed correctly, Latte is not installed correctly, or there is a conflict with an extension you have installed.

User avatar
david63
Jr. Extension Validator
Posts: 15770
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Going back to 3.1.9?

Post by david63 » Sat Feb 09, 2019 2:30 pm

HiFiKabin wrote:
Sat Feb 09, 2019 11:39 am
If you are seeing something different then I suggest that either phpBB 3.2.5 is not installed correctly, Latte is not installed correctly, or there is a conflict with an extension you have installed.
... or the versions of phpBB and Latte are not compatible
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50251
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Going back to 3.1.9?

Post by stevemaury » Sat Feb 09, 2019 10:34 pm

Well, he does have version 3.2.5 of Latte installed, but I cannot confirm his phpBB version. I can confirm that the upgrade was not performed in accordance with the instructions from here, as prosilver is still at 3.1.12.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50251
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Going back to 3.1.9?

Post by stevemaury » Sat Feb 09, 2019 10:40 pm

Please confirm that your version of phpBB is correctly upgraded to 3.2.5 by posting the output of this SQL ( Executing SQL Queries in phpMyAdmin ). If your table prefix is not phpbb_ change accordingly

Code: Select all

SELECT config_value FROM phpbb_config WHERE config_name = 'version'
If the output is indeed "3.2.5", then please install and activate prosilver version 3.2.5, implement it, and see whether the problem remains. If it does not, then this is not a phpBB issue, but rather a custom style issue. If it does, we are happy to try top help you further.

I am moving this to Support, which is more appropriate and where it will get greater exposure.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Tithenon
Registered User
Posts: 55
Joined: Mon Mar 08, 2010 3:51 pm
Name: Paul Emerson

Re: Going back to 3.1.9?

Post by Tithenon » Sun Feb 10, 2019 6:59 am

HiFiKabin wrote:
Sat Feb 09, 2019 11:39 am
I have just tested quoting with latte on phpBB 3.2.5 and I can not see any problem. All authors are quoted correctly.

screenshot_35.png

If you are seeing something different then I suggest that either phpBB 3.2.5 is not installed correctly, Latte is not installed correctly, or there is a conflict with an extension you have installed.
This is what I get from one of my posters...

Image

Holy crap, I really don't want to have to re-upload everything. I did exactly as the instructions provided, saved the right directories and the config.php file, destroyed the forum on my cPanel File Manager for 3.1.10, then uploaded everything new for 3.2.5, did the database update as required, deleted the install folder, the re-uploaded the directories and config.php the way the instructions say to do. Latte 3.1.9 came next... holy crap, I think I know what the problem was and, in this case it would be my fault. I think I forgot to change the default style back to prosilver, make sure all of my accounts were changed off it as well, unload Latte Red, then unload Latte, then do all that other stuff, upload phpBB 3.2.5 and everything else to follow. I wonder, at 12:46 am, if that's what I needed to do?
stevemaury wrote:
Sat Feb 09, 2019 10:40 pm
Please confirm that your version of phpBB is correctly upgraded to 3.2.5 by posting the output of this SQL ( Executing SQL Queries in phpMyAdmin ). If your table prefix is not phpbb_ change accordingly

Code: Select all

SELECT config_value FROM phpbb_config WHERE config_name = 'version'
If the output is indeed "3.2.5", then please install and activate prosilver version 3.2.5, implement it, and see whether the problem remains. If it does not, then this is not a phpBB issue, but rather a custom style issue. If it does, we are happy to try top help you further.

I am moving this to Support, which is more appropriate and where it will get greater exposure.
I am running the correct version of phpBB, 3.2.5.

Alright, it's really late, I was supposed to be in bed two hours ago, I really do appreciate everyone's help with this. I have done research in other places with this problem, including looking at Gaby's forum for Latte, and there are no answers to be had, there. However, there are other problems involved, with both the style and phpBB. I will have to wait until Monday, but I think the only thing I've missed, which I've never had to do, before, was to remove everyone from the style to the base style so the database sees it that way, then tearing everything down and rebuilding it. Until Monday, folks.

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 3813
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Going back to 3.1.9?

Post by HiFiKabin » Sun Feb 10, 2019 9:45 am

Just do all of this EXACTLY as described and in the order specified. Once you have make sure the upgrade is complete (ie files replaced and database updated without errors) then try the quote function (nb existing quotes will still not show correctly) Once you have confirmed that the quote function is correct, upload a NEW set of Latte files, activate the style and test. THEN re enable and/or update any extensions you have.

IMPORTANT:- Un Zip the downloads on your PC and upload them with a proper FTP client. DO NOT do it through your cPanel

Notes:
  • Your server must be running at least PHP 5.4.7 or higher.
  • phpBB 3.2 is not completely backwards compatible with 3.1 and custom edits may no longer work. The easiest upgrade method is to remove all existing files prior to upgrading and re-applying custom changes after verifying their correctness.

    To upgrade, perform the following steps:
  1. Make a back-up of the original files and database
  2. Deactivate all styles except for prosilver
  3. Deactivate any extensions which are not compatible with phpBB 3.2. Check with the extension author to find out if an extension is compatible or not.
  4. Ensure that the activated spambot countermeasure is one of the standard phpBB plugins (Simple image, GD image, GD 3D image, Q&A, reCaptacha).
  5. Set British English as the only language pack and delete all other language pack directories from your server
  6. Delete all of your phpBB files EXCEPT for the following:
    • The config.php file
    • The /ext/ directory
    • The /images/ directory
    • The /files/ directory
    • The /store/ directory
  7. Upload the contents of the phpBB3 directory from the uncompressed 3.2.x Full Package (EXCEPT for config.php) into your forum's directory (Note: you don't want to overwrite your original config.php file)
  8. Browse to www.example.com/install/
  9. Click the Update tab
  10. Click the Update button
  11. Select "Update database only" and click Submit
  12. Wait for the progress bar to reach 100% and for a message indicating that the update has completed
  13. Delete or rename the /install/ directory

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50251
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Going back to 3.1.9?

Post by stevemaury » Sun Feb 10, 2019 2:51 pm

OP wrote:then uploaded everything new for 3.2.5,
No point in crying over spilled milk, but if you had done that, the prosilver files would be from 3.2.5 and they aren't.

Are you by chance trying to upload files using the cPanel File Manager? That is a recipe for disaster. You should be using FTP.

How, exactly, are you able to confirm that your database version is 3.2.5? Is that being reported in the ACP?

Anyway, if you would install and activate prosilver, we could see whether it is an upgrade problem, a style problem, or something else.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Tithenon
Registered User
Posts: 55
Joined: Mon Mar 08, 2010 3:51 pm
Name: Paul Emerson

Re: Going back to 3.1.9?

Post by Tithenon » Mon Feb 11, 2019 1:02 am

HiFiKabin wrote:
Sun Feb 10, 2019 9:45 am
Just do all of this EXACTLY as described and in the order specified.
I will do exactly these things step-by-step... I have taken a screenshot and printed it out as my checklist, and that's exactly what I'm going to do. I've done this since either 2.0.8 or 2.0.6 and never had these sorts of problems is all I'm saying.
stevemaury wrote:
Sun Feb 10, 2019 2:51 pm
No point in crying over spilled milk, but if you had done that, the prosilver files would be from 3.2.5 and they aren't.
Not helpful.
Are you by chance trying to upload files using the cPanel File Manager? That is a recipe for disaster. You should be using FTP.
Nope, I use an FTP.
How, exactly, are you able to confirm that your database version is 3.2.5? Is that being reported in the ACP?
Yes. The SQL query I was given doesn't work, and I followed the instructions there, too.
Anyway, if you would install and activate prosilver, we could see whether it is an upgrade problem, a style problem, or something else.
I intend to knock that out first thing tomorrow morning.

Again, my friends, thank you all for your help... Please understand that I do not recall EVER having this sort of trouble with phpBB, EVER! So, this is new for me and, admittedly, frustrating. I'm not a php guru, but the games I use phpBB to run are extremely important to me, so having a software package I've ALWAYS been able to count on suddenly go wonky on me is strange; I've had things go wrong before, but not like this, and they've been my fault and I've fixed them, but not like this.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Exabot [Bot] and 29 guests