"New Topic" Button Disappears after Login

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Dr_jinG
Registered User
Posts: 26
Joined: Fri Sep 02, 2016 6:23 am

"New Topic" Button Disappears after Login

Post by Dr_jinG » Wed Mar 13, 2019 5:43 am

First, thanks to everyone working on this free forum software. I'm very grateful for it, and am excited about finally turning my idea into reality! I do not have a coding background (unless you consider Basic programming in the 80s and G-coding in the 90s as qualifying), so a lot of the technical background to understand all of this is missing in my resume. ;)

Problem: When I go to my site as a guest, and click on a forum (sub-forum?), I can see the New Topic button. But when I log in (either as administrator or with my personal account), the button is no longer available. Results are the same on my phone as on my PC. I found another member post with this problem, but I didn't find an answer. Thank you, in advance!

Here is the info from the form:
Support Request Template
What version of phpBB are you using? phpBB 3.2.5
What is your board's URL? http://techparentz.com
Who do you host your board with? Bluehost
How did you install your board? I used a tool provided by my host
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? ProSilver
What language(s) is your board currently using? English (British)
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Created forums a month ago, but did not try to add a topic until now.
Please describe your problem. When I view the site as a guest, I see the "New Topic" button. When I click it and log in, the button is no longer available. I've logged in under Admin and my regular login, and the behavior is the same between them.
Generated by SRT Generator

User avatar
Lumpy Burgertushie
Registered User
Posts: 65886
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: "New Topic" Button Disappears after Login

Post by Lumpy Burgertushie » Wed Mar 13, 2019 6:14 am

probably a group permissions problem.

guests usually do not have the permission to start a new topic or even reply. the default permission for registered users is normally that you can start a new topic and reply to topics.

everybody that is not in the guest group is supppsed to be in the registered user group.
the only person that should be in the guest group is the anonymous user and the anonymous user should not be in any group other than the guest group.

did you by change delete the anonymous user and or take yourself out of the registered user group?


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
david63
Jr. Extension Validator
Posts: 15588
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: "New Topic" Button Disappears after Login

Post by david63 » Wed Mar 13, 2019 6:16 am

Dr_jinG wrote:
Wed Mar 13, 2019 5:43 am
How did you install your board? I used a tool provided by my host
This may be part of the problem as these "one click" installs use modified files. You should be using the files downloaded from this site
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Dr_jinG
Registered User
Posts: 26
Joined: Fri Sep 02, 2016 6:23 am

Re: "New Topic" Button Disappears after Login

Post by Dr_jinG » Wed Mar 13, 2019 2:53 pm

Lumpy Burgertushie wrote:
Wed Mar 13, 2019 6:14 am
probably a group permissions problem.

guests usually do not have the permission to start a new topic or even reply. the default permission for registered users is normally that you can start a new topic and reply to topics.

everybody that is not in the guest group is supppsed to be in the registered user group.
the only person that should be in the guest group is the anonymous user and the anonymous user should not be in any group other than the guest group.

did you by change delete the anonymous user and or take yourself out of the registered user group?


robert
Thank you for your reply, Robert. I didn't make any changes to users. I'll look for permissions, via ACP, and see if there's something wonky there. Thank you for the tip!

User avatar
Dr_jinG
Registered User
Posts: 26
Joined: Fri Sep 02, 2016 6:23 am

Re: "New Topic" Button Disappears after Login

Post by Dr_jinG » Wed Mar 13, 2019 7:23 pm

david63 wrote:
Wed Mar 13, 2019 6:16 am
Dr_jinG wrote:
Wed Mar 13, 2019 5:43 am
How did you install your board? I used a tool provided by my host
This may be part of the problem as these "one click" installs use modified files. You should be using the files downloaded from this site
Thank you, David. We'll see what needs done. If I have to do a full deletion and install, i'll see if I can figure out what needs doing. Cheers!

User avatar
Dr_jinG
Registered User
Posts: 26
Joined: Fri Sep 02, 2016 6:23 am

Re: "New Topic" Button Disappears after Login

Post by Dr_jinG » Thu Mar 14, 2019 4:40 am

I checked permissions, and updated them as seemed sensible, but I still don't see the New Topic button when logged in as either administrator or a user name I created as a "registered user". Here's what I see through ACP:

https://imgur.com/HRmKIRz

Any other ideas on what might be wrong?

Thanks!

User avatar
Lumpy Burgertushie
Registered User
Posts: 65886
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: "New Topic" Button Disappears after Login

Post by Lumpy Burgertushie » Thu Mar 14, 2019 5:02 am

go back to the admin panel.
check on forum permissions, choose any of the forums, choose the registered usergroup on the next page it should say standard access

if it does not, change it so that it does. If it says standard access then go back and check on forum roles and and on the line for standard access click
on the green cog on the far right side.
on that page make sure that everything but the top two and the last one and the one for ignore flood are all checked yes. that should be the default settings.

save/apply

go back to the main page of the admin panel, click on purge the cache

go back and see if you can see the new topic and/or reply buttons.
if none of that works for you you could make my account I just setup a admin and I will fix it for you. you can then delete that account.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Dr_jinG
Registered User
Posts: 26
Joined: Fri Sep 02, 2016 6:23 am

Re: "New Topic" Button Disappears after Login

Post by Dr_jinG » Thu Mar 14, 2019 5:34 am

Thank you, Robert. I did as you said, and permissions were wrong for users, and admins and mods had no permissions. I set permissions, purged cache, and get the same result...

Thank you for your offer! I set your Administrative permissions to User and Groups Admin. Does that work?

User avatar
Dr_jinG
Registered User
Posts: 26
Joined: Fri Sep 02, 2016 6:23 am

FIXED: "New Topic" Button Disappears after Login

Post by Dr_jinG » Thu Mar 14, 2019 3:47 pm

And it looks like I'm all fixed up! Still lots to learn about the phpBB environment and which permissions do what, but I'm super grateful for the software, the help of this forum, and in particular Lumpy Burgertushie (Robert)!

Cheers, all!

User avatar
david63
Jr. Extension Validator
Posts: 15588
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: "New Topic" Button Disappears after Login

Post by david63 » Thu Mar 14, 2019 4:05 pm

And I would still recommend that you replace the current files with those from this site as experience has shown that sooner or later you will have problems that cannot be resolved
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Mick
Support Team Member
Support Team Member
Posts: 20711
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: "New Topic" Button Disappears after Login

Post by Mick » Fri Mar 15, 2019 9:34 am

And support for such installs is limited.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: canonknipser, Mats_o, MosesTM, PixelFool and 21 guests