Forum phpbb3 3.2.4 Been down days restored backups same issue

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Sun Apr 14, 2019 9:36 pm

Hi I may have damaged my 3.2.4 forum 2 weeks ago when I attempted an update to 3.2.5 and got errors. I may not have followed the process correctly on what folders to keep and which ones to delete on the server etc. after that I attempted to purged the cache I got an AJAX error which which then resulted in a 505 error on the Index. I could use some things in the control panel but forum is still down. When I restore from backups (I was away too much time elapsed between backup)I can view the forum posts etc. but the moment I get back into ACP and attempt purge or go to Index it happens again in all my full site backups as well. I cleared browser cache etc . tried new fresh install with 3.2.5 and then importing sql database backup with data but that didn't work either. I had/have two extensions: Board Announcements and Stop Forum Spam. IN ACP clicking Forums Tab results in 505 error just like index does.

Code: Select all

ERROR LOGS:

[14-Apr-2019 20:43:42 UTC] PHP Parse error:  syntax error, unexpected end of file, expecting '(' in /home4/bathouse/public_html/forum/vendor/twig/twig/lib/Twig/Node/Expression/Function.php on line 18
[14-Apr-2019 20:43:47 UTC] PHP Parse error:  syntax error, unexpected end of file in /home4/bathouse/public_html/forum/vendor/twig/twig/lib/Twig/Template.php on line 605
[14-Apr-2019 21:13:24 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:15:28 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:15:30 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:15:31 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:15:32 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:21:53 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in 


/home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:22:02 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223

/home4/bathouse/public_html/forum/adm/error_log:
[14-Apr-2019 14:29:08 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 19:40:18 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 20:22:36 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:19:53 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php on line 5223
[14-Apr-2019 21:22:37 UTC] PHP Catchable fatal error:  Object of class phpbb\log\log could not be converted to string in /home4/bathouse/public_html/forum/phpbb/textformatter/s9e/factory.php on line 177


Tried this too on found on support forum:
"Re: Catchable Fatal Error
Unread post by mriggins » Thu Jul 06, 2017 3:24 am

I figured it out.

I removed everything from /cache except .htaccess and index.htm. The board loads properly now.

Looking at Customize in ACP, I can see all the old extensions there, with "Enable" (Because I deleted the data in phpbb_ext) so I will attempt to remove them via ftp now that cache has been cleared and see if it still works after that.
Last edited by thecoalman on Mon Apr 15, 2019 1:45 am, edited 1 time in total.

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3160
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by thecoalman » Mon Apr 15, 2019 1:47 am

hoarybat wrote:
Sun Apr 14, 2019 9:36 pm
Looking at Customize in ACP, I can see all the old extensions there, with "Enable" (Because I deleted the data in phpbb_ext) so I will attempt to remove them via ftp now that cache has been cleared and see if it still works after that.
Were they enabled before all this happened?

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Mon Apr 15, 2019 9:31 pm

Extensions? Yes they were enabled. Btw that quote was not from me but was a post on phpbb3 support forum by someone having a similar issue..Thanks

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3160
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by thecoalman » Mon Apr 15, 2019 11:09 pm

hoarybat wrote:
Mon Apr 15, 2019 9:31 pm
Extensions? Yes they were enabled. Btw that quote was not from me but was a post on phpbb3 support forum by someone having a similar issue..Thanks
For future reference if you are going to quote something from someone else use the quote box so it's easily identified as quote. Providing a link to what you are quoting is also useful.

Is the error logs also part of the quote?

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Wed Apr 17, 2019 12:24 pm

Hi thecoalman no that error is what I receive from my server log when attempting to go to the board index (main page of forum).

User avatar
tbackoff
Former Team Member
Posts: 7022
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by tbackoff » Wed Apr 17, 2019 1:05 pm

Have you tried uploading a fresh vendor folder from 3.2.4? https://www.phpbb.com/files/release/phpBB-3.2.4.zip
Flying is the second best thrill to cheerleaders; being caught is the first.

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Wed Apr 17, 2019 7:33 pm

What a coincidence I was thinking about trying just that, deleting the vendor folder and uploading a fresh 3.2.4 vendor. so thanks will do it asap. and chime back.

User avatar
MarkDHamill
Registered User
Posts: 3780
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by MarkDHamill » Thu Apr 18, 2019 6:56 pm

This is probably a poorly written extension. However, disabling the extension doesn't necessarily solve the problem. The problem is the log_data column in the phpbb_logs table is either blank or contains a string in JSON meant to be interpreted as an array. So you will see these if you look in phpBB's log. Something like this:

a:2:{i:0;s:10:"2019-04-17";i:1;s:2:"21";}

whereas what may end up is a string of text.

If you don't care what's in the log, the simplest solution is to use phpMyAdmin to truncate (empty) the table.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Wed Apr 24, 2019 12:46 pm

Hi Mark! I tried your suggestion maybe I did it wrong? I went into phpbb_log and emptied everything then purged the cache and Got 500 white page of death after Index. Thanks for your reply.
Last edited by hoarybat on Wed Apr 24, 2019 1:18 pm, edited 2 times in total.

User avatar
MarkDHamill
Registered User
Posts: 3780
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by MarkDHamill » Wed Apr 24, 2019 12:53 pm

I only know about this stuff because I was recently troubleshooting my digests extension, so I needed to use phpBB's add log function. Strings that need to show up in the log have to be wrapped inside of an array, otherwise you get the error you describe.

Example, this would work:

Code: Select all

						$this->phpbb_log->add('admin', $this->user->data['user_id'], $this->user->ip, 'LOG_CONFIG_DIGESTS_BAD_DIGEST_TYPE', false, array($row['user_digest_type'], $row['username']));
but this would not:

Code: Select all

						$this->phpbb_log->add('admin', $this->user->data['user_id'], $this->user->ip, 'LOG_CONFIG_DIGESTS_BAD_DIGEST_TYPE', false, $row['user_digest_type'] .  $row['username']);
If the fifth argument is used, it must be an array.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Wed Apr 24, 2019 1:29 pm

Mark, each time I get the 500 error on index to recover I go into CPANEL file mgr. and delete my forum main directory (which on mine is named forum not phpbb3) and copy/restore my working backup of the forum directory and then I am able to index the forum no problem at least until I do a Purge of cache in ACP. What I don't understand is how can/do recover from latter step enabling me to Index as I thought there was no writing done in the forum directy only the SQL database? Obviously I'm ignorant about this. How did this start? Well I had errors cuz I did the update wrong when attempting to update to 3.2.5 from my current 3.2.4 maybe that is what happened dunno.
Last edited by hoarybat on Wed Apr 24, 2019 1:37 pm, edited 1 time in total.

User avatar
MarkDHamill
Registered User
Posts: 3780
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by MarkDHamill » Wed Apr 24, 2019 1:34 pm

I often find that manually deleting the contents of /cache folder, then refreshing a phpBB page can solve issues. Sometimes there are issues with permissions. The cache folder should have 777 permissions, but they don't always seem to take properly. The production folder may not have it and sometimes the twig folder ends up with 755 permissions. Sometimes manually deleting the cache with the file manager of FTP and fixing any file or directory permissions that aren't 777 solves problems.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Wed Apr 24, 2019 1:40 pm

Yes I did delete them via FTP and I put 777 write permissions on everything in cache folder and cache folder itself still a NOGO. Would you be open to taking a look via my CPANEL or anyone here who as more knowledge than me? We are a small hobby community: bathouseforum.org/forum
Last edited by hoarybat on Wed Apr 24, 2019 1:47 pm, edited 1 time in total.

User avatar
MarkDHamill
Registered User
Posts: 3780
Joined: Fri Aug 02, 2002 12:36 am
Location: Florence, MA USA
Contact:

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by MarkDHamill » Wed Apr 24, 2019 1:45 pm

Your problem is somewhere else. Like Wordpress, when you have issues like this it's best to keep things simple: disable extensions, make sure you have the current version of the file installed (upload a reference version) and then slowly enable features. That might give a clue to where the problem lies. There is usually evidence for the cause of HTTP 500 errors in the PHP or web server logs. It can be stupid stuff, like a file was not uploaded properly with FTP. I had that happen for a client recently: their FTP server was so unreliable that a zero length file was uploaded and that caused the issue.

While I do help out from time to time on these forums, I don't provide free support. Sorry.
Get the latest versions of my Digests and Smartfeed extensions.
Need phpBB services or a phpBB consultant? I offer most phpBB services.

hoarybat
Registered User
Posts: 66
Joined: Tue Jul 22, 2008 11:23 pm

Re: Forum phpbb3 3.2.4 Been down days restored backups same issue

Post by hoarybat » Wed Apr 24, 2019 1:51 pm

Thanks yes I disabled all extensions but still the the 500 on index and forums. Thanks for trying Mark. I wonder if I could do a fresh install of 3.1.4 and then import the SQL database backup to that. Thought I already did and got the same error.

Post Reply

Return to “[3.2.x] Support Forum”