Not able to log in anymore after update to 3.2.6

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Neverlands
Registered User
Posts: 47
Joined: Thu Sep 05, 2002 12:06 am
Location: Vienna / Austria
Contact:

Re: Not able to log in anymore after update to 3.2.6

Post by Neverlands » Thu May 02, 2019 9:56 pm

EA117 wrote:
Wed May 01, 2019 1:41 pm
Hopefully this might be a useful summary of what is expected.

With the release of phpBB 3.2.6, performing a login now requires a "form token", and results in "the submitted form is invalid" when those form token fields don't exist. The primary login forms in the phpBB 3.2.6 proSilver style were updated to include these form tokens, but if you're using a non-proSilver style the login forms on your board may not attempt to include these form tokens in the login forms. Note this can happen even if your style is proSilver-based and inherits from proSilver, since your style may have overridden and replaced the templates that define the login forms. In addition to all that, there were also some login forms in phpBB 3.2.6 proSilver which mistakenly did not get updated, and those need to be fixed as well.

To fix the known login issues while keeping phpBB 3.2.6:
...
Thank you so much - you saved my live :D

omeroon
Registered User
Posts: 22
Joined: Thu Apr 26, 2018 1:39 pm

Re: Not able to log in anymore after update to 3.2.6

Post by omeroon » Fri May 10, 2019 3:14 pm

</Solidjeuh> wrote:
Mon Apr 29, 2019 2:16 pm
I have updated to 3.2.6 RC.1 , but we have no style changes from 3.2.6 RC.1 to 3.2.6. So looks like where missing some changes then.

EDIT

I'm using the "quick login" extension.
I needed to add add_form_key('login', '_LOGIN'); in listner.php
And {{ S_FORM_TOKEN_LOGIN }} in quick_login.html

So it's working now ;)
This got me on the right track, maybe it helps someone else too allthough I don't have a solution yet (apart from changing the link to the separate login page).

I am using the Metro templateset, which was recently updated (May 1). Metro features a "quick login popup thingy" on every page, however the form token is only rendered on the index (probably because that is the only place where the add_form_key() is added in the code of the pages itself. The template variable is there, but it just isn't rendered on other pages.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21435
Joined: Fri Aug 29, 2008 9:49 am
Location: Not watching cricket

Re: Not able to log in anymore after update to 3.2.6

Post by Mick » Fri May 10, 2019 3:40 pm

Anybody with similar issues please start your own topic as this one is marked as solved (Image) thanks.
"The more connected we get the more alone we become" - Kyle Broflovski

Post Reply

Return to “[3.2.x] Support Forum”