Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
hurghanico
Registered User
Posts: 67
Joined: Mon May 07, 2018 10:59 am

Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by hurghanico » Sun May 05, 2019 2:41 pm

Hi, by using the automatic update package method and following all the given instructions during the procedure yesterday I udated my board from 3.2.5 to 3.2.6 and today from 3.2.6 to 3.2.7, purged the cache each time, but now I get the following message if I log in from the home (index.php) page: "The submitted form was invalid. Try submitting again." which brings me directly to the user login page (ucp.php) where finally I can log in successfully.

The address of my board is: https://allabouthd500x.altervista.org

The theme is based on prosilver which I modded time ago just for the colors and icons, and I added some ads in the index_body.html, viewforum_body.html and viewtopic_body.html pages, no other mods I made.

Until now I updated the board as soon as new stable releases were at disposal, but this is the first time I have this problem.

What can I do to fix it?

User avatar
david63
Registered User
Posts: 16720
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by david63 » Sun May 05, 2019 2:49 pm

hurghanico wrote:
Sun May 05, 2019 2:41 pm
The theme is based on prosilver which I modded time ago just for the colors and icons, and I added some ads in the index_body.html, viewforum_body.html and viewtopic_body.html pages, no other mods I made.
You will need to update your style with the changes in 3.2.6 & 3.2.7
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Prosk8er
Registered User
Posts: 1444
Joined: Sun Mar 12, 2006 3:30 am
Location: Rochester, NY
Name: Tyler
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by Prosk8er » Sun May 05, 2019 2:50 pm

did you update your style? compare it to prosilver cause some of those files you mentioned were updated to fix that problem


User avatar
hurghanico
Registered User
Posts: 67
Joined: Mon May 07, 2018 10:59 am

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by hurghanico » Sun May 05, 2019 3:19 pm

david63 wrote:
Sun May 05, 2019 2:49 pm
hurghanico wrote:
Sun May 05, 2019 2:41 pm
The theme is based on prosilver which I modded time ago just for the colors and icons, and I added some ads in the index_body.html, viewforum_body.html and viewtopic_body.html pages, no other mods I made.
You will need to update your style with the changes in 3.2.6 & 3.2.7
I thought that the automatic update method which I chose to use and finished successfully served exactly to update all the necessary files while keeping my mods. that is, it should have been a fairly quick operation to do everything.

But at this point it is clear that this is not the case.

Where can I find instructions or useful references to know what to do to update the style with the changes made in 3.2.6 and 3.2.7?

User avatar
</Solidjeuh>
Registered User
Posts: 1732
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by </Solidjeuh> » Sun May 05, 2019 3:31 pm


User avatar
hurghanico
Registered User
Posts: 67
Joined: Mon May 07, 2018 10:59 am

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by hurghanico » Sun May 05, 2019 3:33 pm

Prosk8er wrote:
Sun May 05, 2019 2:50 pm
did you update your style? compare it to prosilver cause some of those files you mentioned were updated to fix that problem
I updated everything by using the automatic update package method and when asked during the procedure I downloaded the changed/updated files and uploaded them back into my board, everyting went fine, after that the database has been updated successfully and the procedure ended, after that I purged the cache.

Before starting the automatic update procedure I didn't know that I had to update also the style manually.

User avatar
hurghanico
Registered User
Posts: 67
Joined: Mon May 07, 2018 10:59 am

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by hurghanico » Sun May 05, 2019 3:35 pm

</Solidjeuh> wrote:
Sun May 05, 2019 3:31 pm
Thanks for the reference, I'll see what to do.

User avatar
david63
Registered User
Posts: 16720
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by david63 » Sun May 05, 2019 4:29 pm

hurghanico wrote:
Sun May 05, 2019 3:19 pm
I thought that the automatic update method which I chose to use and finished successfully served exactly to update all the necessary files while keeping my mods. that is, it should have been a fairly quick operation to do everything.
The automatic update will only update phpBB core files - it will not, and never has, update custom files
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
EA117
Registered User
Posts: 1082
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by EA117 » Sun May 05, 2019 5:40 pm

Looking at the quick login form at the bottom of https://allabouthd500x.altervista.org/, it confirms that the login form has the fields needed for login, just as phpBB 3.2.7 intended.

Indeed, phpBB 3.2.6 had made a change which required updating styles which did not directly use the proSilver-provided login forms. No auto-update or full package installation would have avoided that, since those non-proSilver files that needed updated were not phpBB-delivered files.

But phpBB 3.2.7 eliminates the login template change dependency, and will "inject" the correct login fields even if you have not yet made the needed changes to the style. You still "want to make those style changes" as soon as possible, so that the style will be ready for when the template changes are mandatory again in some future release.

But in phpBB 3.2.7 itself, absence of those style changes would not explain "I still get invalid form when attempting to login." And looking at the quick login form at the bottom of https://allabouthd500x.altervista.org/, it indeed has the correct login fields needed for login. Is that because it's working now, or do you still have an issue with "form invalid" when attempting to login directly from the index page?

If there is still an issue, I think the next step will be to provide you with an updated functions.php which will perform some informational logging, in order to better understand the nature of the "form invalid" error that is still being encountered.

User avatar
</Solidjeuh>
Registered User
Posts: 1732
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by </Solidjeuh> » Sun May 05, 2019 5:43 pm

I had to make 2 edits in the Quick login ext
viewtopic.php?f=556&t=2509981&p=15243291#p15243291

casualmind
Registered User
Posts: 16
Joined: Wed Apr 03, 2019 5:02 am

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by casualmind » Sun May 05, 2019 5:55 pm

Go to your Styles > Inherits your style into prosilver.

User avatar
EA117
Registered User
Posts: 1082
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by EA117 » Sun May 05, 2019 5:58 pm

</Solidjeuh> wrote:
Sun May 05, 2019 5:43 pm
I had to make 2 edits in the Quick login ext
viewtopic.php?f=556&t=2509981&p=15243291#p15243291
Good point on whether there is actually an extension involved, and needed to adjust extension-specific templates if they provide login forms.

However when I said "quick login" -- and what I thought I was seeing on https://allabouthd500x.altervista.org/ page (it's disabled right now) -- I was referring to standard "login directly from the index page" login fields defined in the standard index_body.html template. Not something enabled with an extension. i.e. "Quick" as in not having to invoke the "Login" link first; not "Quick Login" as in the name of an extension.

User avatar
hurghanico
Registered User
Posts: 67
Joined: Mon May 07, 2018 10:59 am

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by hurghanico » Sun May 05, 2019 6:08 pm

EA117 wrote:
Sun May 05, 2019 5:40 pm
looking at the quick login form at the bottom of https://allabouthd500x.altervista.org/, it indeed has the correct login fields needed for login. Is that because it's working now, or do you still have an issue with "form invalid" when attempting to login directly from the index page?
I still have the same issue, I haven't updated any style files till now, I'm still trying to remember which files I modded time ago to make the site appear like it is, in order to realize which updated style files need to be simply uploaded as they are and which of them need instead to be modded again before uploading.

User avatar
EA117
Registered User
Posts: 1082
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Updated from 3.2.6 to 3.2.7 problem logging in from the home page

Post by EA117 » Sun May 05, 2019 6:24 pm

Well, if you're willing, the attached functions.php generates informational messages into the normal phpBB "User" log, visible from ACP Maintenance tab. This functions.php is otherwise 3.2.7, and all the changes are confined to the add_form_key() and check_form_key() functions.

Ideally, do this with a test user account created for this purpose & deleted afterwards, so that you can have zero reservations about sharing the data logged during their login attempts.

On success you're expecting to see a pair of messages similar to:

Code: Select all

{Add form key for "login" created form token based on time "1557077384" + salt "0b0ool15uelo1qse" + form "login" + sid "cf66f21872918d1f55211148a948dddc".}
{Check form key for "login" SUCCESS based on time "1557077384" + salt "0b0ool15uelo1qse" + form "login" + sid "cf66f21872918d1f55211148a948dddc".}
And errors could terminate with any of the following types of messages instead:

Code: Select all

{Check form key for "login" FAILED based on time "1557077384" + salt "0b0ool15uelo1qse" + form "login" + sid "cf66f21872918d1f55211148a948dddc".}	
{Check form key for "login" FAILED due to time delta between creation time "1557077384", current time "1557077390", and allowed time span "7200".}	
{Check form key for "login" failed because the form token field is missing.}	
{Check form key for "login" failed because the creation time field is missing.}	
{Check form key for "login" failed because both the creation time and form token fields are missing.}
So you would apply this updated /includes/functions.php, perform one or two of the failed logins and then perhaps a successful login for comparison, put the original unmodified phpBB 3.2.7 /includes/functions.php back on your board, and then go into ACP Maintenance and view the Users log and report all the informational lines that were logged in your failure and success cases.

EDIT: Updated attached functions.php to hash selected output fields, to reduce unnecessary clear-text exposure of internal info. Just in case anyone else downloading this debug functions.php cannot limit the logged information to "just a test user that I deleted afterwards."
Attachments
functions.php
(158.96 KiB) Downloaded 16 times

Post Reply

Return to “[3.2.x] Support Forum”