Phpbb 3.2.7 does not install with php 7.3

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
WelshPaul
Registered User
Posts: 303
Joined: Tue Aug 19, 2014 2:09 pm

Re: Phpbb 3.2.7 does not install with php 7.3

Post by WelshPaul » Tue Jul 16, 2019 9:02 pm

It's kind of ironic that the phpBB team always recommend that one update to the latest version of phpBB and even refuse to help users of older versions other than to "update" or "upgrade" and yet when there are newer versions of "php" or "MySQL" and phpBB is lagging behind one is greeted with a "whats the rush to update" attitude. :roll:

User avatar
warmweer
Registered User
Posts: 2374
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Phpbb 3.2.7 does not install with php 7.3

Post by warmweer » Tue Jul 16, 2019 9:08 pm

WelshPaul wrote:
Tue Jul 16, 2019 9:02 pm
It's kind of ironic that the phpBB team always recommend that you update to the latest version of phpBB and even refuse to help users of older versions other than to update or upgrade and yet when there are newer versions of php or MySQL one is greeted with a "whats the rush to update" attitude. :roll:
Isn't it ironic that your post contains misleading info?
phpBB offers support for all versions of 3.2. Support for 3.1, 3.0 and even 2.x is limited to support for upgrading. And it is completely natural that the general advice/recommendation is to use the latest stable version. (Try getting support for Vista or earlier, even Win7).

Added: BTW support for phpBB3.1 continued long after the release of phpBB 3.2.0 and ample warning was given that support for 3.1 would cease at a certain date.
My board's not broken, it just went peculiar

User avatar
Lumpy Burgertushie
Registered User
Posts: 66482
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Phpbb 3.2.7 does not install with php 7.3

Post by Lumpy Burgertushie » Tue Jul 16, 2019 9:42 pm

as does support for recent versions of php mysql etc.

every software reaches end of life at some point. no company can be expected to support old versions of its software forever.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

aszilagyi
Registered User
Posts: 6
Joined: Tue Feb 09, 2016 6:24 pm

Re: Phpbb 3.2.7 does not install with php 7.3

Post by aszilagyi » Fri Jul 19, 2019 8:15 am

Debian 10 Buster has been released on July 7. It comes with php 7.3.4 out of the box.
People with Debian 10 servers cannot use phpBB 3.2.7 unless they do some wizardry to downgrade their php or go back to phpBB 3.2.5 which doesn't check for php version. BTW it seems to run fine with php 7.3.

User avatar
</Solidjeuh>
Registered User
Posts: 1684
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Phpbb 3.2.7 does not install with php 7.3

Post by </Solidjeuh> » Fri Jul 19, 2019 8:24 am

aszilagyi wrote:
Fri Jul 19, 2019 8:15 am
BTW it seems to run fine with php 7.3.
Nope, see your server logs.

aszilagyi
Registered User
Posts: 6
Joined: Tue Feb 09, 2016 6:24 pm

Re: Phpbb 3.2.7 does not install with php 7.3

Post by aszilagyi » Fri Jul 19, 2019 9:12 am

</Solidjeuh> wrote:
Fri Jul 19, 2019 8:24 am
Nope, see your server logs.
I don't see any errors in the logs, and from my limited testing, the forum works fine.
Maybe there is some rarely used function that wouldn't work.

Post Reply

Return to “[3.2.x] Support Forum”