Page 1 of 2

Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 11:03 am
by kamaleon
Hello,

When I try to update one of my boards I get this error

No valid update directory was found, please make sure you uploaded the relevant files.

I am sure I have uploaded the files.

What else to do?

Thanks

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 11:11 am
by janus_zonstraal
I am sure I have uploaded the files.
What files did you upload?
I think the wrong one's

Better use this method
https://www.phpbb.com/support/docs/en/3 ... ating-32x/

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 11:39 am
by kamaleon
Yes, this is the method I used.

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 11:47 am
by janus_zonstraal
Maybe something from a previous attempt?

Try to delete the installer folder in the cache folder
and io_lock.lock and something like install.php in the store folder

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 12:41 pm
by david63
I have had that message on every update that I have ever done - I just ignore it and carry on, and have never had any problems.

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 3:46 pm
by EA117
david63 wrote:
Sat May 11, 2019 12:41 pm
I have had that message on every update that I have ever done - I just ignore it and carry on, and have never had any problems.
+1

I assumed that was the message which simply meant or confirmed "you're not using an update package", to confirm why only "Update database" was being offered by the installer instead of any file-related actions. i.e. We're seeing it because we're using the Full Package method.

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 3:51 pm
by kamaleon
I reuploaded the files and the message disappeared and did the update successfully.

Now the board is not loading. This is a test board.

I am worried about the production one now...

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 3:54 pm
by janus_zonstraal
Now the board is not loading.
What do you mean with "not load"?

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 4:05 pm
by kamaleon
a 500 http error when I click on login.

If I am not logged in, it works...

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 4:36 pm
by EA117
This is potentially what you're looking for in setting up the test board; if an particular extension or other change you use on your production board has an issue with the later phpBB version, now is when you can identify that condition ahead of time.

The 500 error means something failed in a way which doesn't even let phpBB handle or report the error, and the error will actually be reported by the web server itself. (e.g. in the Apache error log, which might be just an error log in your main site directory, or might be something you access through your hosting control panel.)

The error log will tell of a particular failure, a particular PHP call stack, or a particular configuration issue, etc., that resulted in the 500 status. That's the next clue to look for: What did the web server say the cause of this 500 status was? You can include the latest log entries here for input on what kind of issue they're reporting.

It might turn out to be something more unique and limited to "just your test environment." Or it might be a clue of something you'll now know to address ahead of time and avoid when updating the production server. (e.g. An updated extension that needs to be installed before updating to phpBB 3.2.7, or similar.)

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 4:49 pm
by Lumpy Burgertushie
quite often this is caused when using the autoupdate or when not deleting the old files before you upload the new ones when using the full package method.

try the full package update again. remove all the old files except for the config.php file and the folders mentioned in the instructions.

if you have already run the database update then remove the install folder and test.


robert

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 8:54 pm
by kamaleon
I have already updated the database, so what do I do?

I upload the files again and remove the install folder?

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 9:45 pm
by Lumpy Burgertushie
yes, the folder named install.
also, check the folder named store remove any and all files with migration in the name and anything that looks like install config in the name.

robert

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sat May 11, 2019 9:55 pm
by kamaleon
Done and still not working...

Re: Error updating from 3.2.5 to 3.2.7

Posted: Sun May 12, 2019 9:38 am
by kamaleon
I tried the update with another board and it is not even loading now.

Followed the update guide line by line...

Anyone got it to work from 3.2.5 to 3.2.7????