10 year old upgrade? Possible???

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
ziska
Registered User
Posts: 12
Joined: Sun May 20, 2007 9:22 pm

10 year old upgrade? Possible???

Post by ziska » Wed May 15, 2019 11:43 am

Forum which hasn't had phpbb updated in about.... oh.... 10 years?

http://www.aspenmurals.com/forum/

"Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /data/14/1/56/110/1871436/user/2033194/htdocs/aspenmurals/forum/common.php:29 Stack trace: #0 /data/14/1/56/110/1871436/user/2033194/htdocs/aspenmurals/forum/index.php(26): include() #1 {main} thrown in /data/14/1/56/110/1871436/user/2033194/htdocs/aspenmurals/forum/common.php on line 29"

Would love to save the mountains of information on the board.
Many members would like to see it functional again.

User avatar
WelshPaul
Registered User
Posts: 298
Joined: Tue Aug 19, 2014 2:09 pm

Re: 10 year old upgrade? Possible???

Post by WelshPaul » Wed May 15, 2019 11:50 am

That function no longer exists in PHP 7 - Downgrade to php 5 and then upgrade your phpBB

ziska
Registered User
Posts: 12
Joined: Sun May 20, 2007 9:22 pm

Re: 10 year old upgrade? Possible???

Post by ziska » Wed May 15, 2019 12:28 pm

Sigh.... I can downgrade to 5.0 but not one website at a time which means that the 5 other databases on the hosting package will be broken because they need 7.0 ....

Does anyone have an idea of how to do this without downgrading to 5.0- rebuilding 6 web databases and then upgrading and rebuilding again?

User avatar
Prosk8er
Registered User
Posts: 1444
Joined: Sun Mar 12, 2006 3:30 am
Location: Rochester, NY
Name: Tyler
Contact:

Re: 10 year old upgrade? Possible???

Post by Prosk8er » Wed May 15, 2019 12:41 pm

get a database backup and copy the website forum files and install a older version of xampp with php 5 do the upgrade locally

do you know what version of phpbb it was

*just looked at the site looks like your on phpBB2
Last edited by Prosk8er on Wed May 15, 2019 12:46 pm, edited 1 time in total.

User avatar
david63
Registered User
Posts: 16067
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: 10 year old upgrade? Possible???

Post by david63 » Wed May 15, 2019 12:43 pm

ziska wrote:
Wed May 15, 2019 12:28 pm
Does anyone have an idea of how to do this without downgrading to 5.0- rebuilding 6 web databases and then upgrading and rebuilding again?
Install Xampp on your local machine, copy the database from your production board onto your local machine and run the upgrade from there.

These should help

Knowledge Base - Installing and Setting Up Your Own Web Server
Knowledge Base - Transferring Your Board to a New Host or Domain
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

ziska
Registered User
Posts: 12
Joined: Sun May 20, 2007 9:22 pm

Re: 10 year old upgrade? Possible???

Post by ziska » Wed May 15, 2019 12:53 pm

Thank you Xampp looks like a lifesaver

Prosk8er
probably phpbb 2.0 but I'm still trying to get through the "new" network solutions hosting dashboard to some real information... and breathing deeply...

Prosk8er and david63
Which version of Xampp?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69035
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: 10 year old upgrade? Possible???

Post by KevC » Wed May 15, 2019 1:04 pm

Yes it's phpBB2
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
AmigoJack
Registered User
Posts: 5569
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: 10 year old upgrade? Possible???

Post by AmigoJack » Wed May 15, 2019 4:02 pm

ziska wrote:
Wed May 15, 2019 12:53 pm
Which version of Xampp?
One that fits your operating system and still has PHP5 in it. I.e. if you're using Windows then one of https://sourceforge.net/projects/xampp/ ... ws/5.6.40/ should be your choice.
The worst thing about censorship is ███████████
Affin wrote:
Tue Nov 20, 2018 9:51 am
The problem is probably not my English but you do not want to understand correctly.
...
We will not come anybody anyway, nevertheless, it's best to shit this.

ziska
Registered User
Posts: 12
Joined: Sun May 20, 2007 9:22 pm

Re: 10 year old upgrade? Possible???

Post by ziska » Wed May 15, 2019 5:22 pm

Thank you AmigoJack- understood.

I was responding to Prosk8er

"and install a older version of xampp with php 5"

User avatar
vader696
Translator
Posts: 74
Joined: Sat Jan 21, 2017 11:38 am
Location: Krakow, Poland
Contact:

Re: 10 year old upgrade? Possible???

Post by vader696 » Wed May 15, 2019 6:00 pm

Just to inform. 2-3 years ago I was upgrading phpBB2 to phpBB 3.2.4 and could not login to upgraded forum. There is also info for convertion that:

Password conversion Due to the utf-8 based handling of passwords in phpBB3, it is not always possible to transfer all passwords. For passwords "lost in translation" the easiest workaround is to use the I forgot my password link on the login page.

So I copied old password hashes to new database and all users could login with old password. SQL query looks like

Code: Select all

UPDATE newDatabase.phpbb_users, oldDatabase.phpbb_users
SET newDatabase.phpbb_users.user_password = oldDatabase.phpbb_users.user_password
WHERE newDatabase.phpbb_users.user_id = oldDatabase.phpbb_users.user_id;

User avatar
Prosk8er
Registered User
Posts: 1444
Joined: Sun Mar 12, 2006 3:30 am
Location: Rochester, NY
Name: Tyler
Contact:

Re: 10 year old upgrade? Possible???

Post by Prosk8er » Wed May 15, 2019 9:50 pm

ziska wrote:
Wed May 15, 2019 5:22 pm
Thank you AmigoJack- understood.

I was responding to Prosk8er

"and install a older version of xampp with php 5"
if on windows use the link from amigojack and get the xampp-windows-x64-5.6.40-1-VC11-installer.exe if your on a 64-bit machine if not then xampp-win32-5.6.40-0-VC11-installer.exe

also it may be better to upgrade to phpbb 3.0.14 first then to 3.2.7
if you have any questions feel free to pm me

ziska
Registered User
Posts: 12
Joined: Sun May 20, 2007 9:22 pm

Re: 10 year old upgrade? Possible???

Post by ziska » Thu May 16, 2019 3:52 pm

Update from the Apache Friends board:

ziska wrote:
4. Where's the dashboard to enable php 5.0 and download the current message board?

"Nowhere. You cannot freely enable any php version, Xampp 7.x comes with PHP7 and thats it, and there is neither any download tool for any message boards."

So it seems XAMPP is not an option for a local host because it's php 7 and nothing else.

Good news - finally got to phpmyadmin on Network Solutions which let me tell you with their "new improved" dashboard was not fun.
Dreamweaver CS6 (no cloud-I live in Freddy Kruger no upload land)
Mac 10.11.6

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50411
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: 10 year old upgrade? Possible???

Post by stevemaury » Thu May 16, 2019 3:58 pm

Yes, but all that means is you need a different version of XAMPP with php 5.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
EA117
Registered User
Posts: 583
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 10 year old upgrade? Possible???

Post by EA117 » Thu May 16, 2019 4:09 pm

The current XAMPP Downloads page only offers 7.x versions since there are already three of those to offer, and even 7.1.x is arguably "an older version" to be offering at this point. But if you visit the More Downloads link from that page, you can still find the even older 5.6.x releases, too.

ziska
Registered User
Posts: 12
Joined: Sun May 20, 2007 9:22 pm

Re: 10 year old upgrade? Possible???

Post by ziska » Thu May 16, 2019 4:39 pm

XAMPP for mac 1.0.3

I suspect there is no 5.0 version for OSX

Post Reply

Return to “[3.2.x] Support Forum”