Problem updating from 3.2.5 to 3.2.7 using full package.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Fri May 17, 2019 2:21 am

I have to apologize for the large error log that I have posted below.
But I do not know what is relevant, and what is not, so I have posted the lot.

Uploading the full package using the instructions shown in the attachment, all seemed to go well, and I got confirmation that the database had been updated. I was offered the option to go to the ACP but went to my FTP client to delete the install folder. After this I tried to load my forum in my browser and got a 500 error page ? I came back to these pages and found advice that perhaps all had not been uploaded resulting in missing files. So I uploaded everything a second time and went through the whole procedure again. This time when given the option to go to the ACP I accepted and tried to log in, but was given the error message 'no permission' or the like. What I noticed was that my forum ACP page was showing my METRO style/theme. I found this odd, as I had most certainly set the style to Prosilver prior to the first update attempt.
Needless to say when I tried to load my forum in my browser again, I got another 500 error.

What is going on here ?

Code: Select all

[16-May-2019 23:51:13 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[16-May-2019 23:51:14 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[16-May-2019 23:51:15 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[16-May-2019 23:51:16 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[16-May-2019 23:51:19 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[17-May-2019 00:01:31 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[17-May-2019 00:01:49 UTC] PHP Fatal error:  Composer dependencies have not been set up yet, run 'php ../composer.phar install' from the phpBB directory to do so. in /home/seanb620/public_html/forum/includes/startup.php on line 81
[17-May-2019 00:50:42 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 00:50:53 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 00:51:23 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 00:51:26 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 00:51:31 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 00:56:17 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 00:56:48 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 01:05:08 UTC] PHP Fatal error:  Class 'phpbb\path_helper' not found in /home/seanb620/public_html/forum/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 2736
[17-May-2019 01:27:06 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 01:32:24 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 01:44:29 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 01:44:32 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
[17-May-2019 02:01:56 UTC] PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
Stack trace:
#0 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Configurator.php(7373): s9e\TextFormatter\Plugins\MediaEmbed\Configurator\Collections\SiteDefinitionCollection->getNotExistException('blab')
#1 /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator.php(53): s9e\TextFormatter\Configurator\Collections\NormalizedCollection->get('blab')
#2 /home/seanb620/public_html/forum/ext/phpbb/mediaembed/event/main_listener.php(79): s9e\TextFormatter\Plugins\MediaEmbed\Configurator->add('blab')
#3 [internal function]: phpbb\mediaembed\event\main_listener->configure_media_embed(Object(phpbb\event\data), 'core.text_forma...', Object(phpbb\event\dispatcher))
#4 /home/seanb620/public_html/forum/vendor/symfony/event-dispatcher/EventDispat in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php on line 21
Attachments
Update 3.2.5 to 3.2.7.JPG
Last edited by Mick on Fri May 17, 2019 7:30 am, edited 1 time in total.
Reason: Added code tag.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Lumpy Burgertushie » Fri May 17, 2019 3:00 am

those errors almost always mean that at the very least the vendor folder was not removed and replaced properly during your update process.

you are supposed to remove all the files and folders except for the config.php file and the files, ext, images folders and then upload all new files from the full package except for the blank config.php file.

or, if you have cloudfare or some other caching setup at the server level you need to either purge it or turn it off during the update.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
3Di
Former Team Member
Posts: 13663
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by 3Di » Fri May 17, 2019 3:45 am

Dun4 wrote:
Fri May 17, 2019 2:21 am
I have to apologize for the large error log that I have posted below.
Why instead not to use the provided bbcodes?

like
[quote][/quote]
or
[code][/code]
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
EA117
Registered User
Posts: 582
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by EA117 » Fri May 17, 2019 3:49 am

Dun4 wrote:
Fri May 17, 2019 2:21 am
[17-May-2019 02:01:56 UTC] PHP Fatal error: Uncaught exception 'RuntimeException' with message 'Media site 'blab' does not exist' in /home/seanb620/public_html/forum/vendor/s9e/text-formatter/src/Plugins/MediaEmbed/Configurator/Collections/SiteDefinitionCollection.php:21
That's the issue described here, and encountered by several sites that updated to the latest phpBB version. So also include updating the https://www.phpbb.com/customise/db/exte ... ediaembed/ extension to the current version, which is apparently helpful even though it is not specific to these latest phpBB updates.

User avatar
3Di
Former Team Member
Posts: 13663
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by 3Di » Fri May 17, 2019 4:22 am

EA117 wrote:
Fri May 17, 2019 3:49 am
So also include updating the https://www.phpbb.com/customise/db/exte ... ediaembed/ extension to the current version, which is apparently helpful even though it is not specific to these latest phpBB updates.
The extension only enables the rich feature set of MediaEmbed which is third-party software bundled within phpBB.

The latest available version is 1.0.4. If someone's running a lesser version than that then yes, it should be updated.

If the extension is already 1.0.4 then only the phpBB's vendor folder has to be deleted and the 3.2.7's one uploaded, and cache purged.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Fri May 17, 2019 2:50 pm

On my previous two attempts at updating from 3.2.5 to 3.2.7 I have deleted the files as shown in the attachment, and then used CUTE FTP to upload/overwrite my php forum files. These two attepts failed ?

This time I deleted all of the unwanted files on the server, and then uploaded the new files.
Still no go and I am still getting the error 500 page ?

With all 3 attempts I got his message below, with the database update saying it had been successful.

Skip “installer.update_filesystem.download_updated_files” task
Skip “installer.update_filesystem.update_files” task
Skip “installer.update_filesystem.show_file_status” task
Skip “installer.update_filesystem.diff_files” task
Skip “installer.update_filesystem.check_task” task
Skip “installer.obtain_data.update_ftp_settings” task
Skip “installer.obtain_data.update_files” task
Skip “installer.obtain_data.file_updater_method” task

What is my next option ?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Lumpy Burgertushie » Fri May 17, 2019 3:16 pm

did you update the media embed extension yet?

download the 1.0.4 version from the link above.

unzip it on your computer.
using your ftp, delete the ext/phpbb/mediaembed folder and upload the new one from your computer.

using ftp, delete everything from the folder named cache except for the index and htaccess files.

if you have cloudfare running on your server, turn it off or purge the cache from your hosting control panel .

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Sat May 18, 2019 7:54 pm

Well, I have carried out the actions suggested by Lumpy Burgertushie » Fri May 17, 2019 4:16 pm

I do not have cloudflair, and I have explained things to my host and asked if any 'Cache' could be deleted, and am waiting to hear back.

The problem persists and below is the error log result ............

[18-May-2019 20:39:55 Europe/London] PHP Fatal error: Uncaught exception 'Twig\Error\LoaderError' with message 'Unable to find template "message_body.html" (looked into: /home/seanb620/public_html/forum/styles/all/template).' in /home/seanb620/public_html/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php:245
Stack trace:
#0 /home/seanb620/public_html/forum/phpbb/template/twig/loader.php(135): Twig\Loader\FilesystemLoader->findTemplate('message_body.ht...')
#1 /home/seanb620/public_html/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php(155): phpbb\template\twig\loader->findTemplate('message_body.ht...')
#2 /home/seanb620/public_html/forum/vendor/twig/twig/src/Environment.php(351): Twig\Loader\FilesystemLoader->getCacheKey('message_body.ht...')
#3 /home/seanb620/public_html/forum/vendor/twig/twig/src/Environment.php(445): Twig\Environment->getTemplateClass('message_body.ht...')
#4 /home/seanb620/public_html/forum/phpbb/template/twig/environment.php(277): Twig\Environment->loadTemplate('message_body.ht...', NULL)
#5 /home/seanb620/public_html/forum/vendor in /home/seanb620/public_html/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 245

User avatar
Lumpy Burgertushie
Registered User
Posts: 66236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Lumpy Burgertushie » Sun May 19, 2019 3:56 am

delete the vendor folder completely from the server.

upload a new copy of the vendor folder.
'
purge the cache.

test.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Mon May 20, 2019 1:39 pm

I contacted my Host to explain the situation to them and asked them to purge the cache if needed. My support ticket got elevated to Third Level, and I am still waiting to hear back.
As soon as I hear I will post the details here.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50407
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by stevemaury » Mon May 20, 2019 3:08 pm

As you have FTP access, you can clear the cache yourself by deleting the /production folder.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Mon May 20, 2019 4:22 pm

This is the reply from my Host ........
Hello,
In the "forum" folder, you will find an error_log file. Please check it.

Below is the log. I have again deleted the vendor folder and uploaded afresh, and I have deleted the production folder in the cache folder.
Still not working ?

Please advise.


[20-May-2019 13:55:21 UTC] PHP Fatal error: Uncaught exception 'Twig\Error\LoaderError' with message 'Unable to find template "message_body.html" (looked into: /home/seanb620/public_html/forum/styles/all/template).' in /home/seanb620/public_html/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php:245
Stack trace:
#0 /home/seanb620/public_html/forum/phpbb/template/twig/loader.php(135): Twig\Loader\FilesystemLoader->findTemplate('message_body.ht...')
#1 /home/seanb620/public_html/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php(155): phpbb\template\twig\loader->findTemplate('message_body.ht...')
#2 /home/seanb620/public_html/forum/vendor/twig/twig/src/Environment.php(351): Twig\Loader\FilesystemLoader->getCacheKey('message_body.ht...')
#3 /home/seanb620/public_html/forum/vendor/twig/twig/src/Environment.php(445): Twig\Environment->getTemplateClass('message_body.ht...')
#4 /home/seanb620/public_html/forum/phpbb/template/twig/environment.php(277): Twig\Environment->loadTemplate('message_body.ht...', NULL)
#5 /home/seanb620/public_html/forum/vendor in /home/seanb620/public_html/forum/vendor/twig/twig/src/Loader/FilesystemLoader.php on line 245

User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Tue May 21, 2019 8:17 pm

I have just gone through the whole process again but this time there has been something new.
At the final stages of uploading the last folder, the vendor folder, I got this message pop up ?

The remote folder already contains a folder named 'Exception'

I instructed to overwrite.

I have never seen this folder ?

What on earth is happening here ?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66236
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Lumpy Burgertushie » Tue May 21, 2019 8:31 pm

exactly how are you uploading the files? are you using ftp? if so, what ftp program?


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Dun4
Registered User
Posts: 82
Joined: Wed Mar 28, 2018 1:48 pm
Location: London UK

Re: Problem updating from 3.2.5 to 3.2.7 using full package.

Post by Dun4 » Tue May 21, 2019 8:38 pm

Cute FTP

Post Reply

Return to “[3.2.x] Support Forum”