I think I lost my site...

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Lonewolf147
Registered User
Posts: 82
Joined: Fri Jul 12, 2013 3:13 pm
Location: Milwaukee, WI
Name: Scott

I think I lost my site...

Post by Lonewolf147 » Sat May 18, 2019 1:52 pm

I'm just looking to confirm this, that I'm probably out of luck on recovering my forum.

I made a copy of the phpbb directory and saved it to my backup drive. BUT, I totally forgot to back up the database for it. I host locally, so no one else to look to for backups.

Without the database, have I actually lost everything as I think I have?

User avatar
david63
Registered User
Posts: 16093
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: I think I lost my site...

Post by david63 » Sat May 18, 2019 2:08 pm

Lonewolf147 wrote:
Sat May 18, 2019 1:52 pm
Without the database, have I actually lost everything as I think I have?
Unfortunately - yes
Lonewolf147 wrote:
Sat May 18, 2019 1:52 pm
host locally,
If you host it locally then why can you not get a copy of your database?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Lonewolf147
Registered User
Posts: 82
Joined: Fri Jul 12, 2013 3:13 pm
Location: Milwaukee, WI
Name: Scott

Re: I think I lost my site...

Post by Lonewolf147 » Sat May 18, 2019 2:09 pm

david63 wrote:
Sat May 18, 2019 2:08 pm
If you host it locally then why can you not get a copy of your database?

It was due to a computer crash, and I ended up reinstalling windows. :(

Thanks for the confirmation though.
Last edited by Lonewolf147 on Sat May 18, 2019 2:11 pm, edited 1 time in total.

User avatar
</Solidjeuh>
Registered User
Posts: 1563
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: I think I lost my site...

Post by </Solidjeuh> » Sat May 18, 2019 2:10 pm

Yes, without database backup your screwed :cry:
Maybe there is a recent database backup in the /store folder, if you created one via ACP ?
Register a free account & Play!!
~~~ https://www.solidjeuh.be ~~~
Have a secret? --> https://www.tellyoursecrets.eu

User avatar
david63
Registered User
Posts: 16093
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: I think I lost my site...

Post by david63 » Sat May 18, 2019 2:14 pm

</Solidjeuh> wrote:
Sat May 18, 2019 2:10 pm
Maybe there is a recent database backup in the /store folder, if you created one via ACP ?
Not if it was on his local machine where he re-installed Windows unless the disc was partitioned with data on a different partition to Windows.
Lonewolf147 wrote:
Sat May 18, 2019 2:09 pm
It was due to a computer crash, and I ended up reinstalling windows.
The moral being always keep an offsite backup
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
</Solidjeuh>
Registered User
Posts: 1563
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: I think I lost my site...

Post by </Solidjeuh> » Sat May 18, 2019 2:16 pm

david63 wrote:
Sat May 18, 2019 2:14 pm
</Solidjeuh> wrote:
Sat May 18, 2019 2:10 pm
Maybe there is a recent database backup in the /store folder, if you created one via ACP ?
Not if it was on his local machine where he re-installed Windows unless the disc was partitioned with data on a different partition to Windows.
Lonewolf147 wrote:
Sat May 18, 2019 1:52 pm
I made a copy of the phpbb directory and saved it to my backup drive.
He has the phpBB files, so maybe there is... :D
Register a free account & Play!!
~~~ https://www.solidjeuh.be ~~~
Have a secret? --> https://www.tellyoursecrets.eu

User avatar
Lonewolf147
Registered User
Posts: 82
Joined: Fri Jul 12, 2013 3:13 pm
Location: Milwaukee, WI
Name: Scott

Re: I think I lost my site...

Post by Lonewolf147 » Sat May 18, 2019 2:17 pm

</Solidjeuh> wrote:
Sat May 18, 2019 2:10 pm
Yes, without database backup your screwed :cry:
Maybe there is a recent database backup in the /store folder, if you created one via ACP ?
Holy cr#p. I totally forgot about that directory. The system was set to make automatic backups and I didn't even remember that. There is indeed backup files there!

User avatar
</Solidjeuh>
Registered User
Posts: 1563
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: I think I lost my site...

Post by </Solidjeuh> » Sat May 18, 2019 2:23 pm

What a relief it can be :lol:
Register a free account & Play!!
~~~ https://www.solidjeuh.be ~~~
Have a secret? --> https://www.tellyoursecrets.eu

User avatar
Lonewolf147
Registered User
Posts: 82
Joined: Fri Jul 12, 2013 3:13 pm
Location: Milwaukee, WI
Name: Scott

Re: I think I lost my site...

Post by Lonewolf147 » Sat May 18, 2019 2:25 pm

Indeed! You all just made my weekend a whole lot better than it was starting out :D

Cheers!

User avatar
david63
Registered User
Posts: 16093
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: I think I lost my site...

Post by david63 » Sat May 18, 2019 2:31 pm

Just make sure that the database and files are for the same version of phpBB
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Lumpy Burgertushie
Registered User
Posts: 66268
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: I think I lost my site...

Post by Lumpy Burgertushie » Sat May 18, 2019 2:57 pm

and, when you get it all back up and working. make backups, keep one sometwhere other than on your computer.



robert
I am going to be out of town and off line for a week . see ya when I get back.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
Lonewolf147
Registered User
Posts: 82
Joined: Fri Jul 12, 2013 3:13 pm
Location: Milwaukee, WI
Name: Scott

Re: I think I lost my site...

Post by Lonewolf147 » Sat May 18, 2019 3:19 pm

Yes, and Yes :)

Post Reply

Return to “[3.2.x] Support Forum”