Error: The submitted form was invalid. Try submitting again.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Sun May 19, 2019 9:43 pm

Hi there!

I freshly installed the last version of phpBB. Everything went smoothly until I logged out of my forum and tried to log back in (it happened by accident as I've cleared the cookies) - it doesn't work and there is an error message: "The submitted form was invalid. Try submitting again." I've tried forgotten password - same thing. I've tried registering - same thing. So I've made clean install again and it happened again. I tried another install with different settings, same thing. I feel like I am at loss now, I really don't know what to do. I was trying to find a solution on Google, but nobody seems to experience this particular problem. Can you please help me?

User avatar
david63
Registered User
Posts: 16093
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Error: The submitted form was invalid. Try submitting again.

Post by david63 » Mon May 20, 2019 5:21 am

There are several possible reasons for this:

1. You have installed phpBB 3.2.6
2. You have used your host's "one click" install
3. The style you are using is not compatible with your version of phpBB

(When I searched Google returned 225k results!)
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Mon May 20, 2019 5:46 am

Yes, I did install the latest version - is that a problem?

The rest of the options are not relevant for me, so no one click install or the style - there is a default prosilver theme, nothing is changed.

I mean, of course, there are a lot of results connected to this error message, but I couldn’t find a case where someone couldn’t login to their forum right after creating it. People usually have some access to their forum, but can’t create new topics etc. I can’t get into my forum, that’s pretty harsh. :D

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21075
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Error: The submitted form was invalid. Try submitting again.

Post by Mick » Mon May 20, 2019 7:20 am

Please fill out the Support Request Template and post it back here to enable us to assist you better.
"The more connected we get the more alone we become" - Kyle Broflovski

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Mon May 20, 2019 7:28 am

Support Request Template
What version of phpBB are you using? phpBB 3.2.7
What is your board's URL? Not installed at the moment, but it is tied to www.avifauna.cz domain
Who do you host your board with? Savana.cz
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? None, there is default prosilver theme
What language(s) is your board currently using? Default, british english - it's not language related, I've tried
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Fresh install of phpBB, nothing else. It's not working right from the beginning.
Please describe your problem. After logging out of the board after fresh install, I can't login with my credentials. New registration is not working, forgotten password is not working. Error message: The submitted form was invalid. Try submitting again.
Generated by SRT Generator

User avatar
EA117
Registered User
Posts: 605
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Error: The submitted form was invalid. Try submitting again.

Post by EA117 » Mon May 20, 2019 11:17 am

VlkCherokee wrote:
Mon May 20, 2019 7:28 am
New registration is not working, forgotten password is not working. Error message: The submitted form was invalid. Try submitting again.
The "form invalid" related to style or phpBB 3.2.6 and later is only about the login form. Form validation has always been in effect for registration and forgotten password, so these conditions are not "new."

"Just in case" the issue is with the session ID being used for these forms, you could try turning off the "Tie forms to guest sessions:" setting in the ACP General tab, Server configuration, Security settings to see if it affects your problem at all. If that helps, the question will still be "why was the session ID wrong?" A caching service similar to CloudFlare (either implemented by you, or by your hosting service) can potentially be a reason for "I'm served a page which contains a different session ID than what phpBB will actually use for me." There are probably other technical reasons too, but I don't know them.

User avatar
3Di
Former Team Member
Posts: 13686
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Error: The submitted form was invalid. Try submitting again.

Post by 3Di » Mon May 20, 2019 11:28 am

Isn't the forgot password's email in the SPAM folder?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Mon May 20, 2019 11:50 am

Thank you, I can try that when I will get back home. I haven't implemented anything myself, so if there is a problem with that, it must be the provider. I have a caching plugin (WP Fastest Cache) in the root domain folder, because I am running it on my Wordpress website, but I am sure that can't affect the phpBB as it's separate from it (in a different folder)? Or could it be that?

And it's certainly not in my spam folder, it just doesn't work entirely - doesn't do anything but generate the "The submitted form was invalid. Try submitting again."

User avatar
david63
Registered User
Posts: 16093
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Error: The submitted form was invalid. Try submitting again.

Post by david63 » Mon May 20, 2019 12:00 pm

VlkCherokee wrote:
Mon May 20, 2019 11:50 am
Or could it be that?
It is certainly a possibility. Try turning it off and see if it makes any difference.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Mon May 20, 2019 12:12 pm

david63 wrote:
Mon May 20, 2019 12:00 pm
VlkCherokee wrote:
Mon May 20, 2019 11:50 am
Or could it be that?
It is certainly a possibility. Try turning it off and see if it makes any difference.
Or I could try to put it to some list of exceptions if there is an option for that.. I will keep you updated.

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Mon May 20, 2019 4:08 pm

Ok, so I've put my forum root folder /forum as an exception for the WP Fastest Cache plugin and I did that admin setting that was recommended to me above before I logged out. What changed is that I no longer get the "The submitted form was invalid...", instead, when I try to login, I am redirected on the index without logging in. No error message this time. The forgotten password is working and it is sent to my mail. However, same issue persists - I put it into the login fields and I am redirected to index page without being logged in. I've tried to deactivate the caching plugin - same issue.

I was wondering - my website is running on HTTPS and there are some settings when installing the phpBB about cookies, that if you have SSL, you should set in on. I did that, but the forum itself is not running under HTTPS as the website. Could this be a problem? I was suspecting this setting from the start and tried to set different values, but nothing ever changed.

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Mon May 20, 2019 10:04 pm

I've tried to install again, following instructions from the provider (they have a tutorial to install phpBB) and it didn't help. I still can't login. :(

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Tue May 21, 2019 9:16 am

I have an update: I've logged in at work from Macbook and it's working! I am really confused now. The browser is Chrome, same as at my personal computer. So is it an extension in the browser? Ad block? I will try to look into it when I get back home.

User avatar
david63
Registered User
Posts: 16093
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Error: The submitted form was invalid. Try submitting again.

Post by david63 » Tue May 21, 2019 9:37 am

VlkCherokee wrote:
Tue May 21, 2019 9:16 am
The browser is Chrome
Depending on which version of Chrome that you are using there are many reported problems with it on the Internet, and quite a few on this board.
VlkCherokee wrote:
Mon May 20, 2019 10:04 pm
following instructions from the provider (they have a tutorial to install phpBB)
Why not use the instructions provided on here?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

VlkCherokee
Registered User
Posts: 12
Joined: Sun May 19, 2019 9:38 pm

Re: Error: The submitted form was invalid. Try submitting again.

Post by VlkCherokee » Tue May 21, 2019 9:45 am

david63 wrote:
Tue May 21, 2019 9:37 am
VlkCherokee wrote:
Tue May 21, 2019 9:16 am
The browser is Chrome
Depending on which version of Chrome that you are using there are many reported problems with it on the Internet, and quite a few on this board.
VlkCherokee wrote:
Mon May 20, 2019 10:04 pm
following instructions from the provider (they have a tutorial to install phpBB)
Why not use the instructions provided on here?
I have the latest version, it's updating automatically.

I've used instructions provided here at least 3 times, but I was thinking that the provider has some specific server settings that require specific settings during the installation. But apparently, that wasn't the case.

Post Reply

Return to “[3.2.x] Support Forum”