3.2.5 to 3.2.7 Automatic Update - HELP!!!

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
RubiconCSL
Registered User
Posts: 25
Joined: Thu May 11, 2006 9:12 am
Location: Somerset UK

3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by RubiconCSL » Fri May 24, 2019 10:15 am

First of all - got to say, I struggle every time with an update. Maybe it's just me, but I have been working in IT for 30 years, so I'm not exactly thick. Anyway, moan out of the way :)

I tried to update from 3.2.5 to 3.2.7 last night.

I first did a MySQLdump of the database and then (with hindsight - stupidly) did a backup in the admin panel, rather than tar up the file structure.

As there are a few mods I had to to to get the FLATBOOTS style to work, I did the "automatic" update. It does after all say on the download page: -
This update package supplies the automatic updater, which is capable of updating modified installations. This is the package that most users should download to update their forums. If you have made no changes, you can use the 'Changed Files' package instead.
I got stuck in a never-ending loop of "The following files are not modified and represent the original phpBB files from the version you want to update from.".

I had to give up in the end. Fortunately, I had renamed the vendor directory before the update. So I was able to at least restore the vendor directory to its previous state. I renamed the 3.2.7 install directory so that the forum would go out of maintenance mode and hoped for the best.

So I now have several files updated (all bar a few in fact), but not the database.

I tried to restore the backup I made in the admin panel, but it says it's in the wrong format (I guess due to the partial update).

It looks to work - mostly. I can post, read posts etc. Avatars don't display though, although personal ones people have uploaded do thankfully. I'm not sure yet what else is screwed. I've set the default style to proSilver, just in case the FLATBOOTS one now has issues.

How do I recover? How do I get those last bloody files to update - or at least get it back to how it was? Why is this always so painful if there are mods that have been made.

The forum is http://thepompeychimes.net/forum

RubiconCSL
Registered User
Posts: 25
Joined: Thu May 11, 2006 9:12 am
Location: Somerset UK

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by RubiconCSL » Fri May 24, 2019 10:18 am

The 6 files in the infinite loop are all in the root of the forum: -

composer.json
composer.lock
index.php
memberlist.php
posting.php
viewforum.php

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21078
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by Mick » Fri May 24, 2019 10:43 am

Knowledge Base - Updating 3.2.x is the best method for updating.
"The more connected we get the more alone we become" - Kyle Broflovski

RubiconCSL
Registered User
Posts: 25
Joined: Thu May 11, 2006 9:12 am
Location: Somerset UK

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by RubiconCSL » Fri May 24, 2019 1:08 pm

Bu t will that work with MODS? The download page suggests the automatic update download is the way one should go?
Mick wrote:
Fri May 24, 2019 10:43 am
Knowledge Base - Updating 3.2.x is the best method for updating.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21078
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by Mick » Fri May 24, 2019 1:12 pm

What mods, they finished with 3.0 and haven’t been recommended since? 3.1+ uses extensions which, theoretically, should work in 3,2, you need to check with the authors.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
EA117
Registered User
Posts: 608
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by EA117 » Fri May 24, 2019 2:19 pm

RubiconCSL wrote:
Fri May 24, 2019 1:08 pm
RubiconCSL wrote:
Fri May 24, 2019 10:15 am
This update package supplies the automatic updater, which is capable of updating modified installations. This is the package that most users should download to update their forums. If you have made no changes, you can use the 'Changed Files' package instead.
Mick wrote:
Fri May 24, 2019 10:43 am
Knowledge Base - Updating 3.2.x is the best method for updating.
Bu t will that work with MODS? The download page suggests the automatic update download is the way one should go?
"Modified installations" in that original statement means sites where the core .php and/or style files have been modified to be something other than the original phpBB-delivered files. The "automatic updater" is what can "merge" those same core file modifications, more or less, into the updated phpBB files about to be delivered with the new version.

If you've simply installed extensions (or "MODs", as they were in phpBB 3.0.x parlance), the automatic update doesn't help you preserve anything about your installed extensions that the full package update process won't also preserve. The main thing you're avoiding by using the full package update is -- although the automatic update process "can work fine" -- the automatic update process is just more complex and more points of failure, which can and do sometimes go wrong.

The full package update process presumes you don't need to preserve any custom modifications to your core phpBB files, and simply overwrites previous phpBB-delivered files with the latest phpBB-delivered files.

RubiconCSL
Registered User
Posts: 25
Joined: Thu May 11, 2006 9:12 am
Location: Somerset UK

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by RubiconCSL » Sat May 25, 2019 8:23 am

Thanks for the response EA. That was my understanding - other than the fact it might go wrong :)

I made some changes when I updated to 3.2.5 from a very much earlier version (2.something). I wanted a nice flat style and found one called FLATBOOTS. But that did entail a bit of jiggerypokery to get it installed. So I don't want to break that - hence using the automatic update (as I say, the download page suggests it is what most people should use anyway).

So what do I do now? Just download the full package and hope the other style still works? I guess I have little choice now. Maybe I'll get rid of the FLATBOOTS style and just provide basic ones that need no modifications.

I do wish the main download page made it much clearer that the way to go is to use the full package. The wording on there doesn't make tht clear at all to me.

Full package
This is the full 3.2.7 package which can be used for new installations. It contains the entire phpBB source code and the British English language pack. See the link below to download additional language packs.
Auto update
This update package supplies the automatic updater, which is capable of updating modified installations. This is the package that most users should download to update their forums. If you have made no changes, you can use the 'Changed Files' package instead.
EA117 wrote:
Fri May 24, 2019 2:19 pm

"Modified installations" in that original statement means sites where the core .php and/or style files have been modified to be something other than the original phpBB-delivered files. The "automatic updater" is what can "merge" those same core file modifications, more or less, into the updated phpBB files about to be delivered with the new version.

If you've simply installed extensions (or "MODs", as they were in phpBB 3.0.x parlance), the automatic update doesn't help you preserve anything about your installed extensions that the full package update process won't also preserve. The main thing you're avoiding by using the full package update is -- although the automatic update process "can work fine" -- the automatic update process is just more complex and more points of failure, which can and do sometimes go wrong.

The full package update process presumes you don't need to preserve any custom modifications to your core phpBB files, and simply overwrites previous phpBB-delivered files with the latest phpBB-delivered files.

User avatar
EA117
Registered User
Posts: 608
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: 3.2.5 to 3.2.7 Automatic Update - HELP!!!

Post by EA117 » Sat May 25, 2019 10:12 am

RubiconCSL wrote:
Sat May 25, 2019 8:23 am
So what do I do now? Just download the full package and hope the other style still works? I guess I have little choice now. Maybe I'll get rid of the FLATBOOTS style and just provide basic ones that need no modifications.
For "just a style", I don't have any anxiety about it's installed status being corrupted by the type of installation you perform. Automatic install is quite literally about "modifications to the core phpBB files", like if you had edited index.php or posting.php in order to achieve some goal, etc.

Simply having styles installed, or simply having extensions installed, "aren't those kind of modifications." The update from 3.2.5 to 3.2.7, if the instructions are followed, won't remove or uninstall your styles or extensions.

But, the question of whether your installed styles, and/or whether your installed extensions are compatible with the latest version of phpBB is still a valid concern. You may need to update to the latest version of your style, and the latest version of your installed extensions, when updating phpBB. And if there isn't a version of the style or extension that works with the latest version of phpBB, you could end up with some issues.

But the point is, "how you installed phpBB" isn't what will solve or avoid those. If your style needs to be updated to a more phpBB 3.2.7-compatible version of FLATBOOTS, you're still going to need to do that regardless of whether you're successful at an Automatic update or a Full Package install. Those aren't the kind of issues that the Automatic update process resolves.

Post Reply

Return to “[3.2.x] Support Forum”