forum problem

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 1:28 pm

Hello, I want to add a forum from the category, but whatever happens, although I have checked the forum option, I automatically assign it to the category field, that is, the main page, and I can't create a forum.

screnn shots:
AdsıSAz.png

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: forum problem

Post by KevC » Wed Jun 12, 2019 1:31 pm

The ones that are grey probably don't have any permissions set on them to be seen.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

Re: forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 2:10 pm

KevC wrote:
Wed Jun 12, 2019 1:31 pm
The ones that are grey probably don't have any permissions set on them to be seen.
In localhost, it's not grayed out, but that's not the problem, it doesn't create forums and when it creates it automatically detects it as a category and throws it to the home page.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: forum problem

Post by KevC » Wed Jun 12, 2019 2:22 pm

You mean you select 'forum' but it actually makes a category? Never heard of that before.

How do you know it does that?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

Re: forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 2:28 pm

KevC wrote:
Wed Jun 12, 2019 2:22 pm
You mean you select 'forum' but it actually makes a category? Never heard of that before.

How do you know it does that?
can I see if i give you my admin details? and try to create a form.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: forum problem

Post by KevC » Wed Jun 12, 2019 2:31 pm

Sure, just send me a PM.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

Re: forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 2:39 pm

KevC wrote:
Wed Jun 12, 2019 2:31 pm
Sure, just send me a PM.
okay, I sent

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: forum problem

Post by KevC » Wed Jun 12, 2019 2:46 pm

I just made a new category and a forum inside it on the index page at the bottom.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

Re: forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 2:52 pm

KevC wrote:
Wed Jun 12, 2019 2:46 pm
I just made a new category and a forum inside it on the index page at the bottom.
that's what i want to say;
they all have the same permissions, see the gray ones? they have problems.
Ads58ız.png

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21321
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: forum problem

Post by Mick » Wed Jun 12, 2019 3:15 pm

Kev, are all the hierarchies ok? Something looks odd with those forums.
"The more connected we get the more alone we become" - Kyle Broflovski

ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

Re: forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 3:28 pm

Mick wrote:
Wed Jun 12, 2019 3:15 pm
Kev, are all the hierarchies ok? Something looks odd with those forums.
they all look good but i don't understand what happened to me suddenly when i want to open a form in the gray category, it perceives it as a category and throws it to the home page as a form category.
log in and try to open a form in a gray category, you know what I mean.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69239
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: forum problem

Post by KevC » Wed Jun 12, 2019 4:02 pm

As I said at the start, the permissions were wrong.

You can't have a category set to read only and then give people standard access to the forums under it. That makes no sense. You can't allow them to only read at the top level and then give them posting ability below that.

I just changed that top category to standard access for the registered users group and then I was able to make a test forum under it.
Attachments
Screenshot 2019-06-12 at 17.00.13.png
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

ibrahimisahin
Registered User
Posts: 41
Joined: Sat May 04, 2019 8:20 am
Contact:

Re: forum problem

Post by ibrahimisahin » Wed Jun 12, 2019 4:20 pm

KevC wrote:
Wed Jun 12, 2019 4:02 pm
As I said at the start, the permissions were wrong.

You can't have a category set to read only and then give people standard access to the forums under it. That makes no sense. You can't allow them to only read at the top level and then give them posting ability below that.

I just changed that top category to standard access for the registered users group and then I was able to make a test forum under it.
Thanks, kev you're a wonder.

Post Reply

Return to “[3.2.x] Support Forum”

cron