Lost old forum, Making new one and trying to replicate old

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
stueck0514
Registered User
Posts: 3
Joined: Wed Jun 12, 2019 4:43 pm

Lost old forum, Making new one and trying to replicate old

Post by stueck0514 » Wed Jun 12, 2019 4:51 pm

Hey guys, first time to post here. We recently had a crash or something on our server rendering it inoperable. Something about a "shoutbox" we had on the lower part of our main page.

We used an older version of phpbb, and have recently updated to the newest version. Fresh start, etc etc. Now, I would like to get the old threads and posts back, with the old users as well. I have copied the folders:

phpbb_acl_roles
phpbb_acl_roles_data
phpbb_forums
phpbb_posts
phpbb_topics
phpbb_topics_posted
phpbb_users
phpbb_user_group

From our older forum to the new one, renaming all the standard new folders to their same name but adding "_old" to the end of it, in case something goes wrong I can just rename and go back to how it was.

For the life of me I cannot figure out how to get the threads and posts back... I can see when I log into the administration control panel the threads and users and things, but they all seem to be hidden in the background of the website? When I go to the website itself it shows just the clan logo and how many users are online.

If there is any way I can get some help that would be fantastic, or if there is any more information/screenshots you guys would like I can surely supply them.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69038
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Lost old forum, Making new one and trying to replicate old

Post by KevC » Wed Jun 12, 2019 5:00 pm

You can't just bring some of the tables (not folders) over. That's not how it works.

Get a copy of the old version from sourceforge, restore the database and get that working and then upgrade to the latest one in the documented way.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

stueck0514
Registered User
Posts: 3
Joined: Wed Jun 12, 2019 4:43 pm

Re: Lost old forum, Making new one and trying to replicate old

Post by stueck0514 » Wed Jun 12, 2019 5:34 pm

I have a copy of the old version I believe. I have a 25GB backup with everything on it from cPanel, and also the old forum from phpMyAdmin on cPanel as well.

Is this what you are speaking of?

User avatar
canonknipser
Registered User
Posts: 1963
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Lost old forum, Making new one and trying to replicate old

Post by canonknipser » Wed Jun 12, 2019 5:51 pm

KevC wrote:
Wed Jun 12, 2019 5:00 pm
Get a copy of the old version from sourceforge
Why sourceforge, unless it is a version prior to 3.0.0? Use this site: https://download.phpbb.com/pub/release/
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69038
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Lost old forum, Making new one and trying to replicate old

Post by KevC » Wed Jun 12, 2019 5:59 pm

stueck0514 wrote:
Wed Jun 12, 2019 5:34 pm
I have a copy of the old version I believe. I have a 25GB backup with everything on it from cPanel, and also the old forum from phpMyAdmin on cPanel as well.

Is this what you are speaking of?
Yes
Get that working and then you can upgrade it depending on which version it was.

You can do it all locally if it's easier.
Installing and Setting Up Your Own Web Server
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

stueck0514
Registered User
Posts: 3
Joined: Wed Jun 12, 2019 4:43 pm

Re: Lost old forum, Making new one and trying to replicate old

Post by stueck0514 » Wed Jun 12, 2019 6:13 pm

It was before 3.0. Old webpage. If I bring the old webpage back, I can copy/paste the error message it shows, would that help?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69038
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Lost old forum, Making new one and trying to replicate old

Post by KevC » Wed Jun 12, 2019 6:18 pm

2.0.x boards can be brought back to life and converted.
Definitely worth doing it offline because you'll need an older version of php running to make it work (<5.4). What's likely is that your hosts updated php on the server and that's what broke it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Post Reply

Return to “[3.2.x] Support Forum”