whitespace error while posting replies

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

whitespace error while posting replies

Post by deserved » Sat Jun 15, 2019 4:55 pm

while posting replies in my forum, it showing blank white space
when a user posted a reply it was showing as not posted, but actually it is posted
it appearing when user refresh the page,
it was happennig in some forums where traffic was high, other forums with low traffic working normally,
so users are confused and posting the same message multiple times

i contacted my hosting company about this issue, they said it was not our server problem
also adviced me to check your code and shared this like to me
https://stackoverflow.com/questions/840 ... -or-t-vari

need some help
i never changed my code previously

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Sat Jun 15, 2019 4:57 pm

i'm using phpbb version 3.2.2

User avatar
david63
Registered User
Posts: 16166
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: whitespace error while posting replies

Post by david63 » Sat Jun 15, 2019 5:48 pm

deserved wrote:
Sat Jun 15, 2019 4:55 pm
it showing blank white space
Can you explain exactly what that means - preferably with a screenshot.

A link to your board would help.

Do you have a caching program (such as Cloudflare) installed on your site?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Sat Jun 15, 2019 6:09 pm

david63 wrote:
Sat Jun 15, 2019 5:48 pm
deserved wrote:
Sat Jun 15, 2019 4:55 pm
it showing blank white space
Can you explain exactly what that means - preferably with a screenshot.

A link to your board would help.

Do you have a caching program (such as Cloudflare) installed on your site?
just white screen all white nothing else, in some browsers it showing http error 500
i do not have any caching program installed in my site like cloudflare

User avatar
Lumpy Burgertushie
Registered User
Posts: 66324
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: whitespace error while posting replies

Post by Lumpy Burgertushie » Sat Jun 15, 2019 7:04 pm

a blank page is usually caused by a php error somewhere. you will need to access your server error logs to find out what is causing it.

if you do not know where the logs are you will need to ask your host.
once you find the logs, copy and paste the newest 25 or so lines here.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Thu Jun 20, 2019 9:51 am

Code: Select all

Stack trace:
#0 /home/inssiaco/public_html/vendor/twig/twig/lib/Twig/Environment.php(457): Twig_Cache_Filesystem->write('./cache/product...', '<?php\n\n/* navba...')
#1 /home/inssiaco/public_html/phpbb/template/twig/environment.php(277): Twig_Environment->loadTemplate('navbar_header.h...', NULL)
#2 /home/inssiaco/public_html/vendor/twig/twig/lib/Twig/Template.php(366): phpbb\template\twig\environment->loadTemplate('navbar_header.h...', NULL)
#3 /home/inssiaco/public_html/cache/production/twig/a1/a17e47ee62afb17d625332e4af1137ed8a5c6bc99a3d1f75ed10799b8e9fd66c.php(450): Twig_Template->loadTemplate('navbar_header.h...', 'overall_header....', 123)
#4 /home/inssiaco/public_html/vendor/twig/twig/lib/Twig/Template.php(432): __TwigTemplate_d78f7960573dca49abf631842767fe5c0ed792a438722158 in /home/inssiaco/public_html/vendor/twig/twig/lib/Twig/Template.php on line 447
[20-Jun-2019 02:39:12 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:39:46 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:40:48 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:42:25 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:48:16 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:48:39 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:48:50 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:49:23 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:50:55 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:50:57 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:52:16 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:55:59 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 02:58:19 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 03:39:15 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 04:03:43 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 04:05:22 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 04:39:24 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 05:39:30 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 06:33:39 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 06:39:44 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 07:39:49 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 07:55:54 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 08:40:11 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 09:06:51 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
[20-Jun-2019 09:09:45 UTC] PHP Parse error:  syntax error, unexpected ''a:1:{s:5:"email";a:2:{s:12:"p' (T_ENCAPSED_AND_WHITESPACE) in /home/inssiaco/public_html/cache/production/queue.php on line 3
need some help

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3220
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: whitespace error while posting replies

Post by thecoalman » Thu Jun 20, 2019 10:41 am

Have you tried purging the cache? There is button for this on main page of the ACP.

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Thu Jun 20, 2019 4:08 pm

yes i purged cache twice but problem not solved

User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 3220
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.
Contact:

Re: whitespace error while posting replies

Post by thecoalman » Thu Jun 20, 2019 4:26 pm

Try manually deleting the queue.php in the cache folder, there is another topic here but pretty old:

viewtopic.php?t=2357326

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Thu Jun 20, 2019 4:47 pm

recently i faced full disk space problem
and my hosting company added some additional disk space to my site
from that time i'm facing this error

what should i do now
should i delete queue.php completely
is it ok to delete it

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50490
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: whitespace error while posting replies

Post by stevemaury » Thu Jun 20, 2019 5:04 pm

Yes, but if you're nervous, back it up first.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
Lumpy Burgertushie
Registered User
Posts: 66324
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: whitespace error while posting replies

Post by Lumpy Burgertushie » Thu Jun 20, 2019 5:08 pm

be sure you are deleting the one in the cache not the main one.

also, according to what I just looked up, this is often related to a problem with running out of disk space.
contact your host again.
just curious, how much disk space do you have in your account package? why are you running out of disk space? are you hosting a lot of files or images or what?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Thu Jun 20, 2019 5:54 pm

deleted queue.php
and queue.php.lock
in public_html/cache/production/
and now problem gone, replies are working normally when i click submit button
:D :D :D :D :D

they are recreated automatically when i made a reply
actually i'm in shared hosting
they giving unlimited disk space and bandwidth
my site consumes 16gb and increasing daily

thanks for the wonderful support :D :D :D

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Fri Jun 21, 2019 6:02 am

:shock: now all avatars are deleted from board

deserved
Registered User
Posts: 58
Joined: Thu May 17, 2018 6:34 pm

Re: whitespace error while posting replies

Post by deserved » Fri Jun 21, 2019 6:05 am

wait now i can't log in to my acp
showing these errors

phpBB Debug] PHP Warning: in file [ROOT]/phpbb/di/container_builder.php on line 146: require(./../cache/production/autoload_dbdbe80dc7030ae9bd39ee30cca82130.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/di/container_builder.php on line 146: require(./../cache/production/autoload_dbdbe80dc7030ae9bd39ee30cca82130.php): failed to open stream: No such file or directory

Post Reply

Return to “[3.2.x] Support Forum”