PHP 7.3

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
CarpCharacin
Registered User
Posts: 473
Joined: Sat Dec 06, 2014 1:59 pm
Location: Salt Lake City, Utah
Name: James Stewart
Contact:

PHP 7.3

Post by CarpCharacin » Fri Jun 21, 2019 8:55 am

Does phpbb 3.2.7 support PHP 7.3?

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25196
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: PHP 7.3

Post by Paul » Fri Jun 21, 2019 8:55 am

No.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Heo32
Registered User
Posts: 113
Joined: Sat Jan 07, 2017 10:08 pm

Re: PHP 7.3

Post by Heo32 » Fri Jun 21, 2019 2:12 pm

phpBB 3.3 will support it.

Stick with PHP 7.2 for now.

Although it is nice to know the lowest versions of software that are supported, it is also important to know the highest supported versions, too. In the User Guide, maybe it should get updated to reflect that.
Is this for you? :arrow: Windows + Nginx + PHP + MySQL + phpBB + WordPress + Cloudflare

Allow using Content-Security-Policy without unsafe-inline
stevemaury wrote:
Sun May 20, 2018 8:16 pm
I went to your board and looked for an hour or so, but did not see the women without underwear.

User avatar
david63
Registered User
Posts: 16173
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: PHP 7.3

Post by david63 » Fri Jun 21, 2019 2:22 pm

Heo32 wrote:
Fri Jun 21, 2019 2:12 pm
phpBB 3.3 will support it.
If I remember correctly - not all versions of PHP 7.3 will be supported
Heo32 wrote:
Fri Jun 21, 2019 2:12 pm
Although it is nice to know the lowest versions of software that are supported, it is also important to know the highest supported versions, too. In the User Guide, maybe it should get updated to reflect that.
https://tracker.phpbb.com/browse/PHPBB3-16014
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Heo32
Registered User
Posts: 113
Joined: Sat Jan 07, 2017 10:08 pm

Re: PHP 7.3

Post by Heo32 » Fri Jun 21, 2019 7:15 pm

Uh, wrong. All versions of PHP 7.3 will be supported once phpBB 3.3 comes out.
Is this for you? :arrow: Windows + Nginx + PHP + MySQL + phpBB + WordPress + Cloudflare

Allow using Content-Security-Policy without unsafe-inline
stevemaury wrote:
Sun May 20, 2018 8:16 pm
I went to your board and looked for an hour or so, but did not see the women without underwear.

User avatar
david63
Registered User
Posts: 16173
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: PHP 7.3

Post by david63 » Fri Jun 21, 2019 8:40 pm

Heo32 wrote:
Fri Jun 21, 2019 7:15 pm
All versions of PHP 7.3 will be supported once phpBB 3.3 comes out.
That is not what Marc said a few weeks ago on Discord
supported PHP versions as of right now will be 7.1 - 7.3 (7.3.0 & 7.3.1 are excluded as these have major issues that result in random segfaults)
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Heo32
Registered User
Posts: 113
Joined: Sat Jan 07, 2017 10:08 pm

Re: PHP 7.3

Post by Heo32 » Sat Jun 22, 2019 11:18 am

If that is what Marc said on Discord a few weeks ago, then I rest my case. phpBB 3.3 will support PHP 7.3. But I'll cover a few obvious points to help you out.

1. phpBB 3.3 is not out yet, therefore no one is using it in a public environment. If they are, then they shouldn't be.
2. PHP 7.3.0 and PHP 7.3.1 are outdated and insecure versions that no one would use at this point in time even if phpBB 3.3 was out right now.
3. The current version of PHP 7.3 is presently PHP 7.3.6. By the time phpBB 3.3 does come out for public use, there will be a newer version.
4. phpBB 3.3 and newer releases will support all versions of PHP 7.3 that are available and supported. Who cares if PHP 7.3.0 and 7.3.1 are having issues with the current build(s) of phpBB 3.3 with segfaults? None of that matters. They are already outdated versions anyhow with bugs and security holes that have already been patched in the latest version.

So if you want to get all technical and talk about obsolete versions of PHP 7.3 on phpBB software that has not been released for public use, then yes, you would be correct. But if we're being realistic and sensible here, regarding the future, phpBB 3.3 will support all relevant versions of PHP 7.3 just as you claimed Marc said on Discord with the statement "supported PHP versions as of right now will be 7.1 - 7.3".

Case closed.
Is this for you? :arrow: Windows + Nginx + PHP + MySQL + phpBB + WordPress + Cloudflare

Allow using Content-Security-Policy without unsafe-inline
stevemaury wrote:
Sun May 20, 2018 8:16 pm
I went to your board and looked for an hour or so, but did not see the women without underwear.

Post Reply

Return to “[3.2.x] Support Forum”