Board errors / unable to login

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
pete.baker
Registered User
Posts: 3
Joined: Sat Jun 22, 2019 5:14 pm

Board errors / unable to login

Post by pete.baker » Sat Jun 22, 2019 6:22 pm

Hi,

sorry that my first post on here is asking for help.

We have a forum hosted at forum.dloc.co.uk which has been established and running fine for many years, this morning I was informed it was showing as down so logged in and was presented with a basic page missing most content and was unable to load /adm or login as a normal user. This issues only seems to affect some users, one of the board admins is able to login and make changes.

Prior to this knowledge I restored both the database and the forum to Friday evening as I suspected a corrupt file, this hasn't fixed the issue. Server logs are not showing anything, file permissions look to be correct.

I've logged a ticket with the server hosts but would rather fix myself if possible

Many thanks

User avatar
Lumpy Burgertushie
Registered User
Posts: 66728
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Board errors / unable to login

Post by Lumpy Burgertushie » Sat Jun 22, 2019 7:41 pm

things like this don't just happen by themselves. somebody somewhere changed something.

the most likely culprit is you host did something on the server.
either they screwed up and had to restore from bad backups, or , they updated some part of their server software or hardware etc. etc.
or, some admin or someone with ftp access messed with something.

luck,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50812
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Board errors / unable to login

Post by stevemaury » Sat Jun 22, 2019 8:22 pm

Could we get a link to your board?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

clickcoiner
Registered User
Posts: 2
Joined: Sat Jun 22, 2019 5:33 pm

Re: Board errors / unable to login

Post by clickcoiner » Sat Jun 22, 2019 9:01 pm

The same thing has happened to me this morning. I could clear cookie/cache/ and login but there are still hourly spikes in CPU usage starting while I was asleep

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50812
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Board errors / unable to login

Post by stevemaury » Sat Jun 22, 2019 10:31 pm

So the logical question is, what host are each of you using?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

clickcoiner
Registered User
Posts: 2
Joined: Sat Jun 22, 2019 5:33 pm

Re: Board errors / unable to login

Post by clickcoiner » Sat Jun 22, 2019 11:45 pm

I am using geekstorage, it looks like his domain is hosted on 4uhosting.co.uk

pete.baker
Registered User
Posts: 3
Joined: Sat Jun 22, 2019 5:14 pm

Re: Board errors / unable to login

Post by pete.baker » Sun Jun 23, 2019 9:20 am

URL is forum.dloc.co.uk

Hosted by 4uhosting

I can't see anything that's been changed recently from file date stamps, server logs don't show anything of use.

I restored database and files to Friday, issue was reported to me on Saturday morning.

The odd part is some users haven't yet had an issue.

I've got a ticket logged with the hosting company so hope they provide some insight!

Many thanks for the replies

User avatar
EA117
Registered User
Posts: 910
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Board errors / unable to login

Post by EA117 » Sun Jun 23, 2019 2:49 pm

Don't have any suggestions yet, because the site comes up fine for me right now.

Yesterday when you posted, the HTML document returned by index.php was the only thing that came through. (Which created a visual result similar to you were describing.) Every single resource the page had tried to load (.css sheets, .js scripts) was being denied as 404 / does not exist.

But when I tried to capture a LAN trace and dig deeper, suddenly the site was offline entirely, saying a connection couldn't be made to the IP address at all. So I assumed your host must be in the middle of restarting or testing something in response to your ticket, and left it alone.

Re-testing just now shows the site up as expected, and all resources loading successfully. Is it still failing for you, or do you know there are reports that the site is still failing?

User avatar
david63
Registered User
Posts: 16537
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Board errors / unable to login

Post by david63 » Sun Jun 23, 2019 3:20 pm

Me thinks that the host has "tweaked" something!!
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

pete.baker
Registered User
Posts: 3
Joined: Sat Jun 22, 2019 5:14 pm

Re: Board errors / unable to login

Post by pete.baker » Sun Jun 23, 2019 5:31 pm

As suggested, the forum host had firewalled out a great chunk of IP ranges after they updated their web app firewall with the latest definitions. Whatever happened to running things through a dev environment first before releasing into prod!

Thanks for the help all

Post Reply

Return to “[3.2.x] Support Forum”