Page 1 of 1

Board errors / unable to login

Posted: Sat Jun 22, 2019 6:22 pm
by pete.baker
Hi,

sorry that my first post on here is asking for help.

We have a forum hosted at forum.dloc.co.uk which has been established and running fine for many years, this morning I was informed it was showing as down so logged in and was presented with a basic page missing most content and was unable to load /adm or login as a normal user. This issues only seems to affect some users, one of the board admins is able to login and make changes.

Prior to this knowledge I restored both the database and the forum to Friday evening as I suspected a corrupt file, this hasn't fixed the issue. Server logs are not showing anything, file permissions look to be correct.

I've logged a ticket with the server hosts but would rather fix myself if possible

Many thanks

Re: Board errors / unable to login

Posted: Sat Jun 22, 2019 7:41 pm
by Lumpy Burgertushie
things like this don't just happen by themselves. somebody somewhere changed something.

the most likely culprit is you host did something on the server.
either they screwed up and had to restore from bad backups, or , they updated some part of their server software or hardware etc. etc.
or, some admin or someone with ftp access messed with something.

luck,
robert

Re: Board errors / unable to login

Posted: Sat Jun 22, 2019 8:22 pm
by stevemaury
Could we get a link to your board?

Re: Board errors / unable to login

Posted: Sat Jun 22, 2019 9:01 pm
by clickcoiner
The same thing has happened to me this morning. I could clear cookie/cache/ and login but there are still hourly spikes in CPU usage starting while I was asleep

Re: Board errors / unable to login

Posted: Sat Jun 22, 2019 10:31 pm
by stevemaury
So the logical question is, what host are each of you using?

Re: Board errors / unable to login

Posted: Sat Jun 22, 2019 11:45 pm
by clickcoiner
I am using geekstorage, it looks like his domain is hosted on 4uhosting.co.uk

Re: Board errors / unable to login

Posted: Sun Jun 23, 2019 9:20 am
by pete.baker
URL is forum.dloc.co.uk

Hosted by 4uhosting

I can't see anything that's been changed recently from file date stamps, server logs don't show anything of use.

I restored database and files to Friday, issue was reported to me on Saturday morning.

The odd part is some users haven't yet had an issue.

I've got a ticket logged with the hosting company so hope they provide some insight!

Many thanks for the replies

Re: Board errors / unable to login

Posted: Sun Jun 23, 2019 2:49 pm
by EA117
Don't have any suggestions yet, because the site comes up fine for me right now.

Yesterday when you posted, the HTML document returned by index.php was the only thing that came through. (Which created a visual result similar to you were describing.) Every single resource the page had tried to load (.css sheets, .js scripts) was being denied as 404 / does not exist.

But when I tried to capture a LAN trace and dig deeper, suddenly the site was offline entirely, saying a connection couldn't be made to the IP address at all. So I assumed your host must be in the middle of restarting or testing something in response to your ticket, and left it alone.

Re-testing just now shows the site up as expected, and all resources loading successfully. Is it still failing for you, or do you know there are reports that the site is still failing?

Re: Board errors / unable to login

Posted: Sun Jun 23, 2019 3:20 pm
by david63
Me thinks that the host has "tweaked" something!!

Re: Board errors / unable to login

Posted: Sun Jun 23, 2019 5:31 pm
by pete.baker
As suggested, the forum host had firewalled out a great chunk of IP ranges after they updated their web app firewall with the latest definitions. Whatever happened to running things through a dev environment first before releasing into prod!

Thanks for the help all