Fatal error phpBB 3.2.7

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Kerrith
Registered User
Posts: 472
Joined: Mon Mar 28, 2005 10:16 am
Location: Pahoa, Hawaii
Contact:

Re: Fatal error phpBB 3.2.7

Post by Kerrith » Wed Jul 10, 2019 12:24 am

I uploaded board3 to my /forums/styles which also contains prosilver and responsive_curve-beta5 folders.

I deleted everything, including the twig folder, in /caches except index.htm and htaccess.

Then, via ACP, I purged the cache,

I then logged out and refreshed my browser but I only see prosilver in ACP> Customise > Styles. I don't see board3. All forums have prosilver as the "Default style."

Here's the results as of 7/9/19 1424 hrs:

Extension Manager tab:

Enabled Extensions
Notify Admin on Registration 0.0.1 Details Disable
Disabled Extensions
The “phpbb/viglink” extension is not valid.
The requested file could not be found: ./../ext/phpbb/viglink/composer.json

The “sitesplat/BBCore” extension is not valid.
The requested file could not be found: ./../ext/sitesplat/BBCore/composer.json

The “sitesplat/bbootsminicms” extension is not valid.
The requested file could not be found: ./../ext/sitesplat/bbootsminicms/composer.json

The “board3/portal” extension is not valid.
The requested file could not be found: ./../ext/board3/portal/composer.json

Extensions tab:

General Error
Cannot find module ./../includes/acp/\board3\portal\acp\portal_module.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 571
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()

User avatar
Lumpy Burgertushie
Registered User
Posts: 66320
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Fatal error phpBB 3.2.7

Post by Lumpy Burgertushie » Wed Jul 10, 2019 12:57 am

board 3 is not a style. you do not put any part of it in the styles folder where prosilver lives.

you install board3 like any other extension. instructions are here:
https://www.phpbb.com/extensions/installing/

however, this extension is not totally compatible with phpbb 3.2 there are a few changes that have to be made for it to work properly.

http://reyno41.bplaced.net/phpbb/viewto ... p=788#p788

or:
viewtopic.php?p=14672681#p14672681
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
warmweer
Registered User
Posts: 2111
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Fatal error phpBB 3.2.7

Post by warmweer » Wed Jul 10, 2019 1:25 am

Kerrith wrote:
Wed Jul 10, 2019 12:24 am
I uploaded board3 to my /forums/styles which also contains prosilver and responsive_curve-beta5 folders.

I deleted everything, including the twig folder, in /caches except index.htm and htaccess.

Then, via ACP, I purged the cache,

I then logged out and refreshed my browser but I only see prosilver in ACP> Customise > Styles. I don't see board3. All forums have prosilver as the "Default style."

Here's the results as of 7/9/19 1424 hrs:

Extension Manager tab:

Enabled Extensions
Notify Admin on Registration 0.0.1 Details Disable
Disabled Extensions
The “phpbb/viglink” extension is not valid.
The requested file could not be found: ./../ext/phpbb/viglink/composer.json

The “sitesplat/BBCore” extension is not valid.
The requested file could not be found: ./../ext/sitesplat/BBCore/composer.json

The “sitesplat/bbootsminicms” extension is not valid.
The requested file could not be found: ./../ext/sitesplat/bbootsminicms/composer.json

The “board3/portal” extension is not valid.
The requested file could not be found: ./../ext/board3/portal/composer.json
This tells you that board3 is not correctly installed. It's an extension and I'm sure you originally didn't install it by copying it to forums/styles. The zip file should probably have been extracted to the ext/ directory. Check the board3 extension you downloaded for the instructions.
I also see you have other extensions which seem to have been not properly installed, or have had files removed after installing.
Reupload all the extensions you had (look in the extensions table (phpMyAdmin) to see which ones you had. Reupload the viglink folder also.

Thinking worst case scenario - you do have a backup from before updating to 3.2.7, I hope (files and database)?


added: in the meantime Lumpy has also answered and also mentioned that Board3 is not phpBB3.2 compatible. I mentioned it had to be tweaked.
Thinking positively: If (hopefully when) you get your board functioning again, don't mess with it before testing extensions, style, modifications on a copy.

It's 3:25 AM here and bed is calling.
My board's not broken, it just went peculiar

Post Reply

Return to “[3.2.x] Support Forum”