Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

I've done the upgrade using the Full Package, and everything appeared to go smoothly, but it has introduced a new error.

The forum shows the following error when you view it as a visitor:

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4628: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4628: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4628: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)

Then when you access the ACP, you see the following error:

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 137: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)

Any ideas how I might be able to fix this problem?
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

It appears to have affected posting messages to the board - when I try to post a message, a white page comes up with the following error:

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 1868: Cannot modify header information - headers already sent by (output started at [ROOT]/config.php:32)

If I use the back button in the browser, then try to submit the message again, it allows me to submit the message - but shows the errors in my post above.

e2a: The error above is showing up when users try to log in to the site as well
User avatar
david63
Registered User
Posts: 18079
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by david63 »

It would appear that you have some extra lines in your config.php file as it is saying that something has been output on line 32 of that file and a "normal" config.php file only has 17 lines.

Post a copy of your config.php file (with the user and password removed) using code bb tags
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

Here's the config.php file

Code: Select all


<?php





$dbms     = 'mysqli'       ;


$dbhost   = 'localhost' ;


$dbport   = ''            ;


$dbname   = 'removed'   ;


$dbuser   = 'removed' ;


$dbpasswd = 'removed' ;





$table_prefix    = 'phpbb3_' ;


$acm_type        = 'file'   ;


$load_extensions = ''       ;





@define ( 'PHPBB_INSTALLED' , true ) ;





?>





User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by </Solidjeuh> »

You edit your files with a bad editor, are u using standard notepad?
Use Notepad++

Needs to some something like:

Code: Select all

<?php
// phpBB 3.2.x auto-generated configuration file
// Do not change anything in this file!
$dbms     = 'mysqli';
$dbhost   = 'localhost';
$dbport   = '';
$dbname   = 'removed';
$dbuser   = 'removed';
$dbpasswd = 'removed';
$table_prefix    = 'phpbb3_';
$acm_type        = 'file';
$load_extensions = '';

@define ( 'PHPBB_INSTALLED' , true );
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

I actually use Notepad ++

So I need to delete all the extra blank lines in the config.php?
Last edited by robbell on Tue Jul 23, 2019 8:57 pm, edited 2 times in total.
User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by </Solidjeuh> »

robbell wrote:
Tue Jul 23, 2019 8:54 pm
I actually use Notepad ++

So I need to delete all the extra blank lines in the config.php?
Yes, specially at the top
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

I've done that, but that's just led to a different error:

Parse error: syntax error, unexpected '$dbms' (T_VARIABLE) in /home/ehtnamuh/public_html/forum/config.php on line 1
User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by </Solidjeuh> »

robbell wrote:
Tue Jul 23, 2019 8:57 pm
I've done that, but that's just led to a different error:

Parse error: syntax error, unexpected '$dbms' (T_VARIABLE) in /home/ehtnamuh/public_html/forum/config.php on line 1
This is mine

Code: Select all

<?php
// phpBB 3.2.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'phpbb\\db\\driver\\mysqli';
$dbhost = 'localhost';
$dbport = '';
$dbname = '*****';
$dbuser = '*****';
$dbpasswd = '*****';
$table_prefix = 'phpbb_';
$phpbb_adm_relative_path = 'adm/';
$acm_type = 'phpbb\\cache\\driver\\file';

@define('PHPBB_INSTALLED', true);
// @define('PHPBB_DISPLAY_LOAD_TIME', true);
@define('PHPBB_ENVIRONMENT', 'production');
// @define('DEBUG_CONTAINER', true);
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

I had to restore the config.php with all the spaces in in order to get rid of the error... now we're back to where we were earlier today.

It's interesting that your config.php is so different, why would that be?
User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by </Solidjeuh> »

Maybe an older version... don't know.
I see a debug error on your forum. Clear your forum cache.
And is the config file saved as UNIX UTF-8 without BOM in notepad++ ?
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

</Solidjeuh> wrote:
Tue Jul 23, 2019 9:18 pm
I see a debug error on your forum. Clear your forum cache.
And is the config file saved as UNIX UTF-8 without BOM in notepad++ ?
The debug error is the problem I encountered after updating the forum earlier today, clearing the cache didn't fix it, but unfortunately I can't log into the forum now because of that error

The config file is saved as UNIX UTF-8 without BOM
User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by </Solidjeuh> »

robbell 's problem is fixed via PB.

I removed the unnecessary "new lines" and "spaces"

All good now
Last edited by </Solidjeuh> on Tue Jul 23, 2019 10:04 pm, edited 3 times in total.
robbell
Registered User
Posts: 20
Joined: Sun Feb 27, 2011 12:33 am

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by robbell »

Thank you very much for your help, it's greatly appreciated. You have made 3 people much happier and able to sleep tonight!

Now we just have the problem with the disappeared inline images...
User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Done 3.2.2 to 3.2.7 upgrade but inline attachments missing

Post by </Solidjeuh> »

the config.php file you send me via PB was set to 'read only". had to right click the file, and uncheck that box. So maybe that's also the problem with the attachments ... ? not sure, we need a phpBB expert to answer this :D
Post Reply

Return to “[3.2.x] Support Forum”