Page 1 of 1

Can't get URL Rewriting working on subdomain

Posted: Mon Jul 15, 2019 10:11 pm
by Phr3d13
I have two phpbb installs running on my domain (phr3d13.com/forum and musica.phr3d13.com) The former is 'bridged' to the domain's Joomla install with an extension. The latter is completely separate and running as the subdomain's main page. The forum at the main domain is working properly, URLs are being re-written properly. The forum at the subdomain appears to have cookie and/or .htaccess issues. I can't, for the life of me, figure out how to get the urls rewritten for the subdomain. I get SID junk at the end of links and "foo.php" in links as well. I'd be glad to post any files needed for troubleshooting.

Re: Can't get URL Rewriting working on subdomain

Posted: Mon Jul 15, 2019 10:53 pm
by Phr3d13
Support Request Template
What version of phpBB are you using? phpBB 3.2.7
What is your board's URL? http://musica.phr3d13.com
Who do you host your board with? Self
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? Default
What language(s) is your board currently using? Default / British English
Which database type/version are you using? I Don't Know
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Subdomain and domain are both self hosted via XAMPP on Windows 10. Set up subdomain separately from domain in vhosts. Domain from folder xampp/htdocs, subdomain from xampp/musica. Everything on main domain and forum appear to work as expected.
Please describe your problem. Forum on subdomain works, for the most part. I think either my cookies are at fault, or the .htaccess needs some help. URL Rewriting doesn't seem to do anything. I still have 'foo.php' in links as well as 'sid=' strings. Have tried most suggestions in any threads I could find, but nothing appears to help.
Generated by SRT Generator

Re: Can't get URL Rewriting working on subdomain

Posted: Tue Jul 16, 2019 12:52 pm
by Mick
I cant’t see a problem on your second board which is https by the way. Can you give us a specific case or, better still, a link to a specific case so we can see what’s going on please? There are no threads in phpBB btw, they are topics ;)

Re: Can't get URL Rewriting working on subdomain

Posted: Tue Jul 16, 2019 2:27 pm
by Brf
Yes. You have some sort of extension rewriting the URLs in your phr3d13.com/forum
That extension does not appear to be installed in the musica.phr3d13.com one.

Re: Can't get URL Rewriting working on subdomain

Posted: Tue Jul 16, 2019 3:21 pm
by EA117
Mick wrote:
Tue Jul 16, 2019 12:52 pm
Phr3d13 wrote:
Mon Jul 15, 2019 10:53 pm
Have tried most suggestions in any threads I could find, but nothing appears to help.
There are no threads in phpBB btw, they are topics ;)
I missed the part where he said he was only searching on phpBB-based boards for discussion of possible solutions. 😜

Re: Can't get URL Rewriting working on subdomain

Posted: Tue Jul 16, 2019 3:34 pm
by stevemaury
No matter where else he may be searching, phpBB still does not have "threads".

Re: Can't get URL Rewriting working on subdomain

Posted: Tue Jul 16, 2019 7:21 pm
by Phr3d13
After comparing the two setups some more, I think I have it narrowed down to either the Joomla that the phpbb forum sits under, or the bridge extension doing the URL cleanup for the main domain's phpbb. Does anyone know of a MOD that could do similar for my subdomain's phpbb?
PS - Sorry for calling them threads, habit from all the different communication sites I use.