new php version breaks old forum

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

new php version breaks old forum

Post by cassie1275 » Wed Jul 17, 2019 4:44 pm

i have 2 forums and 2 guestbooks using databases. i am not very good at all this.
the 2 forums asked me to upgrade a while ago but i was updating my website to responsive. now the only non responsive thing i have is the forum.
i had to ask my host to upgrade php version before i could get the new install to work. But now my existing forums and guestbooks do not work. The page they are on is just blank.
Is this because of the php version or something else i have done wrong.
Any help would be appreciated.

User avatar
warmweer
Registered User
Posts: 2390
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: new php version breaks old forum

Post by warmweer » Wed Jul 17, 2019 6:33 pm

One possibility is that your host updated the php version to 7.3 (incompatibility with phpBB) but honestly speaking, there's insufficient information.
The fact that your guestbooks have stopped working could be an indication of a problem with the php version but you should post the Support Request Template here to allow a better evaluation of the situation. (and check the host control panel for the php version)
My board's not broken, it just went peculiar

cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

Re: new php version breaks old forum

Post by cassie1275 » Wed Jul 17, 2019 9:51 pm

i am out of my depth, i used to be good at this but getting old and forgot a lot over the years :-(
The hoster has put the version down to 5.6 and the old forums and guestbooks are back up.
But now the new forum has the following message.

You are running an unsupported PHP version. Please upgrade to PHP 5.4.0 or higher before trying to install or update to phpBB 3.2

I don't understand why this all has to be so difficult.

What more info is needed?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50587
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: new php version breaks old forum

Post by stevemaury » Wed Jul 17, 2019 10:34 pm

What version of php? phpBB does not work with php 7.3.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
EA117
Registered User
Posts: 755
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: new php version breaks old forum

Post by EA117 » Thu Jul 18, 2019 12:09 am

And which version of phpBB was installed prior to the PHP upgrade. Since even a "compatible" version such as PHP 7.2.x can cause the symptoms you're describing too, if you're on an older version of phpBB.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21332
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: new php version breaks old forum

Post by Mick » Thu Jul 18, 2019 8:08 am

@OP: Please don’t start multiple topics on the same subject, thanks.
"The more connected we get the more alone we become" - Kyle Broflovski

cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

Re: new php version breaks old forum

Post by cassie1275 » Thu Jul 18, 2019 8:33 am

i haven't !!!
Or dont remember doing so

cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

Re: new php version breaks old forum

Post by cassie1275 » Thu Jul 18, 2019 8:39 am

I dont know what the version of php was before they upgraded to 7.2.

When they upgraded to 7.2 i was able to get the new forum instillation finished and running, but when i went back to the old forum to see what it was called etc, it was not there, just a blank screen.

I contacted my hoster and he put it down to 5.6. The old forums and guestbooks worked but when i went to the new forum i got the following message

"You are running an unsupported PHP version. Please upgrade to PHP 5.4.0 or higher before trying to install or update to phpBB 3.2"

I dont understand why i am getting this message when the php is 5.6.

The original forum which i am trying to upgrade because it is not responsive has the following in the admin section

"Your installation does not seem to be up to date. Updates are available for your version of phpBB, please visit https://www.phpbb.com/downloads.php to obtain the latest version.
The latest available version is phpBB 7.2.0. You are running phpBB 2.0.22.

For the latest information on updates to phpBB, why not subscribe to our mailing list."

I know by searching this forum for phpBB 7.2.0 that it does not exist, and when i click the "mailing list" link it just goes to the main page of this site and can't find any mailing list link.

I need the guestbook (which i am not upgrading) to work with the new forum. If this is not possible I will just close the forum completely (a pity) and forget this all ever happened :-(

User avatar
warmweer
Registered User
Posts: 2390
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: new php version breaks old forum

Post by warmweer » Thu Jul 18, 2019 8:45 am

EA117 wrote:
Thu Jul 18, 2019 12:09 am
And which version of phpBB was installed prior to the PHP upgrade. Since even a "compatible" version such as PHP 7.2.x can cause the symptoms you're describing too, if you're on an older version of phpBB.
php 5.6 hasn't given me any problem with 3.2.x up to 3.2.6 (3.2.7 not tested yet) (and php5.4 hasn't given me any problems up to 3.2.4 - not tested with higer versions)
cassie1275 wrote:
Thu Jul 18, 2019 8:33 am
i haven't !!!
Or dont remember doing so
Actually you did, 1 yesterday morning (my time zone) and again yesterday evening. One topic has been made invisible (and probably any relevant posts merged here).
My board's not broken, it just went peculiar

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21332
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: new php version breaks old forum

Post by Mick » Thu Jul 18, 2019 8:48 am

warmweer wrote:
Wed Jul 17, 2019 6:33 pm
you should post the Support Request Template here to allow a better evaluation of the situation. (and check the host control panel for the php version)
If you can’t fill it all in please complete what you can.
"The more connected we get the more alone we become" - Kyle Broflovski

cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

Re: new php version breaks old forum

Post by cassie1275 » Thu Jul 18, 2019 9:16 am

Support Request Template
What version of phpBB are you using? phpBB 3.2.7
What is your board's URL? https://www.knitone.co.uk/forumdky/index.php
Who do you host your board with? tsohost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? none
What language(s) is your board currently using? english
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? i have an existing forum which has the following notice in admin
"Your installation does not seem to be up to date. Updates are available for your version of phpBB, please visit https://www.phpbb.com/downloads.php to obtain the latest version.
The latest available version is phpBB 7.2.0. You are running phpBB 2.0.22."
I downloaded the newest version from your website. I could not get it to work as it said the php version was too low. My hoster put it up to 7.2 but my old forum and guestbook broke. They put it down to 5.6, the existing forum and guestbook came back.
Please describe your problem. But now the new forum has the following message
"You are running an unsupported PHP version. Please upgrade to PHP 5.4.0 or higher before trying to install or update to phpBB 3.2"

which i dont understand as the php is 5.6.
Generated by SRT Generator

cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

Re: new php version breaks old forum

Post by cassie1275 » Thu Jul 18, 2019 9:18 am

warmweer wrote:
Thu Jul 18, 2019 8:45 am
EA117 wrote:
Thu Jul 18, 2019 12:09 am
And which version of phpBB was installed prior to the PHP upgrade. Since even a "compatible" version such as PHP 7.2.x can cause the symptoms you're describing too, if you're on an older version of phpBB.
php 5.6 hasn't given me any problem with 3.2.x up to 3.2.6 (3.2.7 not tested yet) (and php5.4 hasn't given me any problems up to 3.2.4 - not tested with higer versions)
cassie1275 wrote:
Thu Jul 18, 2019 8:33 am
i haven't !!!
Or dont remember doing so
Actually you did, 1 yesterday morning (my time zone) and again yesterday evening. One topic has been made invisible (and probably any relevant posts merged here).
I think i know what happened, i did the post and navigated away to other pages, then had to go out, when i came back i wanted to see if the post had been put up so i hit back on the browser. When i got back to the post it looked like i had not posted it so i hit submit again. I did not realise it would create another one because i thought i had not done it anyway. I did say i am old :-)

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21332
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: new php version breaks old forum

Post by Mick » Thu Jul 18, 2019 10:13 am

So, your ‘old’ board is version 2? Presumably your trying to upgrade that board to 3.2.7? (which would be the sensible thing to do) According to the old board in the /forum folder you’re using PHP 5.3.29? I can’t see what’s going on with the new board at present.
"The more connected we get the more alone we become" - Kyle Broflovski

cassie1275
Registered User
Posts: 12
Joined: Tue Jul 16, 2019 7:25 pm

Re: new php version breaks old forum

Post by cassie1275 » Thu Jul 18, 2019 10:45 am

My new board is on https://www.knitone.co.uk/forumdky/index.php

All it is "doing" is showing the following on the page

"You are running an unsupported PHP version. Please upgrade to PHP 5.4.0 or higher before trying to install or update to phpBB 3.2"

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21332
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: new php version breaks old forum

Post by Mick » Thu Jul 18, 2019 11:37 am

That’s because your v2 board is using PHP version 5.3.29 which 3.2 can’t. The new board needs PHP 5.4.7 > PHP 7.2 which phpBB v2 won’t work with. The best way to go is upgrade your v2 board to v3.2.7, see Upgrading from 2.0 to 3.2

Also, support for v2 finished years ago but we can help you upgrade.
"The more connected we get the more alone we become" - Kyle Broflovski

Post Reply

Return to “[3.2.x] Support Forum”