Forum not working anymore

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
libralion
Registered User
Posts: 362
Joined: Tue May 13, 2003 9:25 am

Forum not working anymore

Post by libralion »

Hi everybody,
I tried to update my forum to the newest version, but that didn't work.
For some reason it didn't let me upload the new files.
So I thought I would let it rest till tomorrow, but now my forum isn't working anymore.
I don't know where to start to get it working again.
Here is the url: https://www.libralion.com/forum/

Johanna
Last edited by libralion on Mon Aug 12, 2019 4:59 pm, edited 1 time in total.
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

libralion wrote:
Mon Aug 12, 2019 3:35 pm
...
For some reason it didn't let me upload the new files.
Probably something was uploaded becauyse your board now gives a blank page.
Did you use autoupdate?

If you can upload a new set of files and follow the instructions from https://www.phpbb.com/support/documents ... pdate_full (section 4.i. Full package) it should be repaired.
However, it's best to post the Support Request Template first allowing a betterevaluation of the situation.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
Lumpy Burgertushie
Registered User
Posts: 67898
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Forum not working anymore

Post by Lumpy Burgertushie »

what ever you did you apparently did not get all the new files uploaded.

your prosilver is still showing to be version 3.2.5

a blank page usually means a php error.
it can mean that you did not get the vendor folder uploaded properly.

as mentioned above, if you were trying the auto update then that is going to be the issue.

just follow those instructions posted above and start over and it should work.
remember, part of that process is deleting all the old files except for the ones mentioned in the instructions.

then uploading all new ones except for the blank config.php file.

luck,
robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
libralion
Registered User
Posts: 362
Joined: Tue May 13, 2003 9:25 am

Re: Forum not working anymore

Post by libralion »

warmweer wrote:
Mon Aug 12, 2019 3:56 pm
libralion wrote:
Mon Aug 12, 2019 3:35 pm
...
For some reason it didn't let me upload the new files.
Probably something was uploaded becauyse your board now gives a blank page.
Did you use autoupdate?

If you can upload a new set of files and follow the instructions from https://www.phpbb.com/support/documents ... pdate_full (section 4.i. Full package) it should be repaired.
However, it's best to post the Support Request Template first allowing a betterevaluation of the situation.
I used the autoupdate, but removed the files. Then everything should be normal again?

Johanna
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

libralion wrote:
Mon Aug 12, 2019 4:05 pm
I used the autoupdate, but removed the files. Then everything should be normal again?
If your put all your 3.2.5 files it might be back to normal, that would depend on whether the database update acually accomplished something along the way.
If you have a (database) backup (which you should really) then restoring that + your files should bring your board back to the state it was before trying to update.
But in this case, uploading (in binary) the full package as per instructions (don't forget to remove some files first - read the link) - then do the database update : and your board should be updated and working.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
libralion
Registered User
Posts: 362
Joined: Tue May 13, 2003 9:25 am

Re: Forum not working anymore

Post by libralion »

warmweer wrote:
Mon Aug 12, 2019 4:13 pm
libralion wrote:
Mon Aug 12, 2019 4:05 pm
I used the autoupdate, but removed the files. Then everything should be normal again?
If your put all your 3.2.5 files it might be back to normal, that would depend on whether the database update acually accomplished something along the way.
If you have a (database) backup (which you should really) then restoring that + your files should bring your board back to the state it was before trying to update.
But in this case, uploading (in binary) the full package as per instructions (don't forget to remove some files first - read the link) - then do the database update : and your board should be updated and working.
And how do I do that database update?

Johanna
Last edited by libralion on Mon Aug 12, 2019 4:57 pm, edited 1 time in total.
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

libralion wrote:
Mon Aug 12, 2019 4:15 pm
And how do I do that database uodate?
After uploading the3.2.7 fileset according to instructions,
first (delete everything from /cache if you haven't done that, but leave index.htm and .htaccess - and in /store do the same but keep any backups you have made!!!) (if you have followed the instructions, these directories shuld be empty anyway, but for the 2 files mentioned)
and then in your browser
https://www.libralion.com/forum/install/app.php/update
and select update database only (it may be database update only)

edited: rephrased (it wasn't really clear :oops: ) + added /update to https://www.libralion.com/forum/install/app.php
Last edited by warmweer on Mon Aug 12, 2019 7:51 pm, edited 4 times in total.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
Lumpy Burgertushie
Registered User
Posts: 67898
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Forum not working anymore

Post by Lumpy Burgertushie »

no, the autoupdate makes changes to existing files, that is how it works.
at this point you are going to have to do a complete update.

it should only take a few minutes depending on your internet speed.
as linked above:
Knowledge Base - Updating 3.2.x

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

I have a feeling (from what I can see): the title of this topic in now incorrect ;) (although we're not up to 3.2.7 yet).
later: Now up to 3.2.7 but there are error messages.
later again: It seems the vendor folder wasn't uploaded correctly (again).
and again later: Now 3.2.2 ?? What's happening?

I see that your forum is back up and running but it's phpBB version 3.2.2

@libralion
If you downloaded a new 3.2.2 fileset, then there nothing to worry about.
If you used an old one, which you downloaded when 3.2.2 was released, please compare it to a new download! Depending on when you downloaded it, the package may have been compromised. see: viewtopic.php?f=14&t=2456896
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
libralion
Registered User
Posts: 362
Joined: Tue May 13, 2003 9:25 am

Re: Forum not working anymore

Post by libralion »

Hi everybody
I'm confused. I reverted my board back to an older version.
But when I try to update then I get all sorts of issues and can't go any further.
What can I do best?
https://www.libralion.com/forum

Johanna
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

libralion wrote:
Tue Aug 13, 2019 5:16 pm
I'm confused. I reverted my board back to an older version.
Actually I am also confused. You had a working 3.2.5, then why revert to 3.2.2?
libralion wrote:
Tue Aug 13, 2019 5:16 pm
But when I try to update then I get all sorts of issues and can't go any further.
What can I do best?
Post the Support Request Template with as much information as possible.
Languages, styles, extensions, modifications etc...
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
libralion
Registered User
Posts: 362
Joined: Tue May 13, 2003 9:25 am

Re: Forum not working anymore

Post by libralion »

Hi,
I really am using 3.2.5.
Here is the template:

Support Request Template
What version of phpBB are you using? phpBB 3.2.5
What is your board's URL? https://www.libralion.com/forum
Who do you host your board with? Vimexx
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.5
What extensions do you have installed? -External lnks open in new window
-Lightbox
-s9e mediaembed
-scroll to top
What styles do you currently have installed? orangeBBEs and prosilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? No answer given
Please describe your problem. I can't update. The board says that a lot of files aren't compatible with the new style.
Generated by SRT Generator
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

libralion wrote:
Wed Aug 14, 2019 10:11 am
Hi,
I really am using 3.2.5.
That is what you are thinking but
your prosilver = version 3.2.2
your Orange_BBEs is version 2.0.2 for phpBB 3.2.1 (there is a version 2.0.7 for phpBB3.2.7) see https://www.phpbb.com/customise/db/style/orange_bbes/

Also when updating, it can help to disable the extensions, and you certainly need to update the media embedextension (which is why at least that extension has to be disabled before updating.

Added: Also yesterday when you had updated to 3.2.7 I saw the error messages and expected you to post them here (which is why I didn't). I remember seeing something about the media-extension in the error messages.

If you have the time, disable the extensions, delete the mediaextension completely, set prosilver as default style,disbale the old Orange style, use the full phpBB3.2.7 package, put the new OrangeBBEs files in place, and the new mediaextension. Then update, if successfull install the new mediaembed extension, if succesful, activate the new OrangeBB.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
User avatar
libralion
Registered User
Posts: 362
Joined: Tue May 13, 2003 9:25 am

Re: Forum not working anymore

Post by libralion »

Ok. I updated the Orangebbes style and prosilver to the latest version.
I also disabled the s9/ mediaembed.
Then I updated the board. All went well!!
But when I look at the version it still says 3.2 5. I really don't understand anymore and don't know what to do.

Johanna
User avatar
warmweer
Jr. Extension Validator
Posts: 4734
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum not working anymore

Post by warmweer »

libralion wrote:
Wed Aug 14, 2019 10:51 am
Ok. I updated the Orangebbes style and prosilver to the latest version.
I also disabled the s9/ mediaembed.
Then I updated the board. All went well!!
But when I look at the version it still says 3.2 5. I really don't understand anymore and don't know what to do.

Johanna
Your prosilver is now version 3.2.7.
Where do you see that the board version is 3.2.5?

Also, PRIVACY_LINK | TERMS_LINK (bottom of the index page) are missing the language entry.
Last edited by warmweer on Wed Aug 14, 2019 11:00 am, edited 1 time in total.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.2.x] Support Forum”

cron