User connection error from any extension page

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Jostix
Registered User
Posts: 3
Joined: Tue Aug 13, 2019 8:14 pm

User connection error from any extension page

Post by Jostix » Tue Aug 13, 2019 8:20 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.7
What is your board's URL? https://garde-noire.fr
Who do you host your board with? OVH
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.6
What extensions do you have installed? Custom extension
What styles do you currently have installed? Custom style
What language(s) is your board currently using? French
Which database type/version are you using? MySQL 5
What is your level of experience? Advanced
What username can be used to view this issue? Not required
What password can be used to view this issue? Not required
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Migration from one provider (niloo) to another provider (OVH)
Please describe your problem.
* Users receive an error message while trying to connect to the website, right after clicking on "connection", they are redirected to https://garde-noire.fr/ucp.php?mode=login with the error : "Form not valid, please try again"
* This error only occur when they are trying to connect from any extension page (i.e https://garde-noire.fr/app.php), but no errors if they connect directly from the index page
* This website is using SSL connection
* Below the current cookie settings :

Code: Select all

    * Cookie domain: .garde-noire.fr
    * Cookie name : phpbb3_garde_noire
    * Cookie path : /
    * Secured cookie : Yes
    * Cookie notice : Yes
Thanks in advance for your help
Generated by SRT Generator

User avatar
warmweer
Registered User
Posts: 2390
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: User connection error from any extension page

Post by warmweer » Tue Aug 13, 2019 8:44 pm

Jostix wrote:
Tue Aug 13, 2019 8:20 pm
Do you have any extensions installed? Yes

What extensions do you have installed? Custom extension
What styles do you currently have installed? Custom style
If the transfer from host was very recent, it may be caused by persistent cookies (or cache) in your users' browser (although I doubt it).
You mention you have a custom style: does the problem also occur with prosilver?
Any extension which may interact with the login process?
My board's not broken, it just went peculiar

Jostix
Registered User
Posts: 3
Joined: Tue Aug 13, 2019 8:14 pm

Re: User connection error from any extension page

Post by Jostix » Tue Aug 13, 2019 8:50 pm

Hi Warmweer,

Thanks for your reply,

I already tried to clean server/cookies cache without success
Yes same error with Prosilver style and no interaction between login process and any installed extension (I tried to deactivate them one by one, still same issue)

It's really weird :/

User avatar
AbaddonOrmuz
Registered User
Posts: 640
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: User connection error from any extension page

Post by AbaddonOrmuz » Tue Aug 13, 2019 8:56 pm

The template on custom pages doesn't contain the required hidden fields (creation_time and form_token), so if the error is not present using prosilver, you might need to contact the author of your custom style.
Some of my phpBB extensions: [ Imgur | SEO Metadata | Markdown ]
Check out all my extensions
Arch Linux user

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50587
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: User connection error from any extension page

Post by stevemaury » Tue Aug 13, 2019 10:05 pm

Any particular reason you have removed the phpBB copyright from your board?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Jostix
Registered User
Posts: 3
Joined: Tue Aug 13, 2019 8:14 pm

Re: User connection error from any extension page

Post by Jostix » Thu Aug 15, 2019 6:12 am

AbaddonOrmuz wrote:
Tue Aug 13, 2019 8:56 pm
The template on custom pages doesn't contain the required hidden fields (creation_time and form_token), so if the error is not present using prosilver, you might need to contact the author of your custom style.
Thanks a lot for your help,

It seems that this the root cause of the issue, I'm trying now to fix it

On extansion side, is there anything we need to implement (i.e in a controller) to setup those two missing hidden fields ? (creation_time and form_token)
Or those two fields are already generated through PHPBB as global variables ?

Thanks again for your help

Post Reply

Return to “[3.2.x] Support Forum”