Page 1 of 1

Unable to install 3.2 on an nginx+apache server

Posted: Sun Aug 18, 2019 1:34 pm
by Leinad4Mind
Hi there,

I am trying to install 3.2 on an nginx+apache server, but it seems to require to edit nginx conf file. Isn't there any other way to bypass this problem? Because this is an managed server and it is very limited, so I can't edit that file and the host will not edit either.

I am looking for another way to bypass this, after all I am able to install 3.1, so maybe there is a way to install and bypass this problem, it seems all related to the app.php thing.

I dont mind to edit core files to bypass this btw.

Re: Unable to install 3.2 on an nginx+apache server

Posted: Sun Aug 18, 2019 3:11 pm
by AbaddonOrmuz
Nginx setups require you to edit those files since almost every configuration is application specific.

If you can't create/edit those files, I would suggest you to use Apache instead, because in order to "fix" the app.php routes you would need to rewrite the system entirely so you can make requests like app.php?key=value

Besides, it seems that the server you're taking about mainly supports Nginx as a reverse/cache proxy.

Re: Unable to install 3.2 on an nginx+apache server

Posted: Sun Aug 18, 2019 4:01 pm
by Leinad4Mind
I see and yeah NGINX proxies all dynamic requests to Apache which in turn communicates with the PHP-FPM worker pools.