is the latest phpbb compatible with PHP v7.3.5?

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
raykai
Registered User
Posts: 90
Joined: Tue Apr 09, 2013 5:32 am

is the latest phpbb compatible with PHP v7.3.5?

Post by raykai »

Hi is the latest phpbb compatible with PHP v7.3.5?

User avatar
janus_zonstraal
Registered User
Posts: 4046
Joined: Sat Aug 30, 2014 1:30 pm

Re: is the latest phpbb compatible with PHP v7.3.5?

Post by janus_zonstraal »

No only until php7.2 is compatible
Sorry! My English is bat ;) !!!

User avatar
warmweer
Jr. Extension Validator
Posts: 3836
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: is the latest phpbb compatible with PHP v7.3.5?

Post by warmweer »

janus_zonstraal wrote:
Tue Aug 20, 2019 4:58 am
No only until php7.2 is compatible
Was that a typo?
phpBB is compatible with php 7.2

php7.3 compatibility for phpbb3.2.x will certainly not be before version 3.2.9 and nothing is even planned for any 3.2.x as far as I know.
phpBB3.3 should be compatible with php 7.3 (and probably higher).
We should embrace problems, without which there wouldn't be any solutions.

User avatar
knoxtane
Registered User
Posts: 13
Joined: Mon Aug 19, 2019 11:11 pm

Re: is the latest phpbb compatible with PHP v7.3.5?

Post by knoxtane »

Pretty sure it's only up to 7.2. I'm running PHP version: 7.2.7

Sorry.

rxu
Extensions Development Team
Posts: 3050
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: is the latest phpbb compatible with PHP v7.3.5?

Post by rxu »

Long story short: no, it isn't.
Unreleased yet phpBB 3.3.0 is.

User avatar
janus_zonstraal
Registered User
Posts: 4046
Joined: Sat Aug 30, 2014 1:30 pm

Re: is the latest phpbb compatible with PHP v7.3.5?

Post by janus_zonstraal »

warmweer wrote:
Tue Aug 20, 2019 7:38 am
janus_zonstraal wrote:
Tue Aug 20, 2019 4:58 am
No only until php7.2 is compatible
Was that a typo?
phpBB is compatible with php 7.2

php7.3 compatibility for phpbb3.2.x will certainly not be before version 3.2.9 and nothing is even planned for any 3.2.x as far as I know.
phpBB3.3 should be compatible with php 7.3 (and probably higher).
Typo :oops:
Sorry! My English is bat ;) !!!

Post Reply

Return to “[3.2.x] Support Forum”