A problem after upgrading to php 7.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
fredbucket
Registered User
Posts: 2
Joined: Thu Sep 05, 2019 3:36 am

A problem after upgrading to php 7.2

Post by fredbucket »

A phpBB Board I administer has recently upgraded to php 7.2. As a result, this bit of code doesnt work anymore - it just gives a blank screen.

Can somebody please suggest what may be wrong. As may be gathered, my skills is this regard are demonstrably non-existent :-)

________________________________________________________________________________
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<html>
<head>
<title>Opus Transcribisticum</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="85,*" cols="*" framespacing="0" frameborder="NO" border="0">
<frame src="searchFrame.php" name="topFrame" scrolling="NO" noresize >
<frame src="searchResultFrame.php?list=komponist" name="resultFrame">
</frameset>
<noframes><body>

</body></noframes>
</html>
________________________________________________________________________________

Thanks for any help.

Regards
Fred
User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7819
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: A problem after upgrading to php 7.2

Post by JimA »

Hi, welcome to phpBB.com! :)

Could you provide a link to your board and the page where you put this?

This isn't a PHP page, rather just HTML that's embedding another PHP page, so isn't too helpful and I also don't see the connection with phpBB at this point. Are you sure it's related to the board?
Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.
User avatar
3Di
Former Team Member
Posts: 16039
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: A problem after upgrading to php 7.2

Post by 3Di »

The issue is the scripts give 500s, hence blank pages. @see: http://prntscr.com/p23pax
http://www.pianophilia.com/ot/

The forum seems to be this one: http://www.pianophilia.com/phpBB3/index.php

http://www.pianophilia.com/phpBB3/viewt ... ?f=32&t=40 (the OP)
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ยบ PhpStorm's proud user ยบ Extensions, Scripts, MOD porting, Update/Upgrades
๐Ÿš€ Looking for a specific feature or alternative option? We will rock you! ๐Ÿš€
User avatar
warmweer
Jr. Extension Validator
Posts: 5547
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: A problem after upgrading to php 7.2

Post by warmweer »

I'm not sure whether phpbb 3.2.3 is compatible with php 7.2.
The problem could perhaps be solved in upgrading to 3.2.7.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
fredbucket
Registered User
Posts: 2
Joined: Thu Sep 05, 2019 3:36 am

Re: A problem after upgrading to php 7.2

Post by fredbucket »

JimA wrote: โ†‘
Thu Sep 05, 2019 8:55 am
Hi, welcome to phpBB.com! :)

Could you provide a link to your board and the page where you put this?

This isn't a PHP page, rather just HTML that's embedding another PHP page, so isn't too helpful and I also don't see the connection with phpBB at this point. Are you sure it's related to the board?
In the sense that it is part of a phpBB board, yes it is :-)

Regards
Fred
User avatar
3Di
Former Team Member
Posts: 16039
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: A problem after upgrading to php 7.2

Post by 3Di »

phpBB 3.2.3 is not fully compatible with PHP 7.2.

Moreover, your 2 files (searchFrame.php and searchResultFrame.php) give 500 Internal server error.

I suspect those 2 files are not compatible with PHP 7.2 as well.

You can try to downgrade to PHP 7.1 and have a look at your error log server side.
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ยบ PhpStorm's proud user ยบ Extensions, Scripts, MOD porting, Update/Upgrades
๐Ÿš€ Looking for a specific feature or alternative option? We will rock you! ๐Ÿš€
Heo32
Registered User
Posts: 182
Joined: Sat Jan 07, 2017 10:08 pm

Re: A problem after upgrading to php 7.2

Post by Heo32 »

3Di wrote: โ†‘
Fri Sep 06, 2019 12:53 am
phpBB 3.2.3 is not fully compatible with PHP 7.2.
Wrong.
Is this for you? Windows & Nginx & PHP & MySQL & phpBB & WordPress & Cloudflare -- Updated: October 17, 2020

Content-Security-Policy: Allow using Content-Security-Policy without unsafe-inline
stevemaury wrote: โ†‘
Sun May 20, 2018 8:16 pm
I went to your board and looked for an hour or so, but did not see the women without underwear.
User avatar
3Di
Former Team Member
Posts: 16039
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: A problem after upgrading to php 7.2

Post by 3Di »

Heo32 wrote: โ†‘
Fri Sep 06, 2019 1:09 am
3Di wrote: โ†‘
Fri Sep 06, 2019 12:53 am
phpBB 3.2.3 is not fully compatible with PHP 7.2.
Wrong.
Nope, is right. I said NOT FULLY.

Example of a fix for 3.2.6-rc1 here: https://tracker.phpbb.com/browse/PHPBB3-15904

Example of a fix for 3.2.4-rc1 here: https://tracker.phpbb.com/browse/PHPBB3-15612

You can lurk at the search page to find the others: https://www.phpbb.com/search/?q=3.2.3+PHP+7.2
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ยบ PhpStorm's proud user ยบ Extensions, Scripts, MOD porting, Update/Upgrades
๐Ÿš€ Looking for a specific feature or alternative option? We will rock you! ๐Ÿš€
Post Reply

Return to โ€œ[3.2.x] Support Forumโ€