Page 1 of 2

Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 4:36 am
by Dzien Dobry
My update from phpBB 3.2.7 to 3.2.8 failed. I got this error message while trying to go to install/app.php/update :
You are running an unsupported PHP version. Please upgrade to PHP equal to or greater than 5.4.7 but less than 7.3-dev in order to install or update to phpBB 3.2
I believe that the failure was due to my PHP version being higher than 7.3. So my host lowered it to PHP 7.2. That didn't change anything. I still got the same error message. What should I do now?

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 4:40 am
by 3Di
Dzien Dobry wrote:
Sun Sep 22, 2019 4:36 am
So my host lowered it to PHP 7.2. That didn't change anything. I still got the same error message.
A link to your board pls?

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 4:45 am
by Dzien Dobry
http://everythingimportant.org/SDA/

I deleted the Install folder, cleared the cache and then tried uploading the Install folder again and trying again. That didn't change anything.

Every page is now a blank screen.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 4:51 am
by 3Di
Check your server's error log, that's a 500 (internal server error).

Unable to catch your PHP version btw, ask your host.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 4:56 am
by Dzien Dobry
I don't know now to check my server's error log but I'll contact my host and share your insight.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 5:19 am
by Dzien Dobry
3Di wrote:
Sun Sep 22, 2019 4:51 am
Check your server's error log, that's a 500 (internal server error).

Unable to catch your PHP version btw, ask your host.
Sir. You are a genius. I was able to successfully update. My PHP version is now 5.6. Should I keep it at that, ask for 7.2 or something else?

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 5:37 am
by 3Di
Dzien Dobry wrote:
Sun Sep 22, 2019 5:19 am
My PHP version is now 5.6. Should I keep it at that, ask for 7.2 or something else?
Yes... You can use 7.2, but not 7.3. ;)

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 5:54 am
by Dzien Dobry
The support agent at my host thought that 5.6 was best. Could a newer version of phpBB fail with PHP 7.2?

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 6:06 am
by Lumpy Burgertushie
phpbb has supported php 7 for quite a while now.
php 5.6 reached end of support a couple of years ago I believe.
so, I would go ahead and update the php to 7.2
not 7.3

that way, when your host finally decides to get rid of php 5.6 you won't have a problem.


robert

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 6:59 am
by janus_zonstraal
The support agent at my host thought that 5.6 was best.
:shock: :? That php version is 2 years end of live and not secure to use.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 9:03 am
by warmweer
Dzien Dobry wrote:
Sun Sep 22, 2019 4:36 am
That didn't change anything. I still got the same error message. What should I do now?
Before you tried again, was the /cache emptied (leaving .htacces and index.htm)
Also in /store the migrationxxx and io_lock.lock shuld be removed before retrying the update.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 6:30 pm
by Dzien Dobry
warmweer wrote:
Sun Sep 22, 2019 9:03 am
Before you tried again, was the /cache emptied (leaving .htacces and index.htm)
Also in /store the migrationxxx and io_lock.lock shuld be removed before retrying the update.
I didn't empty the cache (never did that before) but maybe the tech support guy did that for me knowing that I was encountering a problem.
I see that I have 4 migrationxxx files and 1 io_lock.lock in store. I didn't remove them before I updated. Should I remove them now? I never knew what they were for.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 6:52 pm
by Ancient Viking
I would like to know what I need to do in order to prevent the same thing happening as it did for the OP.

Right now, I am running 3.2.5, my bad I've been lazy and forgot to update to 3.2.6, and my question is.

Can I update directly from 3.2.5 to 3.2.8 when using PHP 7.1?

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 7:20 pm
by Dzien Dobry
Lumpy Burgertushie wrote:
Sun Sep 22, 2019 6:06 am
I would go ahead and update the php to 7.2 not 7.3
My host just now updated my PHP to version 7.2.22.

Re: Update from phpBB 3.2.7 to 3.2.8 failed

Posted: Sun Sep 22, 2019 7:23 pm
by Dzien Dobry
Ancient Viking wrote:
Sun Sep 22, 2019 6:52 pm
I would like to know what I need to do in order to prevent the same thing happening as it did for the OP.

Right now, I am running 3.2.5, my bad I've been lazy and forgot to update to 3.2.6, and my question is.

Can I update directly from 3.2.5 to 3.2.8 when using PHP 7.1?
I went the route of downloading the changed files only. That download had direct updates from many earlier versions to 3.2.8. I'm sure the direct update from 3.2.5 to 3.2.8 was included.

Any PHP equal to or greater than 5.4.7 but less than 7.3-dev should work.