[url] bbcode not formatting links

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Jakeula
Registered User
Posts: 1
Joined: Tue Oct 01, 2019 5:43 pm

[url] bbcode not formatting links

Post by Jakeula » Tue Oct 01, 2019 5:54 pm

Hey everyone,

I have googled this with no success, so I am posting a thread to see if anyone can help here.

I am using phpbb3.2.8 on Ubuntu 18.04 LTS with PHP Version 7.3.9-1+ubuntu18.04.1+deb.sury.org+1 and PCRE Version 10.33 2019-04-16.

When I post a link using bbcode or Markdown (I also have a markdown extension installed) all that shows up is the raw string.

for instance:

Code: Select all

[url="https://google.com]I am a link[/url]
outputs exactly as it is seen above on any page where a user can post a link. mchat and Pages have this same issue. I have ensure mod_rewrite is enabled and working as best I can. Markdown looks exactly the same when I attempt to use the standard markdown syntax:

Code: Select all

[I am a link](https://google.com)
The links in navbars and built into phpbb work fine, so I assume this is not an apache issue, but not ruling it out. I have both bbcode and markdown enabled across the site, and I have disabled both and removed the markdown extension to be sure that there wasn't some type of race between the two parsing the tags. Essentially no url is actually hyperlinked to the strings between the tags. Most solutions I found seem to be focused on PCRE versions being out of date, but I made sure to build PHP with the proper PCRE version when I created the site (although I don't think that was necessary but I did it anyways).

Any ideas as to what might cause url bbcode issues such as this that I could evaluate?

Post Reply

Return to “[3.2.x] Support Forum”