3.0.x to 3.2.8

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

3.0.x to 3.2.8

Post by seanlancaster » Mon Oct 14, 2019 12:43 am

I downloaded 3.2.8 and followed the directions to upgrade from 3.0.x. found here: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/

I kept
The config.php file
The images/ directory
The files/ directory
The store/ directory
and I deleted these from the downloaded 3.2.8 folder. I deleted all other files in my webserver directory and then uploaded the 3.2.8 files.
I had issues with the PHP version, because I had been bumped to 7.3.x. I had to revert back to 7.2.x, which I've done. I couldn't view my site until I did that. I also had to change config.php from mysql to mysqli (because I read it here somewhere and it helped).

When I visit my site now, I get an error on the main page and click login. The login screen looks fine (no errors). But instead of taking me to the index of categories and topics when I login, I get a screen that shows the following:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 583: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 639: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 578: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 583: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 611: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 1835: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3262)
I have this site on Bluehost. I no longer use the site other than a reference, but I need to reference the discussions because it's part of a research project I am doing. Thanks.
-sean

User avatar
3Di
Former Team Member
Posts: 14374
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.0.x to 3.2.8

Post by 3Di » Mon Oct 14, 2019 1:00 am

seanlancaster wrote: ↑
Mon Oct 14, 2019 12:43 am
PHP Warning: in file [ROOT]/phpbb/session.php on line 583: sizeof():
There are not sizeof()s in the current session.php file.
To be honest in the whole core code of 3.2.8 apart a bunch (3) in the fast-image-size's vendor folder.
I assume your files are out of date then.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.0.x to 3.2.8

Post by seanlancaster » Mon Oct 14, 2019 12:44 pm

Aauuugh! I suspect I uploaded an old version of phpBB that was in my download folder then. I unzipped the downloaded file and the resulting folder never appears at the top of the list. I probably scrolled past the most recent one to an old one and uploaded those contents. Thanks for your feedback. I'll download 3.2.8 and try again. I suck.
-sean

User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.0.x to 3.2.8

Post by seanlancaster » Mon Oct 14, 2019 1:19 pm

replaced the files (sans the config.php and 3 folders) and tried again. I can see the install folder in my directory, but going to the URL fails:
Screen Shot 2019-10-14 at 9.17.09 AM.png
I did check the PHP version and it's PHP Version 7.2.23.

Maybe I'll rest my database and files back to October 6 and start all over.
-sean

User avatar
janus_zonstraal
Registered User
Posts: 3738
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.0.x to 3.2.8

Post by janus_zonstraal » Mon Oct 14, 2019 4:21 pm

I can see the install folder in my directory,
Where is it in your directory
Print screen?
Sorry! My English is bat ;) !!!

User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.0.x to 3.2.8

Post by seanlancaster » Mon Oct 14, 2019 7:56 pm

Thanks. It was in the main directory where all files are uploaded /forum in my case).

I have done this multiple times and always end up with the same errors (I think this was try #4). I have currently reset my database to a week ago and my site to a week ago, which is phpbb 3.0.11 (yeah, it's old). But that was just after my host upgraded me to PHP 7.3.x and everything fell apart. I do go in an change config.php to mysqli to ensure I can even access the site. I have also downgraded my PHP to 7.2.x. I can see my board, but the login page has many errors:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 583: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 639: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4516: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3262)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4516: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3262)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4516: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3262)
Sean's Class Forums

Quick linksFAQLogin
Board index
It is currently 14 Oct 2019, 15:39

This board has no forums.
LOGIN
Username: 
 Password: 
 I forgot my password | Remember me  
WHO IS ONLINE
In total there are 2 users online :: 1 registered, 0 hidden and 1 guest (based on users active over the past 10 minutes)
Most users ever online was 35 on 13 Jan 2017, 19:03
BIRTHDAYS
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
No birthdays today

STATISTICS
Total posts 24644 β€’ Total topics 1536 β€’ Total members 216 β€’
Now, if I login, then I just have errors and cannot proceed.

I will upgrade once again to 3.2.8 and I plan to download the whole package yet again and follow the directions step for step. My concern is that I have errors right now as shown above and perhaps I have a fatal error that is causing everything to fail down the road again and again. I didn't plan to use this site in the future beyond grabbing messages out for a research study. But I can't even do that with upgrading, apparently (or maybe I am just out of luck).
-sean

User avatar
3Di
Former Team Member
Posts: 14374
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.0.x to 3.2.8

Post by 3Di » Mon Oct 14, 2019 7:59 pm

3.0.11 does not work on PHP 7.x.xx, you should downgrade to PHP 5.6.40.

Support for 3.0 is ended, you need to upgrade to 3.2.8, you can do it with PHP 5.6.40 then raise to PHP 7.2.xx.

You need the whole lot of new files to replace the old ones.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

User avatar
janus_zonstraal
Registered User
Posts: 3738
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.0.x to 3.2.8

Post by janus_zonstraal » Mon Oct 14, 2019 8:16 pm

I always update to 3.0.14 first, than run STK
Go to 3.1.0, than 3.1.12 and than 3.2.8
Sorry! My English is bat ;) !!!

User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.0.x to 3.2.8

Post by seanlancaster » Tue Oct 15, 2019 12:21 am

Okay, thanks for the tips. I'll try first downgrading PHP as noted by 3Di. Then I'll upgrade slowly to 3.0.14 > STK . . . 3.1.0 > 3.1.12 > 3.2.8. I'd rather be careful at this point. I appreciate folks sticking with me. I was not getting anywhere with my investigations.
-sean

User avatar
3Di
Former Team Member
Posts: 14374
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.0.x to 3.2.8

Post by 3Di » Tue Oct 15, 2019 12:24 am

Update to 3.0.14 > STK -> upgrade to 3.2.8 (with PHP 5.6.xx). ;)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.0.x to 3.2.8

Post by seanlancaster » Tue Oct 15, 2019 6:05 pm

Thanks for your patience.

I got the host to drop me back to PHP 5.6.x.

I logged into my installation and I am apparently at phpBB 3.2.1. My control panel showed 3.0.14, but I suspect I have been manually updating the site and the control panel script site just doesn't know that. Anyway, if I am at 3.2.1 the I find that perplexing, since my board stopped working this past week when my PHP version was upgraded. Shouldn't 3.2.1 have been able to handle PHP 7.2?

Anyway, should I install the STK and then upgrade to 3.2.8? I only learned about STK from this thread, so I want to make sure I can still find it beneficial at this stage. Thanks.
-sean

User avatar
warmweer
Registered User
Posts: 3010
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: 3.0.x to 3.2.8

Post by warmweer » Tue Oct 15, 2019 6:12 pm

seanlancaster wrote: ↑
Tue Oct 15, 2019 6:05 pm
Shouldn't 3.2.1 have been able to handle PHP 7.2?
I don't think so. 7.0 yes, 7.1 perhaps (can't remember)
Stay on 5.6 until you're at 3.2.8 and everything's working: only then switch to php 7.2
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

User avatar
3Di
Former Team Member
Posts: 14374
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.0.x to 3.2.8

Post by 3Di » Tue Oct 15, 2019 9:16 pm

seanlancaster wrote: ↑
Tue Oct 15, 2019 6:05 pm
Anyway, should I install the STK and then upgrade to 3.2.8?
You should roll back to 3.0.xx (DB and files) and do the upgrade from the beginning. Again.
3Di wrote: ↑
Tue Oct 15, 2019 12:24 am
Update to 3.0.14 > STK -> upgrade to 3.2.8 (with PHP 5.6.xx).
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21676
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 3.0.x to 3.2.8

Post by Mick » Wed Oct 16, 2019 9:07 am

seanlancaster wrote: ↑
Tue Oct 15, 2019 6:05 pm
I only learned about STK from this thread topic
That being the case you havn’t read the upgrade instructions properly.
Upgrading from 3.0 to 3.2 wrote: Remove all MOD-related changes from the database. The Support Toolkit's Database Cleaner can be used for this.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
seanlancaster
Registered User
Posts: 87
Joined: Tue May 04, 2004 2:45 pm
Location: michigan

Re: 3.0.x to 3.2.8

Post by seanlancaster » Wed Oct 16, 2019 3:52 pm

Mick wrote: ↑
Wed Oct 16, 2019 9:07 am
seanlancaster wrote: ↑
Tue Oct 15, 2019 6:05 pm
I only learned about STK from this thread topic
That being the case you havn’t read the upgrade instructions properly.
Upgrading from 3.0 to 3.2 wrote: Remove all MOD-related changes from the database. The Support Toolkit's Database Cleaner can be used for this.
I was relying on the directions here: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/

You've quoted the only mention of STK, which is item #5. I know absolutely that I never install any MODs . . . I run a clean system completely for a research project. So, I had no need to address #5 . . . and, the directions are not *must* but *can* even if I had used a MOD. The way I read it, I could have removed the MODs myself, too. Nowhere am I directed to absolutely install STK. I am adding it because I've now read up on it, but I wouldn't have known to do so using the upgrade instructions.
-sean

Post Reply

Return to β€œ[3.2.x] Support Forum”