phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69430
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Post by KevC » Wed Oct 16, 2019 7:21 pm

ok So I think your best bet is to find some common ground on a php version where you can run your 2x board and either 3.0 or 3.1 and then from there move up on php to where you can go to 3.2. I don't think there's a version of php that will support 2x and 3.2.x

If your starter installation of 3.2 is getting bots, just turn off registration for the moment in the user registration settings. It'll all get overwritten when the board gets converted though.

There is an extension to add accounts manually.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
warmweer
Registered User
Posts: 3050
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Post by warmweer » Wed Oct 16, 2019 7:48 pm

KevC wrote:
Wed Oct 16, 2019 7:21 pm
ok So I think your best bet is to find some common ground on a php version where you can run your 2x board and either 3.0 or 3.1 and then from there move up on php to where you can go to 3.2. I don't think there's a version of php that will support 2x and 3.2.x
There is none.

Just recently (and also a couple of months ago another member) someone needed converting from 2.0.x to 3.2.x and we searched for old versions of easyphp on which both 2.0 and 3.0 cold run. IIRC he ended up using old version of Xamp or Wamp but perhaps it was easyphp version. In the end it wasn't all that difficult to upgrade on localhost.

a quick search came up with this : viewtopic.php?f=556&t=2522856&p=1532208 ... #p15322086
Still, the TS has to get his 2.0 version up and running so he'll need the 2.0 database
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

User avatar
ComoEJ
Registered User
Posts: 15
Joined: Mon Oct 14, 2019 10:01 pm
Location: Los Angeles County, California
Name: E.J. Carpathia
Contact:

Re: phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Post by ComoEJ » Wed Oct 16, 2019 8:27 pm

Greetings,

My phpBB 2.0.23 is getting the spambot registrations and I'm looking for a way to terminate that from happening by making it so the only way to add an account is manually through the Admin Panel.

Does anyone remember how to do this? I would greatly appreciate it!

Sincerely,
E.J.
Commodore E.J. Carpathia
Division 1 Commander, Gamma Fleet
Starfleet, United Federation of Planets

~ www.gammafleet.org ~

User avatar
3Di
Former Team Member
Posts: 14382
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Post by 3Di » Wed Oct 16, 2019 8:36 pm

KevC wrote:
Wed Oct 16, 2019 7:21 pm
I don't think there's a version of php that will support 2x and 3.2.x
PHP 5.4.7 or 5.6.xx should do. Not tested here.

Example here: https://phpbb2refugees.com/index.php (X-Powered-By: PHP/5.6.40)
ComoEJ wrote:
Wed Oct 16, 2019 8:27 pm
My phpBB 2.0.23
There is no support for 2.0.xx (ended long ago), you should ask at the above link (phpBB2 refugees).
Last edited by 3Di on Wed Oct 16, 2019 8:37 pm, edited 1 time in total.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69430
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Post by KevC » Wed Oct 16, 2019 8:36 pm

You should be able to disable registration for the moment. I can't remember where that is though.
The surefire way to stop bots on 2x was something called the RAC MOD but goodness knows if you can still find it anywhere.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
warmweer
Registered User
Posts: 3050
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: phpBB 2.0.23 to phpBB 3.2.8 conversion problem

Post by warmweer » Wed Oct 16, 2019 8:42 pm

ComoEJ wrote:
Wed Oct 16, 2019 6:03 pm
I did get my phpBB 2.0.23 up and running on another server that is still running PHP 4.4! So 14 years of posts are not lost.
OK, so now you can upgrade to 3.0.14, and then transfer that to the server which will allow upgrading to 3.2
ComoEJ wrote:
Wed Oct 16, 2019 6:03 pm
Does anyone remember how to stop the spambots from registering on the forum?
Just turn off registration for the time being. Remove the spam registrations and then upgrade. Once you're on 3.2 you can re-allow registration using the Q&A to hold back spambots.
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

Post Reply

Return to “[3.2.x] Support Forum”

cron