Email not Working

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
John connor
Registered User
Posts: 2293
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Email not Working

Post by John connor » Fri Oct 18, 2019 9:40 am

Do your email settings look exactly like this? download/file.php?id=228171&mode=view

Also, I don't think hostgator is the best hosting site in the world.

User avatar
John connor
Registered User
Posts: 2293
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Email not Working

Post by John connor » Fri Oct 18, 2019 9:21 pm

Something else you can try is checking if the SMTP port is alive via telnet.

To do this in Windows you'll have to install telnet first. To do that type features in the search under start. Click Programs and Features. See screenshot. Go to turn Windows features on and off. In Win 7 it's on the left hand side. Telnet is a Windows feature that you can install. Look for Telnet Client and check it off. Important. Not the telnet server, the client.


Image




Now once you have telnet installed go to search under start and enter cmd to launch command prompt. Type in:

Code: Select all

telnet [your server IP address] 587
So as an example:

Code: Select all

telnet 127.0.0.1 587
That should generate some kind of connection if successful. Another port is 465.

If this works then your host allows SMTP from your host's email offerings.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21659
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Email not Working

Post by Mick » Sat Oct 19, 2019 9:45 am

In Windows command prompt, type ping mail.example.com where "mail.example.com" is the name or IP address of the SMTP server you intend to use. Normally, if an SMTP server is reachable, it should reply.
"The more connected we get the more alone we become" - Kyle Broflovski

revmyev
Registered User
Posts: 12
Joined: Wed Oct 16, 2019 12:00 am

Re: Email not Working

Post by revmyev » Sat Oct 19, 2019 12:49 pm

Thanks for all the help and suggestions. I ended up deleting and reinstalling at 3.2.8 and the email connection now works!! I do have another forum I setup at the same time, so I’ll try the above if I run into the same problems.

Post Reply

Return to “[3.2.x] Support Forum”