LOgin error The submitted form was invalid. Try submitting again.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
in_so@pta
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 11:45 am

LOgin error The submitted form was invalid. Try submitting again.

Post by in_so@pta » Sat Oct 19, 2019 9:21 pm

Support Request Template
What version of phpBB are you using? phpBB 3.2.8
What is your board's URL? http://forum.zonek.ro
Who do you host your board with? www.gazduire.net
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.7
What extensions do you have installed? No answer given
What styles do you currently have installed? elegance_steelblue
What language(s) is your board currently using? english
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? in_so@pta
What password can be used to view this issue? [removed]
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? updating board adn data base
Please describe your problem. Whne i try to login i recive thi error : The submitted form was invalid. Try submitting again.
and is not working also the admin panel , is not working to login.
Generated by SRT Generator

User avatar
janus_zonstraal
Registered User
Posts: 3749
Joined: Sat Aug 30, 2014 1:30 pm

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by janus_zonstraal » Sat Oct 19, 2019 9:50 pm

Delete the production and installer folder from your cache folder with ftp
Try again.
Otherwise update your style to the 3.2.8 version.
Sorry! My English is bat ;) !!!

User avatar
EA117
Registered User
Posts: 1076
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by EA117 » Sat Oct 19, 2019 10:01 pm

Also, I'm not seeing any fundamental problem with the login form or with the cookies currently being used on your site. So what if you delete the current-saved cookies in your web browser and try again. Is the login successful then?

in_so@pta
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 11:45 am

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by in_so@pta » Sat Oct 19, 2019 10:03 pm

I did this right now but i recive the same error, i must update the style, but i search here on the forum and i find some people whit the same error but whit no clear directions to to that. So of course the 1 bilion dollars question is How i do That? Also ACP is not working, the same error.

User avatar
janus_zonstraal
Registered User
Posts: 3749
Joined: Sat Aug 30, 2014 1:30 pm

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by janus_zonstraal » Sat Oct 19, 2019 10:08 pm

You can access your board also on https https://forum.zonek.ro/
Did you overwrite the old .htaccess with the redirect?
On what address are you try to login ?
Sorry! My English is bat ;) !!!

in_so@pta
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 11:45 am

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by in_so@pta » Sat Oct 19, 2019 10:22 pm

I add this line in .htacces

Code: Select all

Redirect 301 / https://forum.zonek.ro/
And is working to login now, i will do more tests in the next hour to see if there is another problem.
Last edited by in_so@pta on Sun Oct 20, 2019 12:57 am, edited 1 time in total.

User avatar
janus_zonstraal
Registered User
Posts: 3749
Joined: Sat Aug 30, 2014 1:30 pm

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by janus_zonstraal » Sat Oct 19, 2019 10:26 pm

Better to try this code

Code: Select all

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
</IfModule>
And set your cookies to secure!
Sorry! My English is bat ;) !!!

in_so@pta
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 11:45 am

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by in_so@pta » Sat Oct 19, 2019 10:49 pm

janus_zonstraal wrote:
Sat Oct 19, 2019 10:26 pm
Better to try this code

Code: Select all

<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
</IfModule>
And set your cookies to secure!
You can edit the code whit my forum adress to see where i jave to put it? I'm new. https://forum.zonek.ro

User avatar
janus_zonstraal
Registered User
Posts: 3749
Joined: Sat Aug 30, 2014 1:30 pm

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by janus_zonstraal » Sat Oct 19, 2019 10:55 pm

just put it thisway into your .htaccess, no need to edit

The whole .htaccess:

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Sorry! My English is bat ;) !!!

in_so@pta
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 11:45 am

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by in_so@pta » Sun Oct 20, 2019 12:55 am

janus_zonstraal wrote:
Sat Oct 19, 2019 10:55 pm
just put it thisway into your .htaccess, no need to edit

The whole .htaccess:

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
I have the same problem after i put your code.

Code: Select all

The submitted form was invalid. Try submitting again. 
What i have to do more? i put a style 3.2.8
and also now i have this error:

Code: Select all

This site can’t provide a secure connection
forum.zonek.ro sent an invalid response.

Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

User avatar
janus_zonstraal
Registered User
Posts: 3749
Joined: Sat Aug 30, 2014 1:30 pm

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by janus_zonstraal » Sun Oct 20, 2019 8:10 am

Ask your host how to redirect to https.
Sorry! My English is bat ;) !!!

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21681
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by Mick » Sun Oct 20, 2019 8:27 am

Make sure you’ve set up ssl correctly, cookie secure requires enabling if you’re using ssl, see Fixing incorrect cookie settings.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
3Di
Former Team Member
Posts: 14381
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by 3Di » Sun Oct 20, 2019 8:28 am

janus_zonstraal wrote:
Sat Oct 19, 2019 10:55 pm
just put it thisway into your .htaccess, no need to edit

The whole .htaccess:

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
    
- SNIP -
Why?

Code: Select all

RewriteEngine on
RewriteEngine On
Please see: https://phpbbstudio.com/kb/website/(hta ... -for-phpbb
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

User avatar
janus_zonstraal
Registered User
Posts: 3749
Joined: Sat Aug 30, 2014 1:30 pm

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by janus_zonstraal » Sun Oct 20, 2019 8:33 am

Oops :oops:

Sorry, only one time RewriteEngine On
Sorry! My English is bat ;) !!!

in_so@pta
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 11:45 am

Re: LOgin error The submitted form was invalid. Try submitting again.

Post by in_so@pta » Sun Oct 20, 2019 10:12 am

Hello, i put the file cookie.php and look when i try to acces the adress https://forum.zonek.ro/cookie.php

Code: Select all

RewriteEngine on RewriteCond %{HTTPS} !=on RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L] # # Uncomment the statement below if URL rewriting doesn't # work properly. If you installed phpBB in a subdirectory # of your site, properly set the argument for the statement. # e.g.: if your domain is test.com and you installed phpBB # in http://www.test.com/phpBB/index.php you have to set # the statement RewriteBase /phpBB/ # #RewriteBase / # # Uncomment the statement below if you want to make use of # HTTP authentication and it does not already work. # This could be required if you are for example using PHP via Apache CGI. # #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] # # The following 3 lines will rewrite URLs passed through the front controller # to not require app.php in the actual URL. In other words, a controller is # by default accessed at /app.php/my/controller, but can also be accessed at # /my/controller # RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ app.php [QSA,L] # # If symbolic links are not already being followed, # uncomment the line below. # http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/ # #Options +FollowSymLinks # With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from # module mod_authz_host to a new module called mod_access_compat (which may be # disabled) and a new "Require" syntax has been introduced to mod_authz_host. # We could just conditionally provide both versions, but unfortunately Apache # does not explicitly tell us its version if the module mod_version is not # available. In this case, we check for the availability of module # mod_authz_core (which should be on 2.4 or higher only) as a best guess. Order Allow,Deny Deny from All Order Allow,Deny Deny from All = 2.4> Require all denied Require all denied Order Allow,Deny Deny from All Order Allow,Deny Deny from All Require all denied Require all denied
I also put the .htacces that you gaive to me. for the moment i can t acces the administrator panel to modifi the cookie settings in .forum.zonek.ro and select secure

Post Reply

Return to “[3.2.x] Support Forum”