[3.2.8] php 7.3

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
demokrit
Registered User
Posts: 4
Joined: Fri Oct 25, 2019 2:00 pm

[3.2.8] php 7.3

Post by demokrit »

I'm currently trying to install the latest version of the phpBB (3.2.8) and run into a problem: "You are running an unsupported PHP version. Please upgrade to PHP equal to or greater than 5.4.7 but less than 7.3-dev in order to install or update to phpBB 3.2"

Can't be serious? Can it? I'm running stable php 7.3.9 on a stable Debian 10 environment (7.3.9-1~deb10u1). What Can I do? I would expect, phpBB is running on actual stable versions? I can change the version check in install/app.php to come to the next page. But there I'm also stuck while no database is shown to be selected. What do I need to do? Im running MySQL: 5.5.5-10.3.17-MariaDB.

Please help---
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51386
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: [3.2.8] php 7.3

Post by stevemaury »

phpBB 3.x is not compatible with php > = 7.3 dev.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 903
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: [3.2.8] php 7.3

Post by AbaddonOrmuz »

Change your PHP version to 7.2

phpBB 3.3.x will be compatible with PHP 7.3, so you will need to wait for it to be released.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
demokrit
Registered User
Posts: 4
Joined: Fri Oct 25, 2019 2:00 pm

Re: [3.2.8] php 7.3

Post by demokrit »

downgrade is not trivial while php 7.3 being default package in Debian 10. When can phpBB 3.3 expected to be released?
User avatar
david63
Registered User
Posts: 17912
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2.8] php 7.3

Post by david63 »

demokrit wrote:
Sat Oct 26, 2019 10:01 am
When can phpBB 3.3 expected to be released?
Beta 1 was released this week but there is no ETA for a final version.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 903
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: [3.2.8] php 7.3

Post by AbaddonOrmuz »

demokrit wrote:
Sat Oct 26, 2019 10:01 am
downgrade is not trivial while php 7.3 being default package in Debian 10. When can phpBB 3.3 expected to be released?
You could build it from source, sadly that's what I've been doing for my server, though it seems to be easier to do on Arch Linux than on Debian :P
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
warmweer
Jr. Extension Validator
Posts: 4729
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: [3.2.8] php 7.3

Post by warmweer »

demokrit wrote:
Fri Oct 25, 2019 2:11 pm
I'm currently trying to install the latest version of the phpBB (3.2.8) and run into a problem: "You are running an unsupported PHP version. Please upgrade to PHP equal to or greater than 5.4.7 but less than 7.3-dev in order to install or update to phpBB 3.2"

Can't be serious? Can it?
Why not serious? It's not as though every single forumpackage available is compatible with php 7.3 at this time and neither are released extensions for phpBB).
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
demokrit
Registered User
Posts: 4
Joined: Fri Oct 25, 2019 2:00 pm

Re: [3.2.8] php 7.3

Post by demokrit »

warmweer wrote:
Sun Oct 27, 2019 6:42 pm
Why not serious? It's not as though every single forumpackage available is compatible with php 7.3 at this time and neither are released extensions for phpBB).
php 7.3 is stable since December 2018. No problems with WordPress, Piwigo and other tools. Changes are not so significant to 7.2 (at least if changes and deprecation notes there had been considered). So excuse my surprise, that phpBB is not yet supporting the current and latest php version - at least the basic install.
User avatar
3Di
Former Team Member
Posts: 15635
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [3.2.8] php 7.3

Post by 3Di »

demokrit wrote:
Tue Oct 29, 2019 4:35 pm
php 7.3 is stable since December 2018. No problems with WordPress, Piwigo and other tools. Changes are not so significant to 7.2 (at least if changes and deprecation notes there had been considered). So excuse my surprise, that phpBB is not yet supporting the current and latest php version - at least the basic install.
Are the dependencies of phpBB 3.2.x (ZEND framework) which don't permit to use PHP 7.3, not phpBB itself.

The incoming phpBB 3.3.0 will support it, here is a beta version to test: https://area51.phpbb.com/phpBB/viewtopi ... 81&t=72086
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Looking for a specific feature or alternative option?
User avatar
dingus33
Registered User
Posts: 135
Joined: Fri Sep 29, 2017 11:11 am

Re: [3.2.8] php 7.3

Post by dingus33 »

demokrit wrote:
Sat Oct 26, 2019 10:01 am
downgrade is not trivial while php 7.3 being default package in Debian 10. When can phpBB 3.3 expected to be released?
don't downgrade. just install sury's php 7.2 package alongside debian's 7.3.
https://deb.sury.org/ wrote: Who am I?
I am a Debian Developer since year 2000, and I have been packaging PHP for Debian since PHP 5. That means the official packages in Debian and Ubuntu are either my work or they are based on my work. The PHP packages in my Ubuntu PPA and Debian DPA matches the official packages in Debian. Basically I am saying that you can’t get any closer than that.
read this bash script: https://packages.sury.org/php/README.txt

then install it (adds the sury repo):

Code: Select all

sudo apt-get update
sudo apt-get install curl
curl https://packages.sury.org/php/README.txt | bash
finally, install the packages you need based on requirements.

i like nginx (webserver) and postgres (db), so i install these:

Code: Select all

sudo apt-get install php7.2-fpm php7.2-pgsql php7.2-gd php7.2-imagick php7.2-xml php7.2-curl
further reading to help you pick your packages: https://www.phpbb.com/support/docs/en/3.2/ug/
Post Reply

Return to “[3.2.x] Support Forum”