Updating from phpBB-3.2.2_to_3.2.8 failure

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
muratbora
Registered User
Posts: 13
Joined: Thu Feb 15, 2018 8:15 am

Updating from phpBB-3.2.2_to_3.2.8 failure

Post by muratbora » Wed Nov 06, 2019 5:07 pm

Updating from phpBB-3.2.2_to_3.2.8 failure;
Today I tred to update PHPBB forum from Updating from phpBB-3.2.2_to_3.2.8 , I have downloaded Updating from phpBB-3.2.2_to_3.2.8.zip and loaded /forum/ folder after removing all files except;
The config.php file
The images/ directory
The files/ directory
The store/ directory
(The ext/ directory
as adviced https://www.phpbb.com/support/documents ... pdate_auto

I have Browsed to /install/app.php/update
But it gave error;

Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31

Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31

Fatal error: require(): Failed opening required '../includes/startup.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31

What could be reason and how to solve it?

User avatar
warmweer
Registered User
Posts: 3055
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by warmweer » Wed Nov 06, 2019 5:17 pm

muratbora wrote:
Wed Nov 06, 2019 5:07 pm
What could be reason and how to solve it?
Have you previously updated using autoupdate?
If that's the case, check your /store and remove and install_config.php (and while you're at it also any migrationsxxx and io_lock.lock)
Empty /cache leaving index.htm and .htaccess in place and retry
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

muratbora
Registered User
Posts: 13
Joined: Thu Feb 15, 2018 8:15 am

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by muratbora » Wed Nov 06, 2019 5:30 pm

I do not remember whether previously updated using autoupdate...Probably not...Forum was not visited/checked by me within last 12 months.
Checked /store and removed and install_config.php, io_lock.lock, None migrationsxxx...only
No /cache folder!

I have tried to browse https://www.kayak-merkezleri.com/forum/ ... php/update,
It still gives same error;

User avatar
warmweer
Registered User
Posts: 3055
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by warmweer » Wed Nov 06, 2019 5:37 pm

muratbora wrote:
Wed Nov 06, 2019 5:30 pm
No /cache folder!
Download the full 328 package and copy the /cache folder to your forum root.
While you're at it, you may want to do a full directory compare (including all subdirectories) to check whether something else is missing.

hmm?? I see

Information phpBB is not installed yet.
What happened to the config.php?
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

muratbora
Registered User
Posts: 13
Joined: Thu Feb 15, 2018 8:15 am

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by muratbora » Wed Nov 06, 2019 5:44 pm

While you checked my site, I had removed all files and loaded full 328 package to check what happen! Because it says I can also Upload the contents of the 3.2.8

Now, I have loaded backup and site is working...
And Now I will try again steps for update;

5. Updating from phpBB 3.0.x/3.1x to phpBB 3.2.x
Updating from phpBB 3.0.x or 3.1.x to 3.2.x is just the same as updating from stable releases of phpBB 3.2.x

However you can also start with a new set of phpBB 3.2.x files.

Delete all files EXCEPT for the following:
The config.php file
The images/ directory
The files/ directory
The store/ directory
(The ext/ directory
Upload the contents of the 3.2.x Full Package into your forum's directory. Make sure the root level .htaccess file is included in the upload.
Browse to /install/app.php/update
Read the notice Update database only and press Submit
Delete the install/ directory

****
Should cache/ folder not to be removed?

User avatar
warmweer
Registered User
Posts: 3055
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by warmweer » Wed Nov 06, 2019 5:51 pm

muratbora wrote:
Wed Nov 06, 2019 5:44 pm
Should cache/ folder not to be removed?
No.
When using the full package, it can be removed because the full package contains the /cache.
The changed files package doesn't need the /cache since that is normally not changed .
The /cache is needed because that where the production files are created (in a new directory /production ).
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

muratbora
Registered User
Posts: 13
Joined: Thu Feb 15, 2018 8:15 am

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by muratbora » Wed Nov 06, 2019 6:13 pm

İt is still giving error, and I am unable to proceed for update!
Also error file recorded under /install folder;

[06-Nov-2019 18:03:28 UTC] PHP Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:03:28 UTC] PHP Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:03:28 UTC] PHP Fatal error: require(): Failed opening required '../includes/startup.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:13:15 UTC] PHP Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:13:15 UTC] PHP Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:13:15 UTC] PHP Fatal error: require(): Failed opening required '../includes/startup.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:16:39 UTC] PHP Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:16:39 UTC] PHP Warning: require(../includes/startup.php): failed to open stream: No such file or directory in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31
[06-Nov-2019 18:16:39 UTC] PHP Fatal error: require(): Failed opening required '../includes/startup.php' (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear') in /home/mrtsoftw/www.kayak-merkezleri.com/forum/install/startup.php on line 31

User avatar
EA117
Registered User
Posts: 1081
Joined: Wed Aug 15, 2018 3:23 am
Contact:

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by EA117 » Wed Nov 06, 2019 6:28 pm

muratbora wrote:
Wed Nov 06, 2019 5:07 pm
I have downloaded Updating from phpBB-3.2.2_to_3.2.8.zip and loaded /forum/ folder after removing all files except...
This part was wrong back when those steps were being attempted. "Delete everything except config.php, /images, /files, /store and /ext" are instructions used for the full update package. The phpBB-3.2.2_to_3.2.8.zip is an automatic update package, contains only the files needed to get between the two named phpBB versions, and expects that you still have your phpBB 3.2.2 files in place when starting the automatic update instructions. Seeing the error "require(../includes/startup.php) failed" is because the /includes directory along with all the other phpBB 3.2.2 folders had been removed, which was not expected for the automatic update package install process.
muratbora wrote:
Wed Nov 06, 2019 5:44 pm
However you can also start with a new set of phpBB 3.2.x files.

Delete all files EXCEPT for the following:
The config.php file
The images/ directory
The files/ directory
The store/ directory
(The ext/ directory
Upload the contents of the 3.2.x Full Package into your forum's directory. Make sure the root level .htaccess file is included in the upload.
Browse to /install/app.php/update
Read the notice Update database only and press Submit
Delete the install/ directory
Yes, this is the approach you should be using at this point, in order to simply eliminate the factor of "what files might be missing that the automatic update would require." But note those instructions you quoted are specifically saying "Upload the contents of the 3.2.x Full Package", not the phpBB-3.2.2_to_3.2.8.zip package. There is also a fuller set of instructions for performing the full package update available from Knowledge Base - Updating 3.2.x.

Your site is right now at this moment still showing the "require(../includes/startup.php) failed" error, so I'm assuming you are still in a state of "I have removed all the folders as instructed by the full package update instructions, but have actually only uploaded the phpBB-3.2.2_to_3.2.8.zip package files." Which is why the /includes folder, as well as presumably many other folders, are considered missing.

User avatar
warmweer
Registered User
Posts: 3055
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by warmweer » Wed Nov 06, 2019 6:36 pm

muratbora wrote:
Wed Nov 06, 2019 6:13 pm
İt is still giving error, and I am unable to proceed for update!
OK, I suspect you deleted files and directory's from your board root directory instead of from the changedfiles package.
Let's establish the starting situation in full first.
You have a 3.2.2 board (in working order I presume) (also a database and files backup which you made before starting the update process)

Edited: since EA117 apparently suspects the same.

Post the Support Request Template here so as provide as much info a possible. The directories and files you removed are not necessarily a problem (and certainly not if you have a backup), and your config.php can be rebuilt if you have phpMyAdmin access.
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

muratbora
Registered User
Posts: 13
Joined: Thu Feb 15, 2018 8:15 am

Re: Updating from phpBB-3.2.2_to_3.2.8 failure

Post by muratbora » Wed Nov 06, 2019 7:53 pm

The given update tutorial page ( English ) is not well described, or my English is not so good to understand all...
Finally I found tutorial into Turkish https://www.phpbbturkey.com/forums/view ... 60&t=21819,
I followed it, it was very easy and completed updating into 3 seconds. Problem was " language "

Thank you for your effort and help!

Post Reply

Return to “[3.2.x] Support Forum”