so this just happened for no reason

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
lobsterman
Registered User
Posts: 10
Joined: Wed Mar 02, 2011 11:09 am

so this just happened for no reason

Post by lobsterman » Wed Nov 06, 2019 6:50 pm

Code: Select all

Fatal error: Uncaught Error: Call to undefined method phpbb\di\service_collection::getArrayCopy() in C:\xampp\htdocs\site\phpbb\di\service_collection_iterator.php:35 Stack trace: #0 C:\xampp\htdocs\site\phpbb\di\service_collection.php(49): phpbb\di\service_collection_iterator->__construct(Object(phpbb\di\service_collection)) #1 C:\xampp\htdocs\site\phpbb\template\twig\twig.php(100): phpbb\di\service_collection->getIterator() #2 C:\xampp\htdocs\site\cache\production\container_4335734bbdd20f586549a504dff5f80c.php(6048): phpbb\template\twig\twig->__construct(Object(phpbb\path_helper), Object(phpbb\config\db), Object(phpbb\template\context), Object(phpbb\template\twig\environment), './cache/product...', Object(phpbb\user), Object(phpbb\di\service_collection), Object(phpbb\extension\manager)) #3 C:\xampp\htdocs\site\vendor\symfony\dependency-injection\Container.php(295): phpbb_cache_container->getTemplateService() #4 C:\xampp\htdocs\site\vendor\symfony\dependency-injection\ContainerBuilder.php(446): Symfony\Component\Dependenc in C:\xampp\htdocs\site\phpbb\di\service_collection_iterator.php on line 35

User avatar
warmweer
Registered User
Posts: 3055
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: so this just happened for no reason

Post by warmweer » Wed Nov 06, 2019 6:56 pm

Perhaps no reason but there surely is a cause
quoting MIck:
Mick wrote:
Wed Nov 06, 2019 6:51 pm
Please fill out the Support Request Template and post it back here to enable us to assist you better.
It's actually on localhost so make sure to include board version, php version (in fact your Xamp version).
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66858
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: so this just happened for no reason

Post by Lumpy Burgertushie » Wed Nov 06, 2019 6:58 pm

do you have this board accessible to the internet from your home computer?
it is an xamp installation which is not a good idea.

anyway, try purging the cache, try rebooting the computer,
if the board was working before and just quit, that means something has changed. either you changed something or windows in all its glory has lost its mind which happens to my computer quite often.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

lobsterman
Registered User
Posts: 10
Joined: Wed Mar 02, 2011 11:09 am

Re: so this just happened for no reason

Post by lobsterman » Wed Nov 06, 2019 7:03 pm

it seemed start when i activated google auto ads

https://vtarcade.com

running all the latest versions oh phpbb
php i think is 7.1 but it was all fine weird

i’m at work i’ll check localhost when i get home
Last edited by lobsterman on Wed Nov 06, 2019 7:14 pm, edited 1 time in total.

User avatar
david63
Registered User
Posts: 16718
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: so this just happened for no reason

Post by david63 » Wed Nov 06, 2019 7:13 pm

lobsterman wrote:
Wed Nov 06, 2019 7:03 pm
it seemed start when i activated google auto ads
Then there is your answer.

From what I have been reading elsewhere Google have changed the way that ads work - yet another reason to avoid anything Google!
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

lobsterman
Registered User
Posts: 10
Joined: Wed Mar 02, 2011 11:09 am

Re: so this just happened for no reason

Post by lobsterman » Wed Nov 06, 2019 7:31 pm

and yes i have deleted cache i deleted the whole production folder but still same error, ill probly just replace all the 3.2.8 upgrade files see if that works lol

User avatar
warmweer
Registered User
Posts: 3055
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: so this just happened for no reason

Post by warmweer » Wed Nov 06, 2019 7:32 pm

Is your board really self-hosted on your PC, open to the internet?
If yes, start thinking about getting a real webhost.
Safely hosting on your home a PC requires some serious knowledge. All the personal webserver software dissuade doing that.
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

lobsterman
Registered User
Posts: 10
Joined: Wed Mar 02, 2011 11:09 am

Re: so this just happened for no reason

Post by lobsterman » Wed Nov 06, 2019 8:05 pm

:lol: it’s all good i might get a webhost but i been hosting on my own for years lol

Post Reply

Return to “[3.2.x] Support Forum”