Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
wyclef
Registered User
Posts: 34
Joined: Thu Mar 24, 2005 9:22 pm

Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by wyclef » Mon Dec 02, 2019 2:40 pm

Hey, I have an old PHPBB board with a customized Subsilver2 theme running v3.0.14 on PHP 5.6 and I need to upgrade. Wondering if I upgrade to the latest version of PHPBB if the Subsilver2 theme I am using will need to be changed significantly and if so, if there is a lower version of PHPBB that might work with PHP 7.2 and my theme a bit better as I do not have the time to make significant updates right now. Thanks.

User avatar
warmweer
Registered User
Posts: 3216
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by warmweer » Mon Dec 02, 2019 2:49 pm

wyclef wrote:
Mon Dec 02, 2019 2:40 pm
Hey, I have an old PHPBB board with a customized Subsilver2 theme running v3.0.14 on PHP 5.6 and I need to upgrade. Wondering if I upgrade to the latest version of PHPBB if the Subsilver2 theme I am using will need to be changed significantly and if so, if there is a lower version of PHPBB that might work with PHP 7.2 and my theme a bit better as I do not have the time to make significant updates right now. Thanks.
Your best bet is to update to 3.2.8 and use a style similar to the one you're using now. There's Allan style subsilver.
Just make sure that when updating your board prosilver is the only active style on the board.
https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

wyclef
Registered User
Posts: 34
Joined: Thu Mar 24, 2005 9:22 pm

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by wyclef » Mon Dec 02, 2019 6:12 pm

Maybe I will just upgrade and use Prosilver default and then worry about the theme at a later date since it seems this will end up being more involved than updating the boards. I will check out Allan Subsilver.

Wirral Talk
Registered User
Posts: 64
Joined: Mon Jun 09, 2014 12:29 am
Location: Wirral, UK
Contact:

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by Wirral Talk » Mon Dec 09, 2019 3:37 pm

I'd also consider changing host, any host that forces a single version on you is probably going to bite you again in the future.

User avatar
P_I
Registered User
Posts: 959
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by P_I » Mon Dec 09, 2019 3:58 pm

wyclef wrote:
Mon Dec 02, 2019 2:40 pm
Hey, I have an old PHPBB board with a customized Subsilver2 theme running v3.0.14 on PHP 5.6 and I need to upgrade.
Both the phpBB version and the PHP are long past end of life as I'm sure the OP is aware, hence the need to upgrade that they mention.
Wirral Talk wrote:
Mon Dec 09, 2019 3:37 pm
I'd also consider changing host, any host that forces a single version on you is probably going to bite you again in the future.
I'd counter with the viewpoint that a hosts shouldn't be offering a long out-of-date version of PHP, such as PHP 5.6, (PHP: Supported Versions) and should be actively encouraging sites to update to supported versions.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

Wirral Talk
Registered User
Posts: 64
Joined: Mon Jun 09, 2014 12:29 am
Location: Wirral, UK
Contact:

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by Wirral Talk » Mon Dec 09, 2019 4:26 pm

P_I wrote:
Mon Dec 09, 2019 3:58 pm
I'd counter with the viewpoint that a hosts shouldn't be offering a long out-of-date version of PHP, such as PHP 5.6, (PHP: Supported Versions) and should be actively encouraging sites to update to supported versions.
I agree in an ideal world but phpBB is living proof of the chain of upgrades required. How many mods, extensions, styles etc are updated in a timely manner or even declare that they will be updated. Its not long ago that phpBB itself wouldn't operate under php 7.2 which left an extremely small window of time after 7.1 was eol'd.

Even php 7.2 is now past its active support date, how many people could confidently upgrade to 7.3 right now which is in theory where hosts should be?

invenio
Registered User
Posts: 125
Joined: Wed Dec 09, 2015 1:45 pm
Location: New Hampshire, USA
Contact:

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by invenio » Mon Dec 09, 2019 5:10 pm

php 7.2 is supported for another year. I think you are referring to 7.1 (for which support ended this past month).

https://en.wikipedia.org/wiki/PHP

User avatar
warmweer
Registered User
Posts: 3216
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by warmweer » Mon Dec 09, 2019 5:32 pm

invenio wrote:
Mon Dec 09, 2019 5:10 pm
php 7.2 is supported for another year. I think you are referring to 7.1 (for which support ended this past month).

https://en.wikipedia.org/wiki/PHP
Actually officially 7.2's active support has ended, but there will be security fixes (if necessary) for another year (approximately).
https://www.php.net/supported-versions.php
The year is 2192. The British Prime Minister visits Brussels to ask for an extension of the Brexit deadline. No one remembers where this tradition originated, but every year it attracts many tourists from all over the world.

invenio
Registered User
Posts: 125
Joined: Wed Dec 09, 2015 1:45 pm
Location: New Hampshire, USA
Contact:

Re: Need to upgrade from 3.0.14. Host upgrading to PHP 7.2.

Post by invenio » Mon Dec 09, 2019 6:32 pm

warmweer wrote:
Mon Dec 09, 2019 5:32 pm
invenio wrote:
Mon Dec 09, 2019 5:10 pm
php 7.2 is supported for another year. I think you are referring to 7.1 (for which support ended this past month).

https://en.wikipedia.org/wiki/PHP
Actually officially 7.2's active support has ended, but there will be security fixes (if necessary) for another year (approximately).
https://www.php.net/supported-versions.php
Good point. However, I figure the security aspect would be the primary reason why hosts would elect to drop old versions of php.

Post Reply

Return to “[3.2.x] Support Forum”