Forum 3.2.8 malfunction under php 7.1 and 7.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Radgost
Registered User
Posts: 6
Joined: Tue Jan 24, 2012 10:38 am
Contact:

Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by Radgost »

I switched the forum in version 3.2.8 from php 5.6 to 7.1 and tried 7.2.
In both cases, the forum has stopped working.
I asked my webhost support if the php server was configured correctly.
He replied that the forum was probably misconfigured.
My question is - where I can configure the forum to work under php 7.x?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 22061
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket.

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by Mick »

Welcome to phpBB

Please fill out the Support Request Template and post it back here to enable us to assist you better.
"The more connected we get the more alone we become" - Kyle Broflovski

Please read: “Am I In The Right Place?” before posting.

User avatar
Radgost
Registered User
Posts: 6
Joined: Tue Jan 24, 2012 10:38 am
Contact:

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by Radgost »

Support Request Template
What version of phpBB are you using? phpBB 3.2.8
What is your board's URL? https://forum.britva.cz
Who do you host your board with? https://ebola.cz
How did you install your board? I used a download package provided by another website
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0-B1
What MODs do you have installed? No answer given
What styles do you currently have installed? Style we_universal created by INVENTEA & v12mike
What language(s) is your board currently using? Czech language
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Under php 5.6 the forum works. It does not work when switched to 7.1 or 7.2
Please describe your problem. I switched the forum in version 3.2.8 from php 5.6 to 7.1 and tried 7.2.
In both cases, the forum has stopped working.
I asked my webhost support if the php server was configured correctly.
He replied that the forum was probably misconfigured.
My question is - where can I configure the forum to work under php 7.x?

I have basic PHP knowledge and I can edit the forum source code.
Generated by SRT Generator

User avatar
janus_zonstraal
Registered User
Posts: 4064
Joined: Sat Aug 30, 2014 1:30 pm

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by janus_zonstraal »

It looks that your board is working?
Or what is the problem?
Sorry! My English is bat ;) !!!

User avatar
Radgost
Registered User
Posts: 6
Joined: Tue Jan 24, 2012 10:38 am
Contact:

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by Radgost »

The forum works under PHP 5.x only.
Does not work under PHP 7.1 or 7.2.
The support of my web host says the forum configuration is wrong.

I ask where can I set the forum to work under PHP 7.1 or 7.2.

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25819
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by Paul »

Stopped working doesn't help much. How did it stop? Do you get an error?
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

User avatar
janus_zonstraal
Registered User
Posts: 4064
Joined: Sat Aug 30, 2014 1:30 pm

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by janus_zonstraal »

Maybe you have to change your $dbms value to mysqli in the config.php file If it is now mysql
Sorry! My English is bat ;) !!!

User avatar
warmweer
Jr. Extension Validator
Posts: 3903
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by warmweer »

The only things I see "wrong" are:

Your cookie domain currently is forum.britva.cz which is OK but if you use content from another subdomain (e.g. extras.brtva.cz) you could might access problems.

Your we_universal style =
style_version = 2.5.9
phpbb_version = 3.2.8
You should switch to prosilver to find out whether the problem persists, if not then the outdated style is probably a reason for problems.

You mention using extensions but you don't mention which ones (nor the version).
Is your language version uptodate for 3.3.0?
And lastly: How did you install your board? I used a download package provided by another website
Basically that introduces an unknown factor as these files may have been edited (however small).
We should embrace problems, without which there wouldn't be any solutions.

User avatar
Radgost
Registered User
Posts: 6
Joined: Tue Jan 24, 2012 10:38 am
Contact:

Re: Forum 3.2.8 malfunction under php 7.1 and 7.2

Post by Radgost »

janus_zonstraal wrote:
Sun Feb 09, 2020 4:51 pm
Maybe you have to change your $dbms value to mysqli in the config.php file If it is now mysql
Problem solved!!!

I changed the value

Code: Select all

$dbms
to

Code: Select all

mysqli
and the forum is working under php 7.x. now.

Thank You!

Post Reply

Return to “[3.2.x] Support Forum”