Problems attempting forum updates

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Problems attempting forum updates

Post by buksida »

Support Request Template
What version of phpBB are you using? phpBB 3.2.2
What is your board's URL? https://davosman.org/
Who do you host your board with? Namecheap
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.2.1
What extensions do you have installed? Recent Topics
Insert Template Code
Max-width switch
s9e/mediaembed
What styles do you currently have installed? default
What language(s) is your board currently using? english
Which database type/version are you using? MariaDB
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Backup, disable extensions, attempt upgrade.
Please describe your problem. Attempted an upgrade from 3.2.2 to 3.3.0 and get a time out error.

There was no way to go back and try it again using the 'manual' option so I deleted the install folder and attempted the upgrade from 3.2.2 > 3.2.9. This threw up a load more errors such as:

Fatal error: Declaration of lexer_6d586c2::tokenize(Twig_Source $source) must be compatible with phpbb\template\twig\lexer::tokenize($code, $filename = NULL) in /home/davos/public_html/cache/installer/container_a5fcce7799cdc15359366537322eb9a2.php on line 2171
Generated by SRT Generator

The only way to fix was to restore the full home directory backup. Afraid to touch it again! Any ideas how to succesfully upgrade?
Last edited by buksida on Mon Aug 03, 2020 10:18 am, edited 1 time in total.
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

ANyone know how to upgrade phpBB without getting these errors?

Is it possible to install the clean full package 3.2.9, and have it upgrade the database from version 3.2.2? If so what folders do I need to leave on the server and which ones get deleted/replaced?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Problems attempting forum upgrades.

Post by Mick »

The The 3.3 User Guide is fairly comprehensive on how to upgrade.
"The more connected we get the more alone we become" - Kyle Broflovski©
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

OK, well thats what I tried getting the timeout error (yes, I checked server logs and there were no errors there).

So I want to upgrade to 3.2.9. Can I do what I have suggested above?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Problems attempting forum upgrades.

Post by Mick »

Did you try the CLI method?
"The more connected we get the more alone we become" - Kyle Broflovski©
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

No, there was no way to 'go back' and try another method, it kept skipping to the fourth stage and timed out every time I tried to update the files.

This is why I'd like to do it in stages and go to the last 3.2 version first - but that also threw up errors (as posted above).
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

So, the question remains - can I update 3.2.2 to 3.2.9 using the full package?

What folders do I need to replace? Will it automatically update the database?
User avatar
3Di
Former Team Member
Posts: 16053
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 - Frankfurt 🇩🇪
Name: Marco
Contact:

Re: Problems attempting forum upgrades.

Post by 3Di »

buksida wrote:
Thu Jul 23, 2020 7:11 am
So, the question remains - can I update 3.2.2 to 3.2.9 using the full package?
Yes. You can UPDATE.
buksida wrote:
Thu Jul 23, 2020 7:11 am
What folders do I need to replace?
See
Mick wrote:
Wed Jul 22, 2020 7:42 am
The The 3.3 User Guide is fairly comprehensive on how to upgrade.
buksida wrote:
Thu Jul 23, 2020 7:11 am
Will it automatically update the database?
Not automatically you need to interact, just follow the above guide.
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
🚀 Looking for a specific feature or alternative option? We will rock you! 🚀
User avatar
janus_zonstraal
Registered User
Posts: 4906
Joined: Sat Aug 30, 2014 1:30 pm

Re: Problems attempting forum upgrades.

Post by janus_zonstraal »

off topic, but your board is under bot attack, you have to block them!
Sorry! My English is bat ;) !!!
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

I don't want to update to 3.3 ... does the user guide apply for 3.2.9?

Apologies for all the q's but everytime I try to upgrade it screws up. I wish phpBB would be like Wordpress with one click and its done - upgrading this software has been a bloody nightmare over the years and it NEVER goes smoothly.

Thanks for the bot update, its another plague we can't seem to get rid of.
User avatar
3Di
Former Team Member
Posts: 16053
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 - Frankfurt 🇩🇪
Name: Marco
Contact:

Re: Problems attempting forum upgrades.

Post by 3Di »

buksida wrote:
Fri Jul 24, 2020 6:54 am
I don't want to update to 3.3 ... does the user guide apply for 3.2.9?
Yes
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
🚀 Looking for a specific feature or alternative option? We will rock you! 🚀
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22919
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket probably.

Re: Problems attempting forum upgrades.

Post by Mick »

buksida wrote:
Fri Jul 24, 2020 6:54 am
its another plague we can't seem to get rid of.
Your Q&A is too easy, the bots will figure that out easily.
"The more connected we get the more alone we become" - Kyle Broflovski©
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

3Di wrote:
Fri Jul 24, 2020 6:56 am
buksida wrote:
Fri Jul 24, 2020 6:54 am
I don't want to update to 3.3 ... does the user guide apply for 3.2.9?
Yes
Well, more errors - I tried again today, following that guide to the letter - it doesn't allow me to skip to the update database only - it just jumps to the update files section then this happens:

update.jpg
phpbb .jpg

Now I cant do anything, leaving the only solution to restore the full backup I made. Unless I can force it to update the database only without timing out?
User avatar
janus_zonstraal
Registered User
Posts: 4906
Joined: Sat Aug 30, 2014 1:30 pm

Re: Problems attempting forum upgrades.

Post by janus_zonstraal »

Delete in the store folder io_lock.lock and something like installer.php
And in the cache folder the installer folder.

Than try the update again.
Sorry! My English is bat ;) !!!
buksida
Registered User
Posts: 326
Joined: Thu Feb 04, 2010 9:11 am

Re: Problems attempting forum upgrades.

Post by buksida »

Thanks for the reply, tried that but the problem remains.
Post Reply

Return to “[3.2.x] Support Forum”