Added and enabled a new extension, now forum is blank white page

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
SQLnovice
Registered User
Posts: 17
Joined: Thu Oct 10, 2019 5:03 am

Added and enabled a new extension, now forum is blank white page

Post by SQLnovice »

Cannot get into my forum. Extension was SmartSubjects. Software version is 3.2.8. Our forum has been running like a top up until now. Enabled the extension through the ACP, it just sat there, then went to a blank page.

Followed other KBs on blank white pages after enabling an extension. Namely, disable extensions in MYPHPadmin. Did that, all are disabled 0. Cleared the cache directory, except for the .htaccess and index.htm files, except those two were already modified and a "_" added to their ends.

This is way above my pay grade.

My forum's offline. I just get a blank page. No other KBs seem to make any difference either. Some say check the server logs, but don't say where you go to view the server logs. Is that through MyPHPadmin? Again, I have no forum, so I have no ability to get into the ACP to check server logs, if that's where they are. I only have FTP, direct file access through the host and MYPHPadmin.

Dead in the water.
User avatar
warmweer
Jr. Extension Validator
Posts: 6543
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Added and enabled a new extension, now forum is blank white page

Post by warmweer »

A link to your board would help.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
SQLnovice
Registered User
Posts: 17
Joined: Thu Oct 10, 2019 5:03 am

Re: Added and enabled a new extension, now forum is blank white page

Post by SQLnovice »

Had to get the error logs with help from the host's support team.

Code: Select all

PHP Fatal error:  Uncaught Twig\Error\SyntaxError: Unexpected end of template. in /home/Main_DB/domains/%domain%/public_html/styles/prosilver/template/overall_header.html:132
Stack trace:
#0 /home/Main_DB/domains/%domain%/public_html/vendor/twig/twig/src/TokenParser/IfTokenParser.php(47): Twig\TokenStream->next()
#1 /home/Main_DB/domains/%domain%/public_html/vendor/twig/twig/src/Parser.php(209): Twig\TokenParser\IfTokenParser->parse(Object(Twig\Token))
#2 /home/Main_DB/domains/%domain%/public_html/vendor/twig/twig/src/Parser.php(122): Twig\Parser->subparse(NULL, false)
#3 /home/Main_DB/domains/%domain%/public_html/vendor/twig/twig/src/Environment.php(735): Twig\Parser->parse(Object(Twig\TokenStream))
#4 /home/Main_DB/domains/%domain%/public_html/vendor/twig/twig/src/Environment.php(793): Twig\Environment->parse(Object(Twig\TokenStream))
#5 /home/Main_DB/domains/%domain%/public_html/vendor/twig/twig/src/Environment.php(482): Twig\Environment->compileSource(Object(Twig\Source))
#6 /home/Main_DB/dom in /home/Main_DB/domains/%domain%/public_html/styles/prosilver/template/overall_header.html on line 132
What a mess!
Last edited by Mick on Tue Jan 19, 2021 8:53 am, edited 1 time in total.
Reason: Removed unnecessary [b] & added [code] tag for clarity.
User avatar
warmweer
Jr. Extension Validator
Posts: 6543
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Added and enabled a new extension, now forum is blank white page

Post by warmweer »

a clean 328 overall_header.html has 5848 bytes and has 132 lines

line 132 should be empty

Try Disabling all extensions at once.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 27163
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Added and enabled a new extension, now forum is blank white page

Post by Paul »

To receive extension support please visit our Extensions Database and post in the specific extension's designated support area. The link to the support area for each released extension is also available in the first post of each released extension listed in the [3.2.x] Extension Database Releases forum. For extensions still in development (not recommended for a live board) support is in that extensions's topic in the Extensions in Development forum.
SQLnovice
Registered User
Posts: 17
Joined: Thu Oct 10, 2019 5:03 am

Re: Added and enabled a new extension, now forum is blank white page

Post by SQLnovice »

Paul, did that. Extension is SmartSubjects.

Warmweer, Went into both the live copy online and a backup copy. The copies I have are 5,855 bytes. But I had made a copy of it prior to modification, which I put back in place. All extensions disabled.

My forum is back! Thank you so much!

Now I have to figure out what else is broken.
SQLnovice
Registered User
Posts: 17
Joined: Thu Oct 10, 2019 5:03 am

Re: Added and enabled a new extension, now forum is blank white page

Post by SQLnovice »

Just a follow-up. I identified what was different in my overall_header.php file that must have been upsetting to the extension enable. I had added meta tags to the header of that file. Thank goodness, as a precaution, I had made a quick duplicate of the file and left it on the live directory structure.

:idea: So knowing the size was different, as warmweer pointed out, and seeing that I had intentionally made an original duplicate backup of that specific file, was enough of a flag to figure on some changes I'd made that were making the extension unhappy. Just changing the names on those two files to put the original file back in place, solved the problem.

I checked server error log file in the host's file manager (control panel) today. That issue is solved, but now I see there's another minor one with another one of my extensions. But I'll save that for another discussion, if I cannot find a solution. :lol:
User avatar
david63
Registered User
Posts: 19067
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Added and enabled a new extension, now forum is blank white page

Post by david63 »

SQLnovice wrote:
Tue Jan 19, 2021 3:46 pm
I had added meta tags to the header of that file.
What did you use to edit the file? Most likely you did not save the file in the correct format.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
warmweer
Jr. Extension Validator
Posts: 6543
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Added and enabled a new extension, now forum is blank white page

Post by warmweer »

SQLnovice wrote:
Tue Jan 19, 2021 7:07 am
...
Cleared the cache directory, except for the .htaccess and index.htm files, except those two were already modified and a "_" added to their ends.
I just noticed this: you should put the original .htaccess and index.htm back. (adding a _ to the filename defeats their purpose and could pose a security risk.

Then ...
david63 wrote:
Tue Jan 19, 2021 4:14 pm
What did you use to edit the file? Most likely you did not save the file in the correct format.
What david63 implies is that some editors (such as Windows Notepad) will mess up the files.
see: phpBB3 and UTF-8 without BOM

And another thing: You mentioned having edited some files.
If you remember editing other files than the ones already mentioned, then I suggest you compare all your files to a pristine 3.2.8 fileset (can be downloaded from https://download.phpbb.com/pub/release/ ... -3.2.8.zip)
You can easily compare directories using the tools mentioned in File comparison programs (the 2 mentioned are just a selection; there are other similar programs available for free on the internet).

Get your board up and running with clean files and once that's in order you can reapply the edit you need, and test.
Be prepared to find out that some of your edits that function properly with phpBB 3.2.8 may cause errors with 3.3.x.
If you upgrade to 3.3 do not use the autoupdate but use the full package and reapply (and test) each modification separately (and backup/backup/backup)
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
SQLnovice
Registered User
Posts: 17
Joined: Thu Oct 10, 2019 5:03 am

Re: Added and enabled a new extension, now forum is blank white page

Post by SQLnovice »

david63 wrote:
Tue Jan 19, 2021 4:14 pm
SQLnovice wrote:
Tue Jan 19, 2021 3:46 pm
I had added meta tags to the header of that file.
What did you use to edit the file? Most likely you did not save the file in the correct format.
It would have been, but I'm guessing, either the editor built into my sFTP tool or by edited the file directly on the site's file system through the browser. I'd lean on the later, since they have easy dropdown tools for copying and renaming files.

But I'm definitely going to take the above advice and be sure if I edit any PHP files in the future, do it with an approved tool like Notepad+ and watch my server error logs.

Thanks a bunch for all your help. It gives those of us with less knowledge of the subject matter, what we need to solve issues and potentially help others like us.
SQLnovice
Registered User
Posts: 17
Joined: Thu Oct 10, 2019 5:03 am

Re: Added and enabled a new extension, now forum is blank white page

Post by SQLnovice »

warmweer,

I ended up seeing a lot of suspicious trolling today, like what others have reported about a Guest invasion out of nowhere. One of the things I ended up doing is not trusting the two '_' files in the cache folder, instead replacing them with larger backups from December.

I also updated all of my extensions and enabled Smartsubjects too, which went w/o a hitch. Checked my server error log file. There were a couple thousand new rows of repeated errors cropping up, but clearing the cache through the ACP stopped new errors in their tracks. Now the Guest invasion has left and their count has returned to an abysmal normal.

Updating to the latest 3.3.x will be next. I want to say I didn't modify any other files other than overall_header.html. I'm feeling confident going forward.
User avatar
warmweer
Jr. Extension Validator
Posts: 6543
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Added and enabled a new extension, now forum is blank white page

Post by warmweer »

SQLnovice wrote:
Wed Jan 20, 2021 5:54 am
Updating to the latest 3.3.x will be next. I want to say I didn't modify any other files other than overall_header.html. I'm feeling confident going forward.
You should feel confident : even though something went wrong somewhere at some time, your backup strategy made a full recovery possible :thumbsup:
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.2.x] Support Forum”