Convert 2.0.22 -> 3.2.2 failing [SOLVED]

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Convert 2.0.22 -> 3.2.2 failing [SOLVED]

Post by RobertWebb » Sun Jun 10, 2018 8:01 am

[Edit: See solution at end]

I'm at my wits end trying to upgrade from 2.0.22 to 3.2.2. I've lost so much time on this.

The initial new install works, but after converting I just see this:

"Sorry but this board is currently unavailable."

And I can't log in as admin. I could before converting, now I can't.

Looking in the database, I can see all my users in the phpbb_users table, so it looks like the conversion basically worked. But I can't log in as admin.

Yes I've deleted the install folder (the message is normally different if you don't anyway). There are no recent errors in my error_log file on the server. I've found lots of posts from people with similar issues, but no answers that work for me.

Yes I disabled the old forum before converting, so maybe it's inherited that setting in phpBB3, but I can't log in to enable it again.

First I installed with Softaculous. Then I deleted it all and started again installing manually. Same result. I actually tried to do this months ago too and eventually gave up. Always the same problem. It seems impossible.

I have these mods installed in 2.0.22:

ConfusaBOT ACP
Favicon
Admin Userlist regIP add on
Log IP Address on Registration
Admin Userlist
Anti-Spam ACP
EasyMOD

Some of those might add columns to database tables etc, could that cause problems?

What can I do to track down this problem?

Thanks,
Rob.

[Edit:] SOLVED! The underlying issue was that I couldn't log in to my admin account after converting the old database, giving me no way to enable the forum. The solution was to delete cookies for the site, via the browser options not just using the forum's "Delete all board cookies" link.
Last edited by RobertWebb on Mon Jun 11, 2018 9:12 am, edited 1 time in total.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19986
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Convert 2.0.22 -> 3.2.2 failing

Post by Mick » Sun Jun 10, 2018 8:08 am

Sorry but this board is currently unavailable.
Is the standard message when the /install folder is present, make sure you deleted or renamed the correct folder. None of your mods will work in 3.0+ so you can forget those. Is your 3.2 board up and running, can we have a link to it please?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 8:13 am

I just mention the mods in case they might indicate why the conversion is failing. If they themselves aren't converted, that's OK, but currently the forum is always unusable after conversion.

The link is https://software3d.com/Forums3/

But no, it's not up and running, that's the point.

It worked after the fresh install. It doesn't work after converting my old phpBB 2.0.22 database.

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 8:25 am

As I mentioned, I deleted the install folder. I've started from scratch several times, and I've deleted that folder after conversion each time. It hasn't made a difference.

After the fresh install (before the conversion) it gave a different message, specifically mentioning that the install folder should be deleted. After conversion it just gives the "Sorry but this board is currently unavailable" message, whether or not the install folder has been deleted yet.

Why else could this message be showing?

User avatar
3Di
Registered User
Posts: 12893
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Convert 2.0.22 -> 3.2.2 failing

Post by 3Di » Sun Jun 10, 2018 8:29 am

Have you tried to login https://software3d.com/Forums3/ucp.php?mode=login and go to ACP and enable the board?
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19986
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Convert 2.0.22 -> 3.2.2 failing

Post by Mick » Sun Jun 10, 2018 8:32 am

What credentials are you using for the new board? If you’ve done the conversion from 2 then you should be using the same username and password you used on the old version 2 board. Have you tried deleting everything in the /cache folder except for index.htm and .htaccess?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 9:33 am

3Di wrote:
Sun Jun 10, 2018 8:29 am
Have you tried to login https://software3d.com/Forums3/ucp.php?mode=login and go to ACP and enable the board?
I have now. When I try to log in, it just takes me back to the main page with the "Sorry but this board is currently unavailable" message.

Interestingly, if I enter the wrong password, it tells me the details are wrong, rather than going back to the message above. This is actually the first time I've seen any behaviour that differentiates between right and wrong login details. It confirms that it's now expecting the password from my old board, not the new one I entered when setting up the new board.

What next?

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 9:36 am

Mick wrote:
Sun Jun 10, 2018 8:32 am
What credentials are you using for the new board? If you’ve done the conversion from 2 then you should be using the same username and password you used on the old version 2 board. Have you tried deleting everything in the /cache folder except for index.htm and .htaccess?
I tried both my old and new credentials with no difference. As I just posted above, I can see via the ucp.php page that there's slightly different behaviour there if I enter my old password (ie rather than telling me the password is wrong, it takes me back to the "unavailable" message).

I just deleted everything in /cache except for those files as you suggested, but it's made no difference to the behaviour.

User avatar
david63
Jr. Extension Validator
Posts: 14646
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Convert 2.0.22 -> 3.2.2 failing

Post by david63 » Sun Jun 10, 2018 2:16 pm

Does your site use a caching program such as Cloudflare?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 2:54 pm

I've been experimenting with the PHP code.

In phpbb/user.php, can confirm that I'm getting the "Sorry but this board is currently unavailable" message because of a combination of two things: board is disabled & I'm not logged in as admin. The issue is that it won't let me log in, not so much that the board is disabled.

I commented out this code, and sure enough I can see my forums along with posts from the old forum, BUT I still can't log in.

Now I'm trying to follow how logging in works.

In ucp.php, when clicking on the login link, it gets to the 'login' case in the switch statement. At this point, before I'm given a chance to enter any details, $user->data['is_registered'] is already returning true, with username Anonymous. Is that right? Is it stuck thinking I'm logged in as Anonymous maybe? If this is expected behaviour, then it seems like the "if ($user->data['is_registered'])" would always be followed, because it would be true even if not logged in, as is the case here.

Any ideas?

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 2:57 pm

david63 wrote:
Sun Jun 10, 2018 2:16 pm
Does your site use a caching program such as Cloudflare?
I've never set up such a thing, so I presume not.

I've been playing with the PHP code to see what I can figure out, and reloading the page always brings in my latest upload, so no caching issue, if that's what you mean.

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 3:32 pm

I think maybe there's a problem with the admin account, so it isn't letting me in.

Looking in the SQL phpbb_users table, I notice the user_permissions column for my admin account has this:
zik0zjzik0zjzik0zg

zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
zik0zjqmx0qo
Is that to be expected?

The user_perm_from field is 0, like all other accounts. Should that be different for admin?

And the phpbb_acl_users table has no entries at all.

Any of that look like a problem?

User avatar
RobertWebb
Registered User
Posts: 12
Joined: Sun Jun 10, 2018 7:36 am

Re: Convert 2.0.22 -> 3.2.2 failing

Post by RobertWebb » Sun Jun 10, 2018 4:03 pm

A little more info.

After calling $auth->login(...) from login_box(), and entering my admin name and password, the resulting status is LOGIN_SUCCESS, but $auth->acl_gets('a_', 'm_'), which seems to be used to tell if a user is admin/moderator, is returning false. Is that to be expected?

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51317
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Convert 2.0.22 -> 3.2.2 failing

Post by Brf » Sun Jun 10, 2018 6:06 pm

RobertWebb wrote:
Sun Jun 10, 2018 3:32 pm
Any of that look like a problem?
No. None of those are unexpected.

janus_zonstraal
Registered User
Posts: 2610
Joined: Sat Aug 30, 2014 1:30 pm

Re: Convert 2.0.22 -> 3.2.2 failing

Post by janus_zonstraal » Sun Jun 10, 2018 8:05 pm

You can try to make a new admin account:
viewtopic.php?f=64&t=2437826#p14820691
Sorry! My English is bat ;) !!!

Post Reply

Return to “[3.2.x] Convertors”

Who is online

Users browsing this forum: No registered users and 2 guests