CConverting BB2 to BB3 and no errors and no conversion

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
User avatar
Prosk8er
Registered User
Posts: 1444
Joined: Sun Mar 12, 2006 3:30 am
Location: Rochester, NY
Name: Tyler
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by Prosk8er » Wed Feb 27, 2019 8:01 pm

styles\all\template\feed.xml.twig is the only files that would be in the all folder by default

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Thu Feb 28, 2019 6:26 pm

Hello,

I have been trying to find a way to install phpBB 3.2.5 with my backup SQL. It has been a roller-coaster ride! Every time I advance closer I get multiple errors at different times & different activities.

When I install phpBB 3.2.5 the board works well with the default DB. When I import my backup the board will launch though fraught errors.

After installing phpBB dozens of times on the host server and on the localhost I may have finally moved closer to my goal. As of now, I have phpBB 6.2.5 working with my backup SQL data. The Prosliver theme displays and I can see all of the topics, posts, users etc..

The solution to get to this point was to export certain tables from the default DB to the DB with my backup in it. I had to delete some tables prior to importing tables plus add tables. Moving folders and files around to new locations in the folder phpBB/ was a must. And finally, change the php coding in some of the php files. Truly wild!

Not done by any means! Two errors have reviled themselves:

1. When I log in, the statistics at the bottom of the page are correct. Ferther up the page in the topic listings all statistics are 0, see images:
Image
Image
Any one have thoughts on where the disconnect may be?

2. When registering a new user, after accepting the agreement the following error displays:

Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "5". in C:\xampp7\htdocs\phpBB3\vendor\symfony\dependency-injection\ContainerBuilder.php:809 Stack trace: #0 C:\xampp7\htdocs\phpBB3\vendor\symfony\dependency-injection\ContainerBuilder.php(455): Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition('5') #1 C:\xampp7\htdocs\phpBB3\phpbb\di\service_collection.php(72): Symfony\Component\DependencyInjection\ContainerBuilder->get('5') #2 C:\xampp7\htdocs\phpBB3\phpbb\profilefields\manager.php(139): phpbb\di\service_collection->offsetGet('5') #3 C:\xampp7\htdocs\phpBB3\includes\ucp\ucp_register.php(659): phpbb\profilefields\manager->generate_profile_fields('register', 1) #4 C:\xampp7\htdocs\phpBB3\includes\functions_module.php(676): ucp_register->main('register', NULL) #5 C:\xampp7\htdocs\phpBB3\includes\functions_module.php(998): p_master->load_active(false) #6 C:\xampp7\htdocs\phpBB3\ucp.php(76): p_master->load('ucp', 'ucp_ in C:\xampp7\htdocs\phpBB3\vendor\symfony\dependency-injection\ContainerBuilder.php on line 809

I have been trying to run this one down though making little headway. Here is another opportunity for help. Please.

Currently I am working on getting the board email working and taking breaks from that to work on 1 & 2 above.

User avatar
3Di
Former Team Member
Posts: 13687
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by 3Di » Thu Feb 28, 2019 6:35 pm

John Robi wrote: ↑
Thu Feb 28, 2019 6:26 pm
I have been trying to find a way to install phpBB 3.2.5 with my backup SQL. It has been a roller-coaster ride! Every time I advance closer I get multiple errors at different times & different activities.

When I install phpBB 3.2.5 the board works well with the default DB. When I import my backup the board will launch though fraught errors.
After having installed a fresh 3.2.5 you can replace (means drop all tables first) the whole fresh DB with a old backup.

After that you should consider that's not any more a 3.2.5 board in effect, you have to delete the content of the store folder except for the index.html and .htaccess files and then copy again the install folder from the 3.2.5's package and surf to http://your_board_root/install/, there you will chose update database only and wait till the end of the iterations.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

User avatar
david63
Registered User
Posts: 16095
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by david63 » Thu Feb 28, 2019 6:46 pm

3Di wrote: ↑
Thu Feb 28, 2019 6:35 pm
you have to delete the content of the store folder except for the index.html and .htaccess files
Not recommended if you any extensions installed that are writing data to the store folder unless you have a backup of that folder that you can restore later.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
3Di
Former Team Member
Posts: 13687
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by 3Di » Thu Feb 28, 2019 7:37 pm

Sure, in this specific case though I don't see the potential issue.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Thu Feb 28, 2019 11:15 pm

Hello,

Good thoughts in the last two posts, thank you.

One bad break is that the moderator of the forum can't remember or find her password. So, I cannot login to the new forum to make changes. I'm locked out! The, I forgot my password, dose not work because the email feature has a glitch. I can't get into the admin panel to correct the email issue.

To get around the no password dilemma I tried adding myself to the new forum however, the board encounters a fatal error when trying to add a new registered user, see above post for the wording. No worries, I just manually added my credentials into the users table of the new forum. I had all the information entered to have a founder's permissions except the password. I registered as a user in the Demo Forum and then accessed the users table, copied the encrypted password and pasted it into the new forum. On exiting the password cell an error displayed, see above post for the text.

To move forward, I have changed the prefix of the users table and imported a users table from a newly installed second forum, AKA Demo Forum. The default users table contains a new administrators credential that I may use to login. Sounds odd I know. I can now login to the new forum and get to the Administration Panel. I can see all of the posts and topics and I'm now perusing the email issue.

At the same time, I need to know an efficient way to copy the users from the original, now renamed, use table into the new user table where my credentials sit.

Any ideas out there? I am looking through the community forum for instructions on how to copy/move the users into the new forum.

I continue to be impressed by all the helpful and thoughtful ideas coming in. THANKS TO YOU ALL!


******************************* up date **************************************** up date **************************************** up date ********************

I have not run the database update yet. I'm concerned about having the second users table in the DB (though the table may not be linked to the rest of the DB because I gave it a new prefix) plus the users have not been copied and entered into the proper users table.

Additionally, since the original users table was apart of the import, the users_group table should contain the correct information as would any another table,... I hope. Once the users are added to the 'official' users table all may be well, so says the novice phpBB girl, me. After getting all the users entered I well drop the renamed table.

Any help as to not being able to create a new registered user, see above post for errors found ?
Last edited by John Robi on Thu Feb 28, 2019 11:46 pm, edited 4 times in total.

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Thu Feb 28, 2019 11:15 pm

ERROR IN POSTING

User avatar
3Di
Former Team Member
Posts: 13687
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by 3Di » Fri Mar 01, 2019 12:25 am

Clear the "cache" folder. And..

Import the users first and run that DB update instead of making changes in the DB continuosly.
Those PWs will be converted by the upgrade.

Pls try to be very synthetic in exposing the problems, posts too long to read hardly meet people willing to help and invest thier time.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
πŸ‘¨β€πŸ« | Take a tour to | The Studio | πŸ‘¨β€πŸ«

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Fri Mar 01, 2019 4:00 pm

Hello,

Understood, thank you.

I'm accessing via CLI. Never tried it before. I'm in now and exploring.


******************** Update ******************** Update *********************** Update ******************

I was able to repair the board via CLI. The board is up and running. So far the only error I can see is the registered users being reported as 0 in Who's on line. I'll explore this.

Any thoughts anyone?

########## A BIG THANK YOU to all for leading this novice through phpBB ###############



********************* Update ************************ Update ********************* Update ******************

I resolved the counter issue in Who's on line. It now reflects the correct number of online users.

So far, the board is stable.

********************* Update ************************ Update ********************* Update ******************
03/02/2019

The board is still stable. All topics, posts, messages and the users are all there. I will make the board available the to the community and turning it over to the moderators early next week.

Again, thanks to all the support members for your support and advice. I now feel better prepared going forward should some issue surface in the future.

Post Reply

Return to β€œ[3.2.x] Convertors”