CConverting BB2 to BB3 and no errors and no conversion

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Mon Feb 25, 2019 4:22 pm

Hello,

You wrote "You're running php 7.3.x It's not compatible with that. Downgrade to 7.1 or 7.2"'. Thr host server or my localhost. I will look at xampp setup.

I just looked at host and it indicates php 5x though the support person at HostGator said he upgraded it to php 7x. I just now used C panel and changed it to php 7.0.

Thank you.

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2228
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by kinerity » Mon Feb 25, 2019 4:41 pm

John Robi,

Please keep in mind that we have a six hour bumping rule. All team members and community members here are volunteers, so we ask you to wait at least six hours before bumping your topic or, if no-one has replied to your last post, edit your last post. Thanks!
Kailey Truscott - Community Team

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Mon Feb 25, 2019 4:52 pm

Hello,

Thank you, understood.

Kailey Truscott - Community Team


I have now installed xmapp php 7.1x. I will try the install again.

**************UPDATE***************

I installed xmapp php7.1 (host server is using php 7.1) and began installing phpBB 3.2.5 on the localhost. An error occurred when Submit was clicked, see images
Image
Image
Image

The config.php file is correct:
$dbname = 'transfor_VIOLET_phpBB3';
$table_prefix = 'phpbb_';

Alternatively I installed phpBB 3.2.5 on the host server. The install went smoothly, I used the same settings in config.php as I did when installing on localhost. phpBB connected to the DB and created the tables. I then, imported my backup SQL and it completed successfully. I renamed the install folder and I tried to access the board and received this error, see images
Image
Image

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Tue Feb 26, 2019 6:30 am

Hello,

I still cannot get phpBB 3.2.5 installed on the localhost due to errors. I can install phpBB 3.2.5 successfully on the host server but I cannot access the board due to errors. Please see my last post for type of errors plus images of the errors.

Any thoughts?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69039
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by KevC » Tue Feb 26, 2019 9:37 am

In the red message it looks like in MySQL manager, that username does not have access to that database.

In the other message, make sure the config.php file information is 100% correct. You cannot guess at any of it. It must be right.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Tue Feb 26, 2019 11:56 am

Hello,

Here is an image of the users allowed to the DB:
Image

transfor_TransMe does have full rights.

As to config.php, it is correct see image:
Image


The odd thing to me is that when I install phpBB 3.2.5 on the host server using the same config it works and adds the tables to the DB. It is only when I access the board do I get an error, see my last two posts for the error.

Also, just an fyi for me, it would seem that phpBB does not populate the config.php file until one of the last steps of the install. Initially config.php is empty. Just for the exercise, I populated config.php and when installing phpBB a message stated the board was already installed.

I have also tried installing on the localhost phpBB 2.0.23 and it will not connect either.

One last observation, in the beginning of all this as I was installing phpBB I found that when the database type was set to MySQL extended the install faild. When I used MySQL the installation proceeded nominally. Does this apply now, probably not.




****************** up date****************************** up date ***************************** up date ************************

I started over, deleted DB uninstalled phpBB in order to install phpBB 3.1.6 on the host server. I recreated DB, transfor_VIOLET_phpBB3 & assigned users to it. I then uploaded phpBB and started the install. All went well, I got to the advanced settings, see image below, I clicked on Proceed To The Next Step and received a General Fatal error, see below.

Image
Image

It seems no matter what phpBB version I select and whether I install from localhost or host server there is a failure.
Last edited by John Robi on Tue Feb 26, 2019 3:15 pm, edited 1 time in total.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21055
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by Mick » Tue Feb 26, 2019 12:53 pm

For a fresh install config.php has to be empty otherwise it will think it's already installed. Mysqli should be used, mysql is deprecated in PHP.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Lumpy Burgertushie
Registered User
Posts: 66242
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by Lumpy Burgertushie » Tue Feb 26, 2019 4:26 pm

just a wild guess here.
your database name and database username are unusually long.

try changing the database name to just transfor_VIOLET or better yet transfor_violet
and create a new user of transfor_me

there is no reason to use uppercase and it might be confusing things .

there are some times when a database name and/or username are too long and it does not work.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Tue Feb 26, 2019 4:51 pm

Hello,

I asked and HostGator does not support MySQLI.

Question, during my adventures with phpBB software over the past several weeks I did manage to get phpBB 3.2.5 in and working. It is still working. The hyperlink is:

http://www.transformationsbyrori.com/phpBB3/

I imported the SQL backup and from what I can tell all of the topics, posts, users are there as I inspected the tables. Only, the board does not recognize the information This is why I abandoned further working with it. The board opening screen indicates "Your First Forum" see image:
Image

I entered my user & password and got in. I have founder permissions. I accessed the admin area to find the board reports 2 users and not the 480 registered users, plus, no forums, topics etc..

Is there a way to allow the board to recognize the data in the tables?

I did perform a data check on the DB as well as a corruption test, no corruption, all reported good.


******************* up date ************************ up date *********************

Thank you Robert, the naming convention of the original DB was upper & lower case plus long names and created long before I was asked to take over. I appall it. The owner asked me to continue the convention so if she takes over it will be familiar. Not a good reason I informed her. But there we are.

What do you think of my issue with the working board, see far above? Could there be some way to get the board to recognize the data in the tables?
Last edited by John Robi on Tue Feb 26, 2019 5:02 pm, edited 1 time in total.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69039
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by KevC » Tue Feb 26, 2019 4:59 pm

Did you edit the config.php file to reflect the imported database information (name, table prefix)?

The config.php file will only look at the database which matches the information that is in it. At the moment, that info is pointing at a brand new database and not the one you think it is.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
david63
Registered User
Posts: 16073
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by david63 » Tue Feb 26, 2019 5:29 pm

John Robi wrote:
Tue Feb 26, 2019 4:51 pm
I asked and HostGator does not support MySQLI.
Ask again because that is the standard - if they still say no then it is time to find a new host that knows what they are doing/talking about.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Tue Feb 26, 2019 9:55 pm

Hello,

Host is php 7.1

Been busy else where other projects as well. I'll get back to this issue this evening.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66242
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by Lumpy Burgertushie » Tue Feb 26, 2019 9:59 pm

as stated above, the problem now is that you are not looking at the correct tables or the correct database.

check the table prefix in the config.php file against what is actually in your database.
remember that when looking at the database in phpmyadmin there is more than one page in the list of tables.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21055
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by Mick » Wed Feb 27, 2019 9:13 am

PHP support wrote:PHP 7 has removed support for the mysql extension and affects the following: Any queries using a mysql_connect function will not function. PHP 7 only allows connections to a MySQL database using mysqli . . .
"The more connected we get the more alone we become" - Kyle Broflovski

John Robi
Registered User
Posts: 91
Joined: Fri Feb 22, 2019 2:15 am

Re: CConverting BB2 to BB3 and no errors and no conversion

Post by John Robi » Wed Feb 27, 2019 5:07 pm

Hello,

Mick, you continue to provide valuable information, THANK YOU!

And your up at very very early hours of the day. Interesting, I am as well. Started on the board issues at 2:00 AM


UPDATE:

1. Apparently the backups I made of the original DB are not all the same. Some are missing tables. Why, who knows, I used the check all button and selected export.

2. Using localhost I was able to create a working board using phpBB 3.2.5 and the default DB.

3. Importing, via BigDump, a good backup (but missing tables) the board almost works. I replaced the missing tables from another backup (phpbb_config_text & phpbb_login_attempts). On launching the board there was an error indicating a missing file: C:\xampp\htdocs\phpBB3\styles\all\template\confirm_body.html. The file actually isn't there. There is only 1 file in the template folder, feed.xml.twig. I copied the template files from Prosliver into the C:\xampp\htdocs\phpBB3\styles\all\template folder. This allowed the board to launch but without a css link. So, no styling. Though, all of the topics, posts, users are there! Huzza!!

4. I made incremental backups. I imported to host server the DB and using FTP I uploaded the phpBB files. The board works well with the default DB though I haven't imported the actual DB yet.

5. I imported the full backup with all of the data to the localhost. Found that the main user (founder) is now missing. All other users are there, go figure. I tried to insert a new user by viewing and duplicating the data from a backup DB only to have errors. I then copied an existing user and inserted it. The duplicated user is working (I changed the user name). Upon editing the user I get stopped at the password, an error displays, see image:
Image
*****
To be clear and this is important, at the host server I have the default DB and phpBB 3.2.5 working (this is the DB when initially installing phpBB)
AND on the localhost I have the full forum backup DB installed and phpBB 3.2.5. Working though no css.
*****
Continuing:

I copied the password from the default DB on the host server to the DB on localhost running the full DB. When I pasted the password into the localhost DB an error indicates it is truncated. As you can see above it is truncated. I do notice that all other passwords in the table take up only one line. I tried changing the password to a shorter one and copied that, same error and it takes two lines. How to get passed this?

Sum it up: New challenges, activate Prosliver to solve "?" the "css" link. Find a way around the password issue.

Reaching out, any thoughts?

P.S. I have been working on this since 2 AM and plan on continuing the rest of the day and night.



******************** up date ********************************* up date ********************************** up date **********************

In reading about Prosliver it is the default theme. Launching the board from the host server I do get a working board with Prosliver theme.

On the localhost it also had the theme when running the default DB with phpBB 3.2.5. I then imported via BigDump the actual SQL backup. After renaming the install file, I launched phpBB and the board started but no css link. All the topics, posts, users... are there.

Just now, success Prosliver. After reading about the issue in the community forum and then looking at the different html files in notepad++ I found where the link to the css was located. The HTML coding indicates the css files are to be in .../styles/theme/. The folder Styles only had the sub folders All and Prosliver. After copying the folder theme to the Styles folder, Prosliver was active.

With the board showing in Prosliver theme I clicked on Register and the following error message displayed:

Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "5". in C:\xampp\htdocs\phpBB3\vendor\symfony\dependency-injection\ContainerBuilder.php:809 Stack trace: #0 C:\xampp\htdocs\phpBB3\vendor\symfony\dependency-injection\ContainerBuilder.php(455): Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition('5') #1 C:\xampp\htdocs\phpBB3\phpbb\di\service_collection.php(72): Symfony\Component\DependencyInjection\ContainerBuilder->get('5') #2 C:\xampp\htdocs\phpBB3\phpbb\profilefields\manager.php(139): phpbb\di\service_collection->offsetGet('5') #3 C:\xampp\htdocs\phpBB3\includes\ucp\ucp_register.php(659): phpbb\profilefields\manager->generate_profile_fields('register', 1) #4 C:\xampp\htdocs\phpBB3\includes\functions_module.php(676): ucp_register->main('register', NULL) #5 C:\xampp\htdocs\phpBB3\includes\functions_module.php(998): p_master->load_active(false) #6 C:\xampp\htdocs\phpBB3\ucp.php(76): p_master->load('ucp', 'ucp_register in C:\xampp\htdocs\phpBB3\vendor\symfony\dependency-injection\ContainerBuilder.php on line 809

Any seen this before? I'm trying to look up the errors and see if I can find a solution. And the day trudges on!
Last edited by John Robi on Wed Feb 27, 2019 9:04 pm, edited 1 time in total.

Post Reply

Return to “[3.2.x] Convertors”