What style is this?

For support and discussion related to templates, themes, and imagesets in phpBB 3.2.
User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Sun Sep 03, 2017 6:31 pm

Okey, I didn't understand well, sry.
I've got a backup files of (colours.css;common.css;overal_footer.html;overal_header.html;stylsheet.css)
I've done all points:
  • removeD the rounded corners from the wrap in common.css in colours.css delete this
  • addED two surrounding divs outside of the wrap open overall_footer.html open overall_header.html
  • createD a new file in the templates folder called theme_navbar.html
  • you will also have to add all the new styles for everything. to do this I recommend creating a theme.css file in your theme folder for all the styles for your theme
    >Can you explain me this, please?
    I do NOT understand much, just done some coding as a hobby, if you explain to me clearly I will be very grateful to you & we can cooperate so it will be done "Nice N' Rough" as Tina Turner used to say ^-^
    (Does it mean that I edit a copy of the original files of prosilver them and link them as

    Code: Select all

    @import url("theme.css");
    & they overlay the original one(s) so that the original one(s) are not damaged(edited) & can be updated on new update of phpBB)
  • addED the following to the new theme.css file
What should I do?
edit: LOLd! Are you a wizard? : )
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
point 4 I was suggesting to not edit everything into the files that come with prosilver. This is a bad practice. It is best to separate everything that is custom into its own css file to prevent issues when prosilver gets updated. That is what the theme.css file was a new custom file for all the custom css
I agree !
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
this is what you have in overall_header.html
This is what I have, should I insert what u've posted?

Code: Select all

<div class="theme-wrap">
    <!-- INCLUDE theme_navbar.html -->
    <div class="theme-contents">
		<div id="wrap">
		</div>
	</div>
</div>
After:

Code: Select all

<div class="theme-wrap">
	<nav class="theme-topnav">
		<a href="/">Home</a>
		<a href="/wiki">Wiki</a>
		<a href="/forum">Forum</a>
		<a href="http://bitbucket.org/rude/love/issues">Issue tracker</a>
		<div id="search-box" class="search-box theme-topnav-search" role="search">
			<form action="./search.php?sid=d78a574729e8dd0bcc2f3b928a459a5c" method="get" id="search">
				<fieldset>
					<input name="keywords" id="keywords" type="search" maxlength="128" title="Search for keywords" class="inputbox search tiny" size="20" value="" placeholder="Search…">
					<button class="button button-search" type="submit" title="Search">
						<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">Search</span>
					</button>
					<a href="./search.php?sid=d78a574729e8dd0bcc2f3b928a459a5c" class="button button-search-end" title="Advanced search">
						<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">Advanced search</span>
					</a>
					<input type="hidden" name="sid" value="d78a574729e8dd0bcc2f3b928a459a5c">
				</fieldset>
			</form>
		</div>
	</nav>
    <!-- INCLUDE theme_navbar.html -->
    <div class="theme-contents">
		<div id="wrap">
		</div>
	</div>
</div>
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
The issue is that the last three </div> need removed from this file they belong in the overall_footer its hard to recommend where now without access to some sort of git repo for your theme.
Here you go overall_footer.html, if you need anything let me know, I might even create a github.

Code: Select all

		<!-- EVENT overall_footer_content_after -->
	</div>

<!-- EVENT overall_footer_page_body_after -->

<div id="page-footer" class="page-footer" role="contentinfo">
	<!-- INCLUDE navbar_footer.html -->

	<div class="copyright">
		<!-- EVENT overall_footer_copyright_prepend -->
		{CREDIT_LINE}
		<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->
		<!-- EVENT overall_footer_copyright_append -->
		<!-- IF DEBUG_OUTPUT --><br />{DEBUG_OUTPUT}<!-- ENDIF -->
		<!-- IF U_ACP --><br /><strong><a href="{U_ACP}">{L_ACP}</a></strong><!-- ENDIF -->
	</div>

	<div id="darkenwrapper" class="darkenwrapper" data-ajax-error-title="{L_AJAX_ERROR_TITLE}" data-ajax-error-text="{L_AJAX_ERROR_TEXT}" data-ajax-error-text-abort="{L_AJAX_ERROR_TEXT_ABORT}" data-ajax-error-text-timeout="{L_AJAX_ERROR_TEXT_TIMEOUT}" data-ajax-error-text-parsererror="{L_AJAX_ERROR_TEXT_PARSERERROR}">
		<div id="darken" class="darken">&nbsp;</div>
	</div>

	<div id="phpbb_alert" class="phpbb_alert" data-l-err="{L_ERROR}" data-l-timeout-processing-req="{L_TIMEOUT_PROCESSING_REQ}">
		<a href="#" class="alert_close">
			<i class="icon fa-times-circle fa-fw" aria-hidden="true"></i>
		</a>
		<h3 class="alert_title">&nbsp;</h3><p class="alert_text"></p>
	</div>
	<div id="phpbb_confirm" class="phpbb_alert">
		<a href="#" class="alert_close">
			<i class="icon fa-times-circle fa-fw" aria-hidden="true"></i>
		</a>
		<div class="alert_text"></div>
	</div>
</div>

</div>

    </div>
</div>

<div>
	<a id="bottom" class="anchor" accesskey="z"></a>
	<!-- IF not S_IS_BOT -->{RUN_CRON_TASK}<!-- ENDIF -->
</div>

<script type="text/javascript" src="{T_JQUERY_LINK}"></script>
<!-- IF S_ALLOW_CDN --><script type="text/javascript">window.jQuery || document.write('\x3Cscript src="{T_ASSETS_PATH}/javascript/jquery.min.js?assets_version={T_ASSETS_VERSION}">\x3C/script>');</script><!-- ENDIF -->
<script type="text/javascript" src="{T_ASSETS_PATH}/javascript/core.js?assets_version={T_ASSETS_VERSION}"></script>
<!-- INCLUDEJS forum_fn.js -->
<!-- INCLUDEJS ajax.js -->
<!-- IF S_ALLOW_CDN -->
	<script type="text/javascript">
		(function($){
			var $fa_cdn = $('head').find('link[rel="stylesheet"]').first(),
				$span = $('<span class="fa" style="display:none"></span>').appendTo('body');
			if ($span.css('fontFamily') !== 'FontAwesome' ) {
				$fa_cdn.after('<link href="{T_ASSETS_PATH}/css/font-awesome.min.css" rel="stylesheet">');
				$fa_cdn.remove();
			}
			$span.remove();
		})(jQuery);
	</script>
<!-- ENDIF -->

<!-- IF S_COOKIE_NOTICE -->
	<script src="{T_ASSETS_PATH}/cookieconsent/cookieconsent.min.js?assets_version={T_ASSETS_VERSION}"></script>
	<script>
		window.addEventListener("load", function(){
			window.cookieconsent.initialise({
				"palette": {
					"popup": {
						"background": "#0F538A"
					},
					"button": {
						"background": "#E5E5E5"
					}
				},
				"theme": "classic",
				"content": {
					"message": "{LA_COOKIE_CONSENT_MSG}",
					"dismiss": "{LA_COOKIE_CONSENT_OK}",
					"link": "{LA_COOKIE_CONSENT_INFO}",
					"href": "{LA_COOKIE_CONSENT_HREF}"
				}
			})});
	</script>
<!-- ENDIF -->

<!-- EVENT overall_footer_after -->

<!-- IF S_PLUPLOAD --><!-- INCLUDE plupload.html --><!-- ENDIF -->
{$SCRIPTS}

<!-- EVENT overall_footer_body_after -->

</body>
</html>
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
add this new css class

Code: Select all

.theme-topnav-search {
    border-radius: 4px;
    display: block;
    float: right;
    margin-right: 5px;
}
Wait. Where?
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
then in your html find this in your theme-topnav
theme-topnav!? If I insert what u've told me in overall_header.html I have already...so if insert it will be 2 of ém. (I edit only the 1st one - "in your theme-topnav" search-header to theme-topnav-search the other stays search-header), but can I have only 1 search button on the additional nav_bar only?

Code: Select all

<div id="search-box" class="search-box search-header" role="search">

Code: Select all

		<div class="headerbar" role="banner">
		<!-- EVENT overall_header_headerbar_before -->
			<div class="inner">

			<!-- EVENT overall_header_searchbox_before -->
			<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
			<div id="search-box" class="search-box search-header" role="search">
				<form action="{U_SEARCH}" method="get" id="search">
				<fieldset>
					<input name="keywords" id="keywords" type="search" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="inputbox search tiny" size="20" value="{SEARCH_WORDS}" placeholder="{L_SEARCH_MINI}" />
					<button class="button button-search" type="submit" title="{L_SEARCH}">
						<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
					</button>
					<a href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
						<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
					</a>
					{S_SEARCH_HIDDEN_FIELDS}
				</fieldset>
				</form>
			</div>
			<!-- ENDIF -->
			<!-- EVENT overall_header_searchbox_after -->

			</div>
			<!-- EVENT overall_header_headerbar_after -->
		</div>
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
remove margin-top: 30px;
I can't find it...

User avatar
Hanakin
Infrastructure Team Member
Infrastructure Team Member
Posts: 569
Joined: Wed Dec 30, 2009 8:14 am
Name: Michael Miday
Contact:

Re: What style is this?

Post by Hanakin » Mon Sep 04, 2017 1:45 pm

ok i did not understand that you only want the one search my bad. as for everything else it seems you do not understand basic html. an html tag has an open and closing tag. <div></div> when you create a wrap it is intended to go around all your html. This means you should not close it in your overall_header.

1. open overall_header
2. find the following code

Code: Select all

<!-- EVENT overall_header_searchbox_before -->
<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
	<div id="search-box" class="search-box search-header" role="search">
		<form action="{U_SEARCH}" method="get" id="search">
			<fieldset>
				<input name="keywords" id="keywords" type="search" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="inputbox search tiny" size="20" value="{SEARCH_WORDS}" placeholder="{L_SEARCH_MINI}" />
				<button class="button button-search" type="submit" title="{L_SEARCH}">
					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
				</button>
				<a href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
					<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
				</a>
				{S_SEARCH_HIDDEN_FIELDS}
			</fieldset>
		</form>
	</div>
<!-- ENDIF -->
<!-- EVENT overall_header_searchbox_after -->
3. delete it
4. find the following

Code: Select all

<div class="theme-wrap">
    <!-- INCLUDE theme_navbar.html -->
    <div class="theme-contents">
		<div id="wrap">
		</div>
	</div>
</div>
5. change it to

Code: Select all

<div class="theme-wrap">
	<!-- INCLUDE theme_navbar.html -->
	<div class="theme-contents">
		<div id="wrap">
6. Open theme_navbar.html
7. replace it with the following

Code: Select all

<nav class="theme-topnav">
	<a href="/">Home</a>
	<a href="/wiki">Wiki</a>
	<a href="/forum">Forum</a>
	<a href="http://bitbucket.org/rude/love/issues">Issue tracker</a>
	<!-- EVENT overall_header_searchbox_before -->
	<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
	<div id="search-box" class="search-box theme-topnav-search" role="search">
		<form action="{U_SEARCH}" method="get" id="search">
			<fieldset>
				<input name="keywords" id="keywords" type="search" maxlength="128" title="{L_SEARCH_KEYWORDS}" class="inputbox search tiny" size="20" value="{SEARCH_WORDS}" placeholder="{L_SEARCH_MINI}" />
				<button class="button button-search" type="submit" title="{L_SEARCH}">
					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
				</button>
				<a href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
					<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
				</a>
				{S_SEARCH_HIDDEN_FIELDS}
			</fieldset>
		</form>
	</div>
	<!-- ENDIF -->
	<!-- EVENT overall_header_searchbox_after -->
</nav>
8. Open overall_footer and make it match the following code

Code: Select all

				<!-- EVENT overall_footer_content_after -->
				</div><!-- close page_body -->

				<!-- EVENT overall_footer_page_body_after -->

				<div id="page-footer" class="page-footer" role="contentinfo">
					<!-- INCLUDE navbar_footer.html -->

					<div class="copyright">
						<!-- EVENT overall_footer_copyright_prepend -->
						{CREDIT_LINE}
						<!-- IF TRANSLATION_INFO --><br />{TRANSLATION_INFO}<!-- ENDIF -->
						<!-- EVENT overall_footer_copyright_append -->
						<!-- IF DEBUG_OUTPUT --><br />{DEBUG_OUTPUT}<!-- ENDIF -->
						<!-- IF U_ACP --><br /><strong><a href="{U_ACP}">{L_ACP}</a></strong><!-- ENDIF -->
					</div>

					<div id="darkenwrapper" class="darkenwrapper" data-ajax-error-title="{L_AJAX_ERROR_TITLE}" data-ajax-error-text="{L_AJAX_ERROR_TEXT}" data-ajax-error-text-abort="{L_AJAX_ERROR_TEXT_ABORT}" data-ajax-error-text-timeout="{L_AJAX_ERROR_TEXT_TIMEOUT}" data-ajax-error-text-parsererror="{L_AJAX_ERROR_TEXT_PARSERERROR}">
						<div id="darken" class="darken">&nbsp;</div>
					</div>
					<div id="loading_indicator" class="loading_indicator">
						<div class="loader">
							<svg class="spinner" width="48px" height="48px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg" aria-labelledby="loader-title" role="img">
								<title id="loader-title">Loading...</title>
								<circle class="spinner-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle>
							</svg>
						</div>
					</div>

					<div id="phpbb_alert" class="phpbb_alert" data-l-err="{L_ERROR}" data-l-timeout-processing-req="{L_TIMEOUT_PROCESSING_REQ}">
						<a href="#" class="alert_close">
							<i class="icon fa-times-circle fa-fw" aria-hidden="true"></i>
						</a>
						<h3 class="alert_title">&nbsp;</h3><p class="alert_text"></p>
					</div>
					<div id="phpbb_confirm" class="phpbb_alert">
						<a href="#" class="alert_close">
							<i class="icon fa-times-circle fa-fw" aria-hidden="true"></i>
						</a>
						<div class="alert_text"></div>
					</div>
				</div>
			</div><!-- close wrap -->
		</div><!-- close theme-contents -->
	</div><!-- close theme-wrap -->

	<div>
		<a id="bottom" class="anchor" accesskey="z"></a>
		<!-- IF not S_IS_BOT -->{RUN_CRON_TASK}<!-- ENDIF -->
	</div>

	<script type="text/javascript" src="{T_JQUERY_LINK}"></script>
	<!-- IF S_ALLOW_CDN --><script type="text/javascript">window.jQuery || document.write('\x3Cscript src="{T_ASSETS_PATH}/javascript/jquery.min.js?assets_version={T_ASSETS_VERSION}">\x3C/script>');</script><!-- ENDIF -->
	<script type="text/javascript" src="{T_ASSETS_PATH}/javascript/core.js?assets_version={T_ASSETS_VERSION}"></script>
	<!-- INCLUDEJS forum_fn.js -->
	<!-- INCLUDEJS ajax.js -->
	<!-- IF S_ALLOW_CDN -->
	<script type="text/javascript">
	(function($){
		var $fa_cdn = $('head').find('link[rel="stylesheet"]').first(),
			$span = $('<span class="fa" style="display:none"></span>').appendTo('body');
		if ($span.css('fontFamily') !== 'FontAwesome' ) {
			$fa_cdn.after('<link href="{T_ASSETS_PATH}/css/font-awesome.min.css" rel="stylesheet">');
			$fa_cdn.remove();
		}
		$span.remove();
	})(jQuery);
	</script>
	<!-- ENDIF -->

	<!-- IF S_COOKIE_NOTICE -->
	<script src="{T_ASSETS_PATH}/cookieconsent/cookieconsent.min.js?assets_version={T_ASSETS_VERSION}"></script>
	<script>
	window.addEventListener("load", function(){
		window.cookieconsent.initialise({
			"palette": {
				"popup": {
					"background": "#0F538A"
				},
				"button": {
					"background": "#E5E5E5"
				}
			},
			"theme": "classic",
			"content": {
				"message": "{LA_COOKIE_CONSENT_MSG}",
				"dismiss": "{LA_COOKIE_CONSENT_OK}",
				"link": "{LA_COOKIE_CONSENT_INFO}",
				"href": "{LA_COOKIE_CONSENT_HREF}"
			}
		})});
	</script>
	<!-- ENDIF -->

	<!-- EVENT overall_footer_after -->

	<!-- IF S_PLUPLOAD --><!-- INCLUDE plupload.html --><!-- ENDIF -->
	{$SCRIPTS}

	<!-- EVENT overall_footer_body_after -->

</body>
</html>
9. place the following in theme.css

Code: Select all

.theme-topnav-search {
    border-radius: 4px;
    display: block;
    float: right;
    margin-right: 5px;
}
10. find all the following in theme.css

Code: Select all

nav
11. change them to the following

Code: Select all

.theme-topnav
***NEVER STYLE HTM L TAGS ALWAYS STYLE CLASSES WHEN BUILDING A THEME***

11. lastly you still have to undo everything from viewtopic.php?f=591&t=2434916&start=30#p14816241

hopefully that fixes everything if not it should get you 99% there

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Mon Sep 04, 2017 3:32 pm

Okey, seems nice to me : ) (almost :p) Just a few questions
  • Advanced search button
  • boarder WHITE is a bit bigger then it should be
  • How can I slap Board index with Quick links, FAQ, Login, Register (just informative if wanna try it, I think somebody wrote it already but dunno)
  • I'm gonna attach colours.css , common.css , overall_footer.html , overall_header.html , stylesheet.css , them_navbar.html , theme.css. Can you check ém, please.
colours.css common.css overall_footer.html overall_header.html stylesheet.css them_navbar.html theme.css
https://drive.google.com/drive/folders/ ... sp=sharing

User avatar
Hanakin
Infrastructure Team Member
Infrastructure Team Member
Posts: 569
Joined: Wed Dec 30, 2009 8:14 am
Name: Michael Miday
Contact:

Re: What style is this?

Post by Hanakin » Mon Sep 04, 2017 5:08 pm

you need to completely undo everything from this post viewtopic.php?f=591&t=2434916&start=30#p14816241. in other words revert those classes back to original prosilver classes. that is what is causing the issues with the white space and non-round corners.

as for the search thats more troubling...it seems the class is not being applied for some reason there might be a typo

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Mon Sep 04, 2017 5:32 pm

SalazarAG wrote:
Sat Sep 02, 2017 6:25 pm
Try this

In common.css, find

.page-body {

Replace all class with:

Code: Select all

.page-body {
    margin: 0 auto 0 auto;
    clear: both;
    width: 82%;}
Find .navbar {

and replace all class with:

Code: Select all

.navbar {
margin: 0 auto 0 auto;
width: 80%;
}
Hanakin wrote:
Mon Sep 04, 2017 5:08 pm
you need to completely undo everything from this post viewtopic.php?f=591&t=2434916&start=30#p14816241. in other words revert those classes back to original prosilver classes. that is what is causing the issues with the white space and non-round corners.
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm

also undo everything @SalazarAG instructed you to do

you also removed the wrap class from the wrap div, pls add that back
Hanakin wrote:
Mon Sep 04, 2017 1:45 pm
11. lastly you still have to undo everything from viewtopic.php?f=591&t=2434916&start=30#p14816241

Code: Select all

.page-body {
	margin: 4px 0;
	clear: both;
}

Code: Select all

.navbar {
	padding: 3px 10px;
	border-radius: 7px;
}

User avatar
Mannix_
Registered User
Posts: 153
Joined: Sun Oct 25, 2015 2:56 pm
Contact:

Re: What style is this?

Post by Mannix_ » Mon Sep 04, 2017 5:39 pm

Hanakin wrote:
Mon Sep 04, 2017 5:08 pm
as for the search thats more troubling...it seems the class is not being applied for some reason there might be a typo
the padding for the buttons is messing up the advanced search button to fix it you need to add !important in buttons.css
it should look like this

Code: Select all

.button-search, .button-search-end {
    float: left;
    border-radius: 0;
    margin: 0;
    padding: 2px 5px !important;
}

Code: Select all

.button-search-end {
    border-left-width: 0;
    border-radius: 0 4px 4px 0 !important;
}
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
My CDB contributions . Like my work? Want me to do make a style just for you? PM here or on twitter.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Need some graphics? PM here or on twitter.

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Mon Sep 04, 2017 6:01 pm

Mannix_ wrote:
Mon Sep 04, 2017 5:39 pm
Hanakin wrote:
Mon Sep 04, 2017 5:08 pm
as for the search thats more troubling...it seems the class is not being applied for some reason there might be a typo
the padding for the buttons is messing up the advanced search button to fix it you need to add !important in buttons.css
it should look like this
"Nothing" happened. I'm gonna restore with the original file buttons.css. If got an idea, I'll try again :)
BTW I'm gonna make a clean fresh new phpBB forum + install the ext that I've got on this 1 and gonna do "this style" all over again clean & then I can backup it on the original one. I just don't want/like to mess up the things. Hanakin suggested
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
point 4 I was suggesting to not edit everything into the files that come with prosilver. This is a bad practice. It is best to separate everything that is custom into its own css file to prevent issues when prosilver gets updated. That is what the theme.css file was a new custom file for all the custom css
Seems nice to me, but if you can explain it to me, would be nice !
Hanakin wrote:
Sun Sep 03, 2017 5:41 pm
you also removed the wrap class from the wrap div, pls add that back
Hm?

User avatar
Hanakin
Infrastructure Team Member
Infrastructure Team Member
Posts: 569
Joined: Wed Dec 30, 2009 8:14 am
Name: Michael Miday
Contact:

Re: What style is this?

Post by Hanakin » Mon Sep 04, 2017 9:53 pm

no do not do that never add !important please restore the original button.css

as for all your questions above. you seem to be understanding everything correctly. you have a theme.css file and everything is correct just make one slight change in the theme-topnav.html file.

find the following

Code: Select all

<a href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
	<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
</a>
and change it to

Code: Select all

<button href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
	<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
</button>

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Tue Sep 05, 2017 12:58 am

Hanakin wrote:
Mon Sep 04, 2017 9:53 pm
as for all your questions above. you seem to be understanding everything correctly. you have a theme.css file and everything is correct just make one slight change in the theme-topnav.html file.

find the following

Code: Select all

<a href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
	<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
</a>
and change it to

Code: Select all

<button href="{U_SEARCH}" class="button button-search-end" title="{L_SEARCH_ADV}">
	<i class="icon fa-cog fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH_ADV}</span>
</button>
in navbar_header.html ? got 2x

Code: Select all

								<a href="{U_SEARCH}" role="menuitem">
									<i class="icon fa-search fa-fw" aria-hidden="true"></i><span>{L_SEARCH}</span>
								</a>
&

Code: Select all

		<!-- IF S_DISPLAY_SEARCH and not S_IN_SEARCH -->
			<li class="rightside responsive-search">
				<a href="{U_SEARCH}" title="{L_SEARCH_ADV_EXPLAIN}" role="menuitem">
					<i class="icon fa-search fa-fw" aria-hidden="true"></i><span class="sr-only">{L_SEARCH}</span>
				</a>
			</li>
		<!-- ENDIF -->
Changed 1st, then 2nd, then both...nothing.
Btw Login a_n_d Register are a bit far away from each other ;d

User avatar
Hanakin
Infrastructure Team Member
Infrastructure Team Member
Posts: 569
Joined: Wed Dec 30, 2009 8:14 am
Name: Michael Miday
Contact:

Re: What style is this?

Post by Hanakin » Tue Sep 05, 2017 3:29 pm

I have no idea what you are talking about or referring to...I never said anything about navbar_header.html!

I said theme-topnav.html

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Tue Sep 05, 2017 10:09 pm

Hanakin wrote:
Tue Sep 05, 2017 3:29 pm
I said theme-topnav.html
I can't find it. Where should it be?

User avatar
Hanakin
Infrastructure Team Member
Infrastructure Team Member
Posts: 569
Joined: Wed Dec 30, 2009 8:14 am
Name: Michael Miday
Contact:

Re: What style is this?

Post by Hanakin » Wed Sep 06, 2017 1:46 am

It's the only a tag in the search div! It's probably not coded correctly which is why you can not find it! Without seeing you exact files I can not say. It has the class button-search-end on it

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Wed Sep 06, 2017 12:54 pm

I can't figure it out...
How can I help you to help me?

User avatar
Hanakin
Infrastructure Team Member
Infrastructure Team Member
Posts: 569
Joined: Wed Dec 30, 2009 8:14 am
Name: Michael Miday
Contact:

Re: What style is this?

Post by Hanakin » Wed Sep 06, 2017 5:02 pm

Post the contents of that file on here 😉

User avatar
fliper4o
Registered User
Posts: 215
Joined: Wed Mar 23, 2011 8:15 pm
Contact:

Re: What style is this?

Post by fliper4o » Fri Sep 08, 2017 3:07 pm

Hanakin wrote:
Wed Sep 06, 2017 5:02 pm
Post the contents of that file on here 😉
fliper4o wrote:
Tue Sep 05, 2017 10:09 pm
Hanakin wrote:
Tue Sep 05, 2017 3:29 pm
I said theme-topnav.html
I can't find it. Where should it be?
Maybe I will dump my forum files or a specific path, somewhere so somebody can take a look of what files I've got & what is inside 'em. :)
Thank you for your effort, fella.

Post Reply

Return to “[3.2.x] Styles Support & Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests